mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Steve Wise <swise@opengridcomputing.com>
To: Roland Dreier <rdreier@cisco.com>
Cc: Stephen Hemminger <shemminger@osdl.org>, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 1/2] iWARP Connection Manager.
Date: Wed, 31 May 2006 15:58:00 -0500	[thread overview]
Message-ID: <1149109080.7469.15.camel@stevo-desktop> (raw)
In-Reply-To: <ada3beqyp39.fsf@cisco.com>

On Wed, 2006-05-31 at 12:24 -0700, Roland Dreier wrote:
> > > +	cm_id_priv = kzalloc(sizeof *cm_id_priv, GFP_KERNEL);
> 
> > Please put paren's after sizeof, it is not required by C but it
> > is easier to read.
> 
> I disagree -- I hate seeing sizeof look like a function call.
> 

For the most part, drivers/infiniband/core uses sizeof without
parentheses.  So I think the correct answer here is to keep the iwcm.c
file in line with the rest of the core.


Steve.




  parent reply	other threads:[~2006-05-31 20:58 UTC|newest]

Thread overview: 20+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2006-05-31 18:26 [PATCH 0/2][RFC] iWARP Core Support Steve Wise
2006-05-31 18:26 ` [PATCH 1/2] iWARP Connection Manager Steve Wise
2006-05-31 18:40   ` Stephen Hemminger
2006-05-31 19:24     ` Roland Dreier
2006-05-31 20:47       ` Muli Ben-Yehuda
2006-05-31 20:58       ` Steve Wise [this message]
2006-05-31 21:01         ` Stephen Hemminger
2006-05-31 21:54           ` Roland Dreier
2006-05-31 22:22             ` Steve Wise
2006-05-31 22:22   ` Sean Hefty
2006-06-01 17:00     ` Steve Wise
2006-06-01 21:09       ` Sean Hefty
2006-06-01 22:21         ` [openib-general] " Tom Tucker
2006-06-01 17:11     ` Tom Tucker
2006-05-31 18:26 ` [PATCH 2/2] iWARP Core Changes Steve Wise
2006-05-31 18:36   ` Stephen Hemminger
2006-05-31 19:17   ` Roland Dreier
2006-05-31 20:30     ` Steve Wise
2006-05-31 20:32       ` Roland Dreier
2006-05-31 21:26   ` Sean Hefty

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1149109080.7469.15.camel@stevo-desktop \
    --to=swise@opengridcomputing.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=rdreier@cisco.com \
    --cc=shemminger@osdl.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®