From: Kay Sievers <kay.sievers@vrfy.org>
To: Cornelia Huck <cornelia.huck@de.ibm.com>
Cc: linux-kernel <linux-kernel@vger.kernel.org>,
Andrew Morton <akpm@osdl.org>, Greg K-H <greg@kroah.com>,
Martin Schwidefsky <schwidefsky@de.ibm.com>
Subject: Re: [Patch -mm 2/2] driver core: Introduce device_move(): move a device to a new parent.
Date: Thu, 16 Nov 2006 17:47:37 +0100 [thread overview]
Message-ID: <1163695657.7900.9.camel@min.off.vrfy.org> (raw)
In-Reply-To: <20061116154210.217f2e04@gondolin.boeblingen.de.ibm.com>
On Thu, 2006-11-16 at 15:42 +0100, Cornelia Huck wrote:
> From: Cornelia Huck <cornelia.huck@de.ibm.com>
>
> Provide a function device_move() to move a device to a new parent device. Add
> auxilliary functions kobject_move() and sysfs_move_dir().
> kobject_move() generates a new uevent of type KOBJ_MOVE, containing the
> previous path (OLD_DEVPATH) in addition to the usual values.
> + sprintf(devpath_string, "OLD_DEVPATH=%s", devpath);
I think it's easier to understand, if the variable starts with the same
string as original name. I prefer DEVPATH_OLD.
> +void kobject_uevent_extended(struct kobject *kobj, enum kobject_action action,
> + const char *string)
I think we should pass an array of env vars here instead of a single
string - you never know ... :) The function could probably be named
kobject_uevent_env() then.
Thanks,
Kay
next prev parent reply other threads:[~2006-11-16 16:48 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2006-11-16 14:42 Cornelia Huck
2006-11-16 16:47 ` Kay Sievers [this message]
2006-11-17 4:23 ` Greg KH
2006-11-20 8:05 ` Cornelia Huck
2006-11-20 12:55 ` [Patch -mm 1/1] " Cornelia Huck
2006-11-20 14:15 ` Kay Sievers
2006-11-20 15:39 ` Cornelia Huck
2006-11-20 16:07 ` Cornelia Huck
2006-11-20 22:42 ` Kay Sievers
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1163695657.7900.9.camel@min.off.vrfy.org \
--to=kay.sievers@vrfy.org \
--cc=akpm@osdl.org \
--cc=cornelia.huck@de.ibm.com \
--cc=greg@kroah.com \
--cc=linux-kernel@vger.kernel.org \
--cc=schwidefsky@de.ibm.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®