From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S932765AbbBPN1d (ORCPT ); Mon, 16 Feb 2015 08:27:33 -0500 Received: from smtp5-g21.free.fr ([212.27.42.5]:17398 "EHLO smtp5-g21.free.fr" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S932275AbbBPN1c convert rfc822-to-8bit (ORCPT ); Mon, 16 Feb 2015 08:27:32 -0500 Date: Mon, 16 Feb 2015 14:27:28 +0100 (CET) From: robert.jarzmik@free.fr To: Lee Jones Cc: Rob Herring , Pawel Moll , Mark Rutland , Ian Campbell , Kumar Gala , Daniel Mack , Haojian Zhuang , Samuel Ortiz , Grant Likely , devicetree@vger.kernel.org, linux-kernel@vger.kernel.org, linux-arm-kernel@lists.infradead.org, Arnd Bergmann , Russell King - ARM Linux , Dmitry Eremin-Solenikov Message-ID: <1170550770.470129293.1424093248596.JavaMail.root@zimbra1-e1.priv.proxad.net> In-Reply-To: <20150216130549.GF14545@x1> Subject: Re: [PATCH v4 2/4] mfd: lubbock_cplds: add lubbock IO board MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: 8BIT X-Originating-IP: [192.198.151.43] X-Mailer: Zimbra 7.2.0-GA2598 (ZimbraWebClient - GC31 (Linux)/7.2.0-GA2598) X-Authenticated-User: robert.jarzmik@free.fr Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org ----- Mail original ----- De: "Lee Jones" À: "Robert Jarzmik" Cc: "Rob Herring" , "Pawel Moll" , "Mark Rutland" , "Ian Campbell" , "Kumar Gala" , "Daniel Mack" , "Haojian Zhuang" , "Samuel Ortiz" , "Grant Likely" , devicetree@vger.kernel.org, linux-kernel@vger.kernel.org, linux-arm-kernel@lists.infradead.org, "Arnd Bergmann" , "Russell King - ARM Linux" , "Dmitry Eremin-Solenikov" Envoyé: Lundi 16 Février 2015 14:05:49 Objet: Re: [PATCH v4 2/4] mfd: lubbock_cplds: add lubbock IO board On Sat, 24 Jan 2015, Robert Jarzmik wrote: > --- > Since v1: change the name from cottula to lubbock_io > Dmitry pointed out the Cottula was the pxa25x family name, > lubbock was the pxa25x development board name. Therefore the > name was changed to lubbock_io (lubbock IO board) > Are you sure this is what you want to do? We don't usually support > 'boards' per say. Instead we support 'devices', then pull each of > those devices together using some h/w description mechanism. Do you know that : 1) anything under "---" in a commit message is thrown away 2) after v2, we _both_ agreed that the accurate name is "cplds" which exactly what is in this patch (see device registering with lubbock_cplds). 3) there is no more mention of "board" anywhere in the patch core > Besides, this is MFD, where we support single pieces of silicon which > happen to support multiple devices. I definitely don't want to support > boards here. > You might want to re-think the naming and your (sales) pitch. I might need help. As for the (sales), no comment. >> +#include > Why have you included this? I don't see the use of the MFD framework > anywhere. So what makes this an MFD? I thought cplds were to be handled by an MFD driver. > I'm going to stop here, as I think I need more of an explanation so > what you're trying to achieve with this driver. Why ? I think things were clear that this driver handles the CPLDs on lubbock board, namely u46 and u52. I don't understand what is wrong with this patch so that you don't want to go forward. -- Robert