From: Bernd Petrovitsch <bernd@firmix.at>
To: Nick Piggin <nickpiggin@yahoo.com.au>
Cc: Joe Perches <joe@perches.com>,
Ben Nizette <ben.nizette@iinet.net.au>,
linux-kernel@vger.kernel.org
Subject: Re: Coding style RFC: convert "for (i=0;i<ARRAY_SIZE(array);i++)" to "array_for_each(index, array)"
Date: Tue, 13 Feb 2007 12:07:48 +0100 [thread overview]
Message-ID: <1171364868.21261.20.camel@tara.firmix.at> (raw)
In-Reply-To: <45D198DB.3040006@yahoo.com.au>
On Tue, 2007-02-13 at 21:54 +1100, Nick Piggin wrote:
> Bernd Petrovitsch wrote:
> > On Tue, 2007-02-13 at 18:42 +1100, Nick Piggin wrote:
> >
> >>Joe Perches wrote:
> >
> > [...]
> >
> >>>perhaps:
> >>>
> >>>#define array_for_each(element, array) \
> >>> for ((element) = (array); \
> >>> (element) < ((array) + ARRAY_SIZE((array))); \
> >>> (element)++)
> >>
> >>If you're going for consistency, then shouldn't this be
> >>array_for_each_entry()?
> >
> >
> > That depends on the decision between consistency to array_for_each_index
> > or consistency to list_for_each.
>
> I don't follow.
Yes, thinko on my side. Sorry.
> list_for_each gives you a list_head.
> list_for_each_entry gives you a pointer to an entry in the list, which
> is equivalent to the above loop which gives a pointer to an entry in the
> array. Accordingly, it should be called array_for_each_entry. What sort
> of logic leads to another conclusion?
The wrong logic that list_for_each gives an entry. Sorry f.t. confusion.
Bernd
--
Firmix Software GmbH http://www.firmix.at/
mobil: +43 664 4416156 fax: +43 1 7890849-55
Embedded Linux Development and Services
next prev parent reply other threads:[~2007-02-13 11:07 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2007-02-12 23:47 Joe Perches
2007-02-13 0:20 ` Ben Nizette
2007-02-13 0:47 ` Joe Perches
2007-02-13 4:19 ` Nick Piggin
2007-02-13 7:34 ` Joe Perches
2007-02-13 7:42 ` Nick Piggin
2007-02-13 10:36 ` Bernd Petrovitsch
2007-02-13 10:54 ` Nick Piggin
2007-02-13 11:07 ` Bernd Petrovitsch [this message]
2007-02-13 7:37 ` Muli Ben-Yehuda
2007-02-13 16:28 ` Randy Dunlap
2007-02-13 7:48 ` YOSHIFUJI Hideaki / 吉藤英明
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1171364868.21261.20.camel@tara.firmix.at \
--to=bernd@firmix.at \
--cc=ben.nizette@iinet.net.au \
--cc=joe@perches.com \
--cc=linux-kernel@vger.kernel.org \
--cc=nickpiggin@yahoo.com.au \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®