From: "Noèl Köthe" <noel@debian.org>
To: Jiri Kosina <jikos@jikos.cz>
Cc: linux-usb-devel@lists.sourceforge.net, linux-kernel@vger.kernel.org
Subject: Re: [PATCH] kernel option CONFIG_USB_HIDINPUT_POWERBOOK description update
Date: Mon, 07 May 2007 21:17:21 +0200 [thread overview]
Message-ID: <1178565441.4813.22.camel@mbp.domain.lan> (raw)
In-Reply-To: <Pine.LNX.4.64.0705030951520.16923@twin.jikos.cz>
[-- Attachment #1: Type: text/plain, Size: 1592 bytes --]
Am Donnerstag, den 03.05.2007, 09:56 +0200 schrieb Jiri Kosina:
Hello Jiri,
> > The description of this option needs to be extended to be correct:)
> > config USB_HIDINPUT_POWERBOOK
> > - bool "Enable support for iBook/PowerBook special keys"
> > + bool "Enable support for iBook/PowerBook/MacBook/MacBookPro special keys"
> I will apply this into my tree, thanks.
Great thanks. Does this mean it will go into your tree and then into the
mainline kernel, or is there an additional step needed?
> > This option is needed on the Apple Intel Laptops, too. I would suggest
> > to rename USB_HIDINPUT_POWERBOOK because its needed on Apple Laptops.
> > Maybe USB_HIDINPUT_APPLELAPTOPS or something like this. Is a renaming
> > patch for this welcome?
>
> The problem here is backwards compatibility - if we would like to do the
> change in a consistent way, we should rename all the places which (for
> historic reasons) mention powerbook only. Unfortunately this would also
> require renaming the module parameter hid_pb_fnmode, which might be a
> little too intrusive with respect to maintaining backward compatibility in
> userspace (ok, we have already been fiddling with this parameter anyway
> during the usbhid code split, but anyway).
>
> If you would care to make the patch which maintains backwards
> compatibility (for example by aliasing the variable pb_fnmode behing two
> module parameters), that might probably be ok.
I understand. I will try.
--
Noèl Köthe <noel debian.org>
Debian GNU/Linux, www.debian.org
[-- Attachment #2: Dies ist ein digital signierter Nachrichtenteil --]
[-- Type: application/pgp-signature, Size: 189 bytes --]
next prev parent reply other threads:[~2007-05-07 19:24 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2007-05-02 15:00 Noèl Köthe
2007-05-03 7:56 ` Jiri Kosina
2007-05-07 19:17 ` Noèl Köthe [this message]
2007-05-07 21:36 ` Jiri Kosina
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1178565441.4813.22.camel@mbp.domain.lan \
--to=noel@debian.org \
--cc=jikos@jikos.cz \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-usb-devel@lists.sourceforge.net \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®