mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: David Woodhouse <dwmw2@infradead.org>
To: Alan Cox <alan@lxorguk.ukuu.org.uk>
Cc: Andi Kleen <ak@suse.de>, David Howells <dhowells@redhat.com>,
	Arnd Bergmann <arnd@arndb.de>,
	Benjamin Herrenschmidt <benh@kernel.crashing.org>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	Dave Airlie <airlied@linux.ie>,
	linux-arch@vger.kernel.org,
	Andrew Morton <akpm@linux-foundation.org>
Subject: Re: [PATCH] Introduce compat_u64 and compat_s64 types
Date: Fri, 15 Jun 2007 14:00:06 +0100	[thread overview]
Message-ID: <1181912406.25228.491.camel@pmac.infradead.org> (raw)
In-Reply-To: <20070615135420.7fe2e4c1@the-village.bc.nu>

On Fri, 2007-06-15 at 13:54 +0100, Alan Cox wrote:
> For the parts used by the processors in question yes people have done
> that work so using the types without unaligned.

I still think we could use a 'get_maybe_but_probably_not_unaligned()',
although it could have a better name.

People now use get_unaligned() for two reasons -- firstly because we
_expect_ something to be unaligned, and we get a performance improvement
if we just emit code to directly handle that instead of taking the trap.
And more recently we've also started to use it because there's a
_slight_ chance it could be unaligned, and some architectures can't
cope.

Where the unalignment is possible but unlikely, many architectures
probably shouldn't be emitting code to cope with it; they should just
take the trap in the rare case.

In fact, the probability threshold at which it makes sense to just take
the trap will vary from architecture to architecture. We should probably
just have a get_probably_unaligned(...) macro which has its first arg as
an _estimated_ constant probability. Then the architecture code could
emit what it likes according to the probability.

-- 
dwmw2


  parent reply	other threads:[~2007-06-15 13:00 UTC|newest]

Thread overview: 35+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <200706150159.l5F1xNgM000459@hera.kernel.org>
2007-06-15  8:44 ` drm: fix radeon setparam on 32/64 bit systems David Woodhouse
2007-06-15  8:58   ` Benjamin Herrenschmidt
2007-06-15  9:28     ` Arnd Bergmann
2007-06-15  9:31       ` [PATCH] Introduce compat_u64 and compat_s64 types Arnd Bergmann
2007-06-15  9:55         ` David Miller
2007-06-15 11:55         ` Andi Kleen
2007-06-15 12:00           ` David Woodhouse
2007-06-15 12:38             ` Andi Kleen
2007-06-15 12:03           ` Arnd Bergmann
2007-06-15 12:40             ` Andi Kleen
2007-06-15 12:47               ` David Woodhouse
2007-06-15 13:19               ` Benjamin Herrenschmidt
2007-06-15 12:09         ` David Howells
2007-06-15 12:43           ` Andi Kleen
2007-06-15 12:54             ` Alan Cox
2007-06-15 12:54               ` Andi Kleen
2007-06-15 13:15                 ` Alan Cox
2007-06-15 13:27                   ` Andi Kleen
2007-06-15 13:32                     ` David Woodhouse
2007-06-15 20:50                 ` Robin Getz
2007-06-15 21:22                   ` Andi Kleen
2007-06-16  8:31                     ` David Woodhouse
2007-06-15 13:00               ` David Woodhouse [this message]
2007-06-15 12:11         ` Matthew Wilcox
2007-06-15 12:38           ` David Woodhouse
2007-06-15 12:42           ` Arnd Bergmann
2007-06-15 13:45             ` Matthew Wilcox
2007-06-15 13:52               ` Arnd Bergmann
2007-06-15 23:54               ` Benjamin Herrenschmidt
2007-06-15 13:16         ` Benjamin Herrenschmidt
2007-06-16  9:38         ` David Woodhouse
2007-06-16 10:26           ` Arnd Bergmann
2007-06-16 11:21             ` Arnd Bergmann
2007-06-16 11:34               ` David Woodhouse
2007-06-16 13:56                 ` Matthew Wilcox

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1181912406.25228.491.camel@pmac.infradead.org \
    --to=dwmw2@infradead.org \
    --cc=airlied@linux.ie \
    --cc=ak@suse.de \
    --cc=akpm@linux-foundation.org \
    --cc=alan@lxorguk.ukuu.org.uk \
    --cc=arnd@arndb.de \
    --cc=benh@kernel.crashing.org \
    --cc=dhowells@redhat.com \
    --cc=linux-arch@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®