From: Bryan Wu <bryan.wu@analog.com>
To: Yoann Padioleau <padator@wanadoo.fr>
Cc: kernel-janitors@vger.kernel.org, aubrey.li@analog.com,
bryan.wu@analog.com, akpm@linux-foundation.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH 04/68] 0 -> NULL, for arch/blackfin
Date: Fri, 27 Jul 2007 18:23:44 +0800 [thread overview]
Message-ID: <1185531824.11601.25.camel@roc-desktop> (raw)
In-Reply-To: <200707270944.LAA17116@ifs.emn.fr>
On Fri, 2007-07-27 at 11:44 +0200, Yoann Padioleau wrote:
> When comparing a pointer, it's clearer to compare it to NULL than to 0.
>
> Here is an excerpt of the semantic patch:
>
> @@
> expression *E;
> @@
>
> E ==
> - 0
> + NULL
>
> @@
> expression *E;
> @@
>
> E !=
> - 0
> + NULL
>
> Signed-off-by: Yoann Padioleau <padator@wanadoo.fr>
> Cc: aubrey.li@analog.com
> Cc: bryan.wu@analog.com
> Cc: akpm@linux-foundation.org
> ---
>
> traps.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/arch/blackfin/kernel/traps.c b/arch/blackfin/kernel/traps.c
> index 3909f5b..691c66d 100644
> --- a/arch/blackfin/kernel/traps.c
> +++ b/arch/blackfin/kernel/traps.c
> @@ -546,7 +546,7 @@ void dump_bfin_regs(struct pt_regs *fp,
> }
>
> printk(KERN_EMERG "return address: [0x%p]; contents of:", retaddr);
> - if (retaddr != 0 && retaddr <= (void *)physical_mem_end
> + if (retaddr != NULL && retaddr <= (void *)physical_mem_end
> #if L1_CODE_LENGTH != 0
> /* FIXME: Copy the code out of L1 Instruction SRAM through dma
> memcpy. */
Why not just use " if (!E)" instead of " if (E != NULL)"?
more readable?
Thanks
- Bryan Wu
next prev parent reply other threads:[~2007-07-27 10:16 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2007-07-27 9:44 Yoann Padioleau
2007-07-27 10:23 ` Bryan Wu [this message]
2007-07-27 13:17 ` Uli Luckas
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1185531824.11601.25.camel@roc-desktop \
--to=bryan.wu@analog.com \
--cc=akpm@linux-foundation.org \
--cc=aubrey.li@analog.com \
--cc=kernel-janitors@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=padator@wanadoo.fr \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®