mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Daniel Walker <dwalker@mvista.com>
To: Steven Rostedt <rostedt@goodmis.org>
Cc: Remy Bohmer <linux@bohmer.net>, Ingo Molnar <mingo@elte.hu>,
	LKML <linux-kernel@vger.kernel.org>,
	RT <linux-rt-users@vger.kernel.org>,
	Thomas Gleixner <tglx@linutronix.de>
Subject: Re: [RT] seqlocks: use of PICK_FUNCTION breaks kernel compile when CONFIG_GENERIC_TIME is NOT set
Date: Wed, 17 Oct 2007 08:24:05 -0700	[thread overview]
Message-ID: <1192634645.17527.134.camel@imap.mvista.com> (raw)
In-Reply-To: <1192633836.8265.6.camel@localhost.localdomain>

On Wed, 2007-10-17 at 11:10 -0400, Steven Rostedt wrote:

> > >  
> > >  #define read_seqbegin_irqsave(lock, flags)			\
> > > -do {								\
> > > +({								\
> > >  	flags = PICK_SEQ_OP_RET(__read_seqbegin_irqsave_raw,	\
> > >  		__read_seqbegin_irqsave, lock);			\
> > > -} while (0)
> > > +	read_seqbegin(lock);					\
> > > +})
> 
> Yes, definitely the raw and unraw functions should be called
> local_irqsave_raw or something else that makes this obvious to what it
> is doing.

Hmm.. I'm not sure what else to name them .. Since it's in the seqlock.h
I don't think it should be called anything "local_irq*" .. It could be
seq_irqsave_{raw} . 

Daniel


  reply	other threads:[~2007-10-17 15:26 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <1192632502.17527.129.camel@imap.mvista.com>
2007-10-17 15:10 ` Steven Rostedt
2007-10-17 15:24   ` Daniel Walker [this message]
2007-10-17 15:34     ` Steven Rostedt
2007-10-22 18:53       ` Daniel Walker
2007-10-16  8:35 Remy Bohmer
2007-10-16 16:52 ` Daniel Walker
2007-10-17 14:07   ` Remy Bohmer

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1192634645.17527.134.camel@imap.mvista.com \
    --to=dwalker@mvista.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-rt-users@vger.kernel.org \
    --cc=linux@bohmer.net \
    --cc=mingo@elte.hu \
    --cc=rostedt@goodmis.org \
    --cc=tglx@linutronix.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®