From: Matt Mackall <mpm@selenic.com>
To: Arjan van de Ven <arjan@linux.intel.com>
Cc: linux-kernel@vger.kernel.org, Ingo Molnar <mingo@elte.hu>,
Andrew Morton <akpm@linux-foundation.org>
Subject: Re: [patch 1/3] move WARN_ON() out of line
Date: Wed, 02 Jan 2008 19:59:29 -0600 [thread overview]
Message-ID: <1199325569.4497.116.camel@cinder.waste.org> (raw)
In-Reply-To: <477C32DA.5060905@linux.intel.com>
On Thu, 2008-01-03 at 01:56 +0100, Arjan van de Ven wrote:
> Subject: move WARN_ON() out of line
> From: Arjan van de Ven <arjan@linux.intel.com>
> CC: Ingo Molnar <mingo@elte.hu>
> CC: Andrew Morton <akpm@linux-foundation.org>
>
> A quick grep shows that there are currently 1145 instances of WARN_ON
> in the kernel. Currently, WARN_ON is pretty much entirely inlined,
> which makes it hard to enhance it without growing the size of the kernel
> (and getting Andrew unhappy).
>
> This patch moves WARN_ON() out of line entirely. I've considered keeping
> the test inline and moving only the slowpath out of line, but I decided
> against that: an out of line test reduces the pressure on the CPUs
> branch predictor logic and gives smaller code, while a function call
> to a fixed location is quite fast. Likewise I've considered doing something
> similar to BUG() (eg use a trapping instruction) but that's not really
> better (it needs the test inline again and recovering from an invalid
> instruction isn't quite fun).
>
> The code size reduction of this patch was about 6.5Kb (on a distro style
> .config):
>
> text data bss dec hex filename
> 3096493 293455 2760704 6150652 5dd9fc vmlinux.before
> 3090006 293455 2760704 6144165 5dc0a5 vmlinux.after
>
> Signed-off-by: Arjan van de Ven <arjan@linux.intel.com>
I hate the do_foo naming scheme (how about __warn_on?), but otherwise:
Acked-by: Matt Mackall <mpm@selenic.com>
> + printk(KERN_WARNING "WARNING: at %s:%d %s()\n",
> + __FILE__, __LINE__, __FUNCTION__);
> + dump_stack();
While we're here, I'll mention that dump_stack probably ought to take a
severity level argument.
--
Mathematics is the supreme nostalgia of our time.
next prev parent reply other threads:[~2008-01-03 2:03 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2008-01-03 0:56 Arjan van de Ven
2008-01-03 1:59 ` Matt Mackall [this message]
2008-01-03 21:06 ` Arjan van de Ven
2008-01-05 2:35 ` Herbert Xu
2008-01-05 18:33 ` Arjan van de Ven
2008-01-03 4:58 ` Olof Johansson
2008-01-03 21:03 ` Arjan van de Ven
2008-01-03 9:25 ` Ingo Molnar
2008-01-03 16:22 ` Arjan van de Ven
2008-01-05 6:42 ` Jeremy Fitzhardinge
2008-01-03 11:20 ` Pekka Enberg
2008-01-05 5:09 ` Dmitri Vorobiev
2008-01-05 6:41 ` Jeremy Fitzhardinge
2008-01-05 18:01 ` Arjan van de Ven
2008-01-05 18:08 ` Arjan van de Ven
2008-01-05 18:37 ` Arjan van de Ven
2008-01-05 18:45 ` Jeremy Fitzhardinge
2008-01-05 20:02 ` Arjan van de Ven
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1199325569.4497.116.camel@cinder.waste.org \
--to=mpm@selenic.com \
--cc=akpm@linux-foundation.org \
--cc=arjan@linux.intel.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@elte.hu \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®