From: Joerg Roedel <joerg.roedel@amd.com>
To: mingo@redhat.com, tglx@linutronix.de
Cc: linux-kernel@vger.kernel.org, iommu@lists.linux-foundation.org,
bhavna.sarathy@amd.com, robert.richter@amd.com,
Joerg Roedel <joerg.roedel@amd.com>
Subject: [PATCH 09/16] AMD IOMMU: rename struct command to iommu_cmd
Date: Fri, 11 Jul 2008 17:14:28 +0200 [thread overview]
Message-ID: <1215789275-20975-10-git-send-email-joerg.roedel@amd.com> (raw)
In-Reply-To: <1215789275-20975-1-git-send-email-joerg.roedel@amd.com>
This patch gives the struct command a more descriptive and not so generic name.
Signed-off-by: Joerg Roedel <joerg.roedel@amd.com>
---
arch/x86/kernel/amd_iommu.c | 12 ++++++------
1 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/arch/x86/kernel/amd_iommu.c b/arch/x86/kernel/amd_iommu.c
index 7fa2d5d..dec10e1 100644
--- a/arch/x86/kernel/amd_iommu.c
+++ b/arch/x86/kernel/amd_iommu.c
@@ -39,7 +39,7 @@ static DEFINE_RWLOCK(amd_iommu_devtable_lock);
/*
* general struct to manage commands send to an IOMMU
*/
-struct command {
+struct iommu_cmd {
u32 data[4];
};
@@ -62,7 +62,7 @@ static int iommu_has_npcache(struct amd_iommu *iommu)
* Writes the command to the IOMMUs command buffer and informs the
* hardware about the new command. Must be called with iommu->lock held.
*/
-static int __iommu_queue_command(struct amd_iommu *iommu, struct command *cmd)
+static int __iommu_queue_command(struct amd_iommu *iommu, struct iommu_cmd *cmd)
{
u32 tail, head;
u8 *target;
@@ -83,7 +83,7 @@ static int __iommu_queue_command(struct amd_iommu *iommu, struct command *cmd)
* General queuing function for commands. Takes iommu->lock and calls
* __iommu_queue_command().
*/
-static int iommu_queue_command(struct amd_iommu *iommu, struct command *cmd)
+static int iommu_queue_command(struct amd_iommu *iommu, struct iommu_cmd *cmd)
{
unsigned long flags;
int ret;
@@ -105,7 +105,7 @@ static int iommu_queue_command(struct amd_iommu *iommu, struct command *cmd)
static int iommu_completion_wait(struct amd_iommu *iommu)
{
int ret;
- struct command cmd;
+ struct iommu_cmd cmd;
volatile u64 ready = 0;
unsigned long ready_phys = virt_to_phys(&ready);
unsigned long i = 0;
@@ -139,7 +139,7 @@ static int iommu_completion_wait(struct amd_iommu *iommu)
*/
static int iommu_queue_inv_dev_entry(struct amd_iommu *iommu, u16 devid)
{
- struct command cmd;
+ struct iommu_cmd cmd;
BUG_ON(iommu == NULL);
@@ -158,7 +158,7 @@ static int iommu_queue_inv_dev_entry(struct amd_iommu *iommu, u16 devid)
static int iommu_queue_inv_iommu_pages(struct amd_iommu *iommu,
u64 address, u16 domid, int pde, int s)
{
- struct command cmd;
+ struct iommu_cmd cmd;
memset(&cmd, 0, sizeof(cmd));
address &= PAGE_MASK;
--
1.5.3.7
next prev parent reply other threads:[~2008-07-11 15:18 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2008-07-11 15:14 [PATCH 0/16] AMD IOMMU updates Joerg Roedel
2008-07-11 15:14 ` [PATCH 01/16] AMD IOMMU: add comments to amd_iommu_types.h Joerg Roedel
2008-07-11 15:14 ` [PATCH 02/16] AMD IOMMU: add comments to the initialization code Joerg Roedel
2008-07-11 15:14 ` [PATCH 03/16] AMD IOMMU: add comments to core code Joerg Roedel
2008-07-11 15:14 ` [PATCH 04/16] AMD IOMMU: replace HIGH_U32 macro with upper_32_bits function Joerg Roedel
2008-07-11 15:14 ` [PATCH 05/16] AMD IOMMU: replace UPDATE_LAST_BDF macro with a function Joerg Roedel
2008-07-11 15:14 ` [PATCH 06/16] AMD IOMMU: replace TBL_SIZE " Joerg Roedel
2008-07-11 15:14 ` [PATCH 07/16] AMD IOMMU: remove unnecessary free checks from init code Joerg Roedel
2008-07-11 15:14 ` [PATCH 08/16] AMD IOMMU: add an emergency exit to the completion wait loop Joerg Roedel
2008-07-11 15:14 ` Joerg Roedel [this message]
2008-07-11 15:14 ` [PATCH 10/16] AMD IOMMU: remove unneeded initializations from command buffer allocation Joerg Roedel
2008-07-11 15:14 ` [PATCH 11/16] AMD IOMMU: use true/false instead of 0/1 for bool value Joerg Roedel
2008-07-11 15:14 ` [PATCH 12/16] AMD IOMMU: do runtime list initialization at compile time Joerg Roedel
2008-07-11 15:14 ` [PATCH 13/16] AMD IOMMU: replace memset with __GFP_ZERO for table allocation Joerg Roedel
2008-07-11 15:14 ` [PATCH 14/16] AMD IOMMU: replace self made size parsing with memparse call Joerg Roedel
2008-07-11 15:14 ` [PATCH 15/16] AMD IOMMU: fix device table entry size Joerg Roedel
2008-07-11 15:14 ` [PATCH 16/16] AMD IOMMU: replace DEVID macro with a function Joerg Roedel
2008-07-11 16:01 ` [PATCH 0/16] AMD IOMMU updates Ingo Molnar
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1215789275-20975-10-git-send-email-joerg.roedel@amd.com \
--to=joerg.roedel@amd.com \
--cc=bhavna.sarathy@amd.com \
--cc=iommu@lists.linux-foundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=robert.richter@amd.com \
--cc=tglx@linutronix.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®