From: Greg Kroah-Hartman <gregkh@suse.de>
To: linux-kernel@vger.kernel.org
Cc: Matthew Wilcox <matthew@wil.cx>,
Kay Sievers <kay.sievers@vrfy.org>,
Dave Young <hidave.darkstar@gmail.com>,
Andrew Morton <akpm@linux-foundation.org>,
James Bottomley <James.Bottomley@HansenPartnership.com>,
Peter Zijlstra <peterz@infradead.org>,
Ingo Molnar <mingo@elte.hu>, Greg Kroah-Hartman <gregkh@suse.de>
Subject: [PATCH 49/79] class: add lockdep infrastructure
Date: Mon, 21 Jul 2008 22:19:13 -0700 [thread overview]
Message-ID: <1216703983-21448-49-git-send-email-gregkh@suse.de> (raw)
In-Reply-To: <20080722051805.GA17373@suse.de>
From: Matthew Wilcox <matthew@wil.cx>
This adds the infrastructure to properly handle lockdep issues when the
internal class semaphore is changed to a mutex.
Matthew wrote the original patch, and Greg fixed it up to work properly
with the class_create() function.
From: Matthew Wilcox <matthew@wil.cx>
Cc: Kay Sievers <kay.sievers@vrfy.org>
Cc: Dave Young <hidave.darkstar@gmail.com>
Cc: Andrew Morton <akpm@linux-foundation.org>
Cc: James Bottomley <James.Bottomley@HansenPartnership.com>
Cc: Peter Zijlstra <peterz@infradead.org>
Cc: Ingo Molnar <mingo@elte.hu>
Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
---
drivers/base/class.c | 11 ++++++-----
include/linux/device.h | 25 +++++++++++++++++++++++--
2 files changed, 29 insertions(+), 7 deletions(-)
diff --git a/drivers/base/class.c b/drivers/base/class.c
index d24d211..8900056 100644
--- a/drivers/base/class.c
+++ b/drivers/base/class.c
@@ -134,7 +134,7 @@ static void remove_class_attrs(struct class *cls)
}
}
-int class_register(struct class *cls)
+int __class_register(struct class *cls, struct lock_class_key *key)
{
struct class_private *cp;
int error;
@@ -178,6 +178,7 @@ int class_register(struct class *cls)
class_put(cls);
return error;
}
+EXPORT_SYMBOL_GPL(__class_register);
void class_unregister(struct class *cls)
{
@@ -203,7 +204,8 @@ static void class_create_release(struct class *cls)
* Note, the pointer created here is to be destroyed when finished by
* making a call to class_destroy().
*/
-struct class *class_create(struct module *owner, const char *name)
+struct class *__class_create(struct module *owner, const char *name,
+ struct lock_class_key *key)
{
struct class *cls;
int retval;
@@ -218,7 +220,7 @@ struct class *class_create(struct module *owner, const char *name)
cls->owner = owner;
cls->class_release = class_create_release;
- retval = class_register(cls);
+ retval = __class_register(cls, key);
if (retval)
goto error;
@@ -228,6 +230,7 @@ error:
kfree(cls);
return ERR_PTR(retval);
}
+EXPORT_SYMBOL_GPL(__class_create);
/**
* class_destroy - destroys a struct class structure
@@ -412,9 +415,7 @@ int __init classes_init(void)
EXPORT_SYMBOL_GPL(class_create_file);
EXPORT_SYMBOL_GPL(class_remove_file);
-EXPORT_SYMBOL_GPL(class_register);
EXPORT_SYMBOL_GPL(class_unregister);
-EXPORT_SYMBOL_GPL(class_create);
EXPORT_SYMBOL_GPL(class_destroy);
EXPORT_SYMBOL_GPL(class_interface_register);
diff --git a/include/linux/device.h b/include/linux/device.h
index b055608..0e1d24c 100644
--- a/include/linux/device.h
+++ b/include/linux/device.h
@@ -16,6 +16,7 @@
#include <linux/kobject.h>
#include <linux/klist.h>
#include <linux/list.h>
+#include <linux/lockdep.h>
#include <linux/compiler.h>
#include <linux/types.h>
#include <linux/module.h>
@@ -205,8 +206,18 @@ struct class {
extern struct kobject *sysfs_dev_block_kobj;
extern struct kobject *sysfs_dev_char_kobj;
-extern int __must_check class_register(struct class *class);
+extern int __must_check __class_register(struct class *class,
+ struct lock_class_key *key);
extern void class_unregister(struct class *class);
+
+/* This is a #define to keep the compiler from merging different
+ * instances of the __key variable */
+#define class_register(class) \
+({ \
+ static struct lock_class_key __key; \
+ __class_register(class, &__key); \
+})
+
extern int class_for_each_device(struct class *class, struct device *start,
void *data,
int (*fn)(struct device *dev, void *data));
@@ -239,9 +250,19 @@ struct class_interface {
extern int __must_check class_interface_register(struct class_interface *);
extern void class_interface_unregister(struct class_interface *);
-extern struct class *class_create(struct module *owner, const char *name);
+extern struct class * __must_check __class_create(struct module *owner,
+ const char *name,
+ struct lock_class_key *key);
extern void class_destroy(struct class *cls);
+/* This is a #define to keep the compiler from merging different
+ * instances of the __key variable */
+#define class_create(owner, name) \
+({ \
+ static struct lock_class_key __key; \
+ __class_create(owner, name, &__key); \
+})
+
/*
* The type of device, "struct device" is embedded in. A class
* or bus can contain devices of different types
--
1.5.6.3
next prev parent reply other threads:[~2008-07-22 5:38 UTC|newest]
Thread overview: 97+ messages / expand[flat|nested] mbox.gz Atom feed top
2008-07-22 5:18 [GIT PATCH] driver core patches against 2.6.26 Greg KH
2008-07-22 5:18 ` [PATCH 01/79] sysfs: add /sys/dev/{char,block} to lookup sysfs path by major:minor Greg Kroah-Hartman
2008-07-22 5:18 ` [PATCH 02/79] kobject: replace '/' with '!' in name Greg Kroah-Hartman
2008-07-22 7:12 ` Kari Hurtta
2008-07-22 18:12 ` Ingo Oeser
2008-07-22 20:50 ` Greg KH
2008-07-22 23:25 ` [PATCH] kobject: Replace ALL occurrences of '/' with '!' instead of only the first one Ingo Oeser
2008-07-22 5:18 ` [PATCH 03/79] debugfs: Add a reference to the debugfs API documentation Greg Kroah-Hartman
2008-07-22 5:18 ` [PATCH 04/79] Firmware: fix typo in example code Greg Kroah-Hartman
2008-07-22 5:18 ` [PATCH 05/79] device create: block: convert device_create to device_create_drvdata Greg Kroah-Hartman
2008-07-22 5:18 ` [PATCH 06/79] device create: char: " Greg Kroah-Hartman
2008-07-22 5:18 ` [PATCH 07/79] device create: coda: " Greg Kroah-Hartman
2008-07-22 5:18 ` [PATCH 08/79] device create: dca: " Greg Kroah-Hartman
2008-07-22 5:18 ` [PATCH 09/79] device create: dvb: " Greg Kroah-Hartman
2008-07-22 5:18 ` [PATCH 10/79] device create: framebuffer: " Greg Kroah-Hartman
2008-07-22 5:18 ` [PATCH 11/79] device create: hid: " Greg Kroah-Hartman
2008-07-22 5:18 ` [PATCH 12/79] device create: hwmon: " Greg Kroah-Hartman
2008-07-22 5:18 ` [PATCH 13/79] device create: i2c: " Greg Kroah-Hartman
2008-07-22 5:18 ` [PATCH 14/79] device create: ide: " Greg Kroah-Hartman
2008-07-22 5:18 ` [PATCH 15/79] device create: ieee1394: " Greg Kroah-Hartman
2008-07-22 5:18 ` [PATCH 16/79] device create: infiniband: " Greg Kroah-Hartman
2008-07-22 5:18 ` [PATCH 17/79] device create: isdn: " Greg Kroah-Hartman
2008-07-22 5:18 ` [PATCH 18/79] device create: macintosh: " Greg Kroah-Hartman
2008-07-22 22:00 ` Benjamin Herrenschmidt
2008-07-22 5:18 ` [PATCH 19/79] device create: mips: " Greg Kroah-Hartman
2008-07-22 5:18 ` [PATCH 20/79] device create: misc: " Greg Kroah-Hartman
2008-07-22 5:18 ` [PATCH 21/79] device create: mtd: " Greg Kroah-Hartman
2008-07-22 5:18 ` [PATCH 22/79] device create: net: " Greg Kroah-Hartman
2008-07-22 5:18 ` [PATCH 23/79] device create: s390: " Greg Kroah-Hartman
2008-07-22 5:18 ` [PATCH 24/79] device create: scsi: " Greg Kroah-Hartman
2008-07-22 5:18 ` [PATCH 25/79] device create: sound: " Greg Kroah-Hartman
2008-07-22 5:18 ` [PATCH 26/79] device create: spi: " Greg Kroah-Hartman
2008-07-22 5:18 ` [PATCH 27/79] device create: usb: " Greg Kroah-Hartman
2008-07-22 5:18 ` [PATCH 28/79] device create: x86: " Greg Kroah-Hartman
2008-07-22 5:18 ` [PATCH 29/79] driver core: remove device_create() Greg Kroah-Hartman
2008-07-22 5:18 ` [PATCH 30/79] device create: convert device_create_drvdata to device_create Greg Kroah-Hartman
2008-07-22 5:18 ` [PATCH 31/79] Driver Core: add ability for class_for_each_device to start in middle of list Greg Kroah-Hartman
2008-07-22 5:18 ` [PATCH 32/79] Driver Core: add ability for class_find_device " Greg Kroah-Hartman
2008-07-22 5:18 ` [PATCH 33/79] block: fix compiler warning in genhd.c Greg Kroah-Hartman
2008-07-22 5:18 ` [PATCH 34/79] block: make printk_partition use the class iterator function Greg Kroah-Hartman
2008-07-22 5:18 ` [PATCH 35/79] block: make blk_lookup_devt " Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 36/79] block: make /proc/diskstats only build if CONFIG_PROC_FS is enabled Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 37/79] block: make proc files seq_start use the class_find_device() Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 38/79] block: move header for /proc/partitions to seq_start Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 39/79] block: make /proc/partitions and /proc/diskstats use class_find_device() Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 40/79] infiniband: rename "device" to "ib_device" in cm_device Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 41/79] infiniband: make cm_device use a struct device and not a kobject Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 42/79] bluetooth: remove improper bluetooth class symlinks Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 43/79] class: move driver core specific parts to a private structure Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 44/79] class: rename "devices" to "class_devices" in internal class structure Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 45/79] class: rename "interfaces" to "class_interfaces" " Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 46/79] class: rename "subsys" to "class_subsys" " Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 47/79] class: rename "sem" to "class_sem" " Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 48/79] class: fix docbook comments for class_private structure Greg Kroah-Hartman
2008-07-22 5:19 ` Greg Kroah-Hartman [this message]
2008-07-22 5:19 ` [PATCH 50/79] class: change internal semaphore to a mutex Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 51/79] driver core: remove KOBJ_NAME_LEN define Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 52/79] driver core: remove DEVICE_NAME_SIZE define Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 53/79] driver core: remove DEVICE_ID_SIZE define Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 54/79] driver core: fix a lot of printk usages of bus_id Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 55/79] pnp: add acpi:* modalias entries Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 56/79] UIO: fix UIO Kconfig dependencies Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 57/79] UIO: Add write function to allow irq masking Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 58/79] UIO: add generic UIO platform driver Greg Kroah-Hartman
2008-07-22 11:34 ` Uwe Kleine-König
2008-07-22 17:13 ` Greg KH
2008-07-22 5:19 ` [PATCH 59/79] UIO: minor style and comment fixes Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 60/79] kobject: reorder kobject to save space on 64 bit builds Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 61/79] kobject: should use kobject_put() in kset-example Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 62/79] sysdev: fix debugging statements in registration code Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 63/79] sysfs: don't call notify_change Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 64/79] uio-howto.tmpl: use standard copyright/legal markings Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 65/79] uio-howto.tmpl: use unique output names Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 66/79] always enable FW_LOADER unless EMBEDDED=y Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 67/79] HOWTO: change email addresses of James in HOWTO Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 68/79] debugfs: Implement debugfs_remove_recursive() Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 69/79] sysfs-rules.txt: reword API stability statement Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 70/79] kobject: Transmit return value of call_usermodehelper() to caller Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 71/79] driver core: Suppress sysfs warnings for device_rename() Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 72/79] sysdev: Pass the attribute to the low level sysdev show/store function Greg Kroah-Hartman
2008-07-22 20:40 ` Andrew Morton
2008-07-22 20:49 ` Greg KH
2008-07-22 21:03 ` Andrew Morton
2008-07-22 21:19 ` Greg KH
2008-07-23 3:04 ` Stephen Rothwell
2008-07-23 4:22 ` Greg KH
2008-07-23 9:03 ` Ingo Molnar
2008-07-23 14:03 ` Greg KH
2008-07-22 5:19 ` [PATCH 73/79] sysdev: Add utility functions for simple int/ulong variable sysdev attributes Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 74/79] sysdev: Convert the x86 mce tolerant sysdev attribute to generic attribute Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 75/79] HP iLO driver Greg Kroah-Hartman
2008-07-22 17:11 ` Altobelli, David
2008-07-22 17:16 ` Greg KH
2008-07-22 5:19 ` [PATCH 76/79] MTD: handle pci_name() being const Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 77/79] 3c59x: " Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 78/79] sparc64: fix up bus_id changes in sparc core code Greg Kroah-Hartman
2008-07-22 5:19 ` [PATCH 79/79] arm: bus_id -> dev_name() and dev_set_name() conversions Greg Kroah-Hartman
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1216703983-21448-49-git-send-email-gregkh@suse.de \
--to=gregkh@suse.de \
--cc=James.Bottomley@HansenPartnership.com \
--cc=akpm@linux-foundation.org \
--cc=hidave.darkstar@gmail.com \
--cc=kay.sievers@vrfy.org \
--cc=linux-kernel@vger.kernel.org \
--cc=matthew@wil.cx \
--cc=mingo@elte.hu \
--cc=peterz@infradead.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome