From: Greg Kroah-Hartman <gregkh@suse.de>
To: linux-kernel@vger.kernel.org
Cc: "Eric W. Biederman" <ebiederm@xmission.com>,
Greg Kroah-Hartman <gregkh@suse.de>
Subject: [PATCH 39/46] kobject: Fix kobject_rename and !CONFIG_SYSFS
Date: Thu, 16 Oct 2008 10:10:40 -0700 [thread overview]
Message-ID: <1224177047-11859-39-git-send-email-gregkh@suse.de> (raw)
In-Reply-To: <20081016170954.GA11824@kroah.com>
From: Eric W. Biederman <ebiederm@xmission.com>
When looking at kobject_rename I found two bugs with
that exist when sysfs support is disabled in the kernel.
kobject_rename does not change the name on the kobject when
sysfs support is not compiled in.
kobject_rename without locking attempts to check the
validity of a rename operation, which the kobject layer
simply does not have the infrastructure to do.
This patch documents the previously unstated requirement of
kobject_rename that is the responsibility of the caller to
provide mutual exclusion and to be certain that the new_name
for the kobject is valid.
This patch modifies sysfs_rename_dir in !CONFIG_SYSFS case
to call kobject_set_name to actually change the kobject_name.
This patch removes the bogus and misleading check in kobject_rename
that attempts to see if a rename is valid. The check is bogus
because we do not have the proper locking. The check is misleading
because it looks like we can and do perform checking at the kobject
level that we don't.
Signed-off-by: Eric W. Biederman <ebiederm@xmission.com>
Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
---
Documentation/kobject.txt | 4 ++++
drivers/base/core.c | 5 +++++
include/linux/sysfs.h | 4 +++-
lib/kobject.c | 18 +++++-------------
4 files changed, 17 insertions(+), 14 deletions(-)
diff --git a/Documentation/kobject.txt b/Documentation/kobject.txt
index 51a8021..f5d2aad 100644
--- a/Documentation/kobject.txt
+++ b/Documentation/kobject.txt
@@ -118,6 +118,10 @@ the name of the kobject, call kobject_rename():
int kobject_rename(struct kobject *kobj, const char *new_name);
+Note kobject_rename does perform any locking or have a solid notion of
+what names are valid so the provide must provide their own sanity checking
+and serialization.
+
There is a function called kobject_set_name() but that is legacy cruft and
is being removed. If your code needs to call this function, it is
incorrect and needs to be fixed.
diff --git a/drivers/base/core.c b/drivers/base/core.c
index 9649d1c..8c2cc26 100644
--- a/drivers/base/core.c
+++ b/drivers/base/core.c
@@ -1327,6 +1327,11 @@ EXPORT_SYMBOL_GPL(device_destroy);
* device_rename - renames a device
* @dev: the pointer to the struct device to be renamed
* @new_name: the new name of the device
+ *
+ * It is the responsibility of the caller to provide mutual
+ * exclusion between two different calls of device_rename
+ * on the same device to ensure that new_name is valid and
+ * won't conflict with other devices.
*/
int device_rename(struct device *dev, char *new_name)
{
diff --git a/include/linux/sysfs.h b/include/linux/sysfs.h
index b330e28..39924a9 100644
--- a/include/linux/sysfs.h
+++ b/include/linux/sysfs.h
@@ -20,6 +20,8 @@
struct kobject;
struct module;
+extern int kobject_set_name(struct kobject *kobj, const char *name, ...)
+ __attribute__((format(printf, 2, 3)));
/* FIXME
* The *owner field is no longer used, but leave around
* until the tree gets cleaned up fully.
@@ -147,7 +149,7 @@ static inline void sysfs_remove_dir(struct kobject *kobj)
static inline int sysfs_rename_dir(struct kobject *kobj, const char *new_name)
{
- return 0;
+ return kobject_set_name(kobj, "%s", new_name);
}
static inline int sysfs_move_dir(struct kobject *kobj,
diff --git a/lib/kobject.c b/lib/kobject.c
index fbf0ae2..ae6bb90 100644
--- a/lib/kobject.c
+++ b/lib/kobject.c
@@ -387,6 +387,11 @@ EXPORT_SYMBOL_GPL(kobject_init_and_add);
* kobject_rename - change the name of an object
* @kobj: object in question.
* @new_name: object's new name
+ *
+ * It is the responsibility of the caller to provide mutual
+ * exclusion between two different calls of kobject_rename
+ * on the same kobject and to ensure that new_name is valid and
+ * won't conflict with other kobjects.
*/
int kobject_rename(struct kobject *kobj, const char *new_name)
{
@@ -401,19 +406,6 @@ int kobject_rename(struct kobject *kobj, const char *new_name)
if (!kobj->parent)
return -EINVAL;
- /* see if this name is already in use */
- if (kobj->kset) {
- struct kobject *temp_kobj;
- temp_kobj = kset_find_obj(kobj->kset, new_name);
- if (temp_kobj) {
- printk(KERN_WARNING "kobject '%s' cannot be renamed "
- "to '%s' as '%s' is already in existence.\n",
- kobject_name(kobj), new_name, new_name);
- kobject_put(temp_kobj);
- return -EINVAL;
- }
- }
-
devpath = kobject_get_path(kobj, GFP_KERNEL);
if (!devpath) {
error = -ENOMEM;
--
1.6.0.2
next prev parent reply other threads:[~2008-10-16 17:29 UTC|newest]
Thread overview: 51+ messages / expand[flat|nested] mbox.gz Atom feed top
2008-10-16 17:09 [GIT PATCH] driver core patches for your 2.6-git tree Greg KH
2008-10-16 17:10 ` [PATCH 01/46] modules: fix module "notes" kobject leak Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 02/46] sysfs: crash debugging Greg Kroah-Hartman
2008-10-16 17:40 ` Mathieu Desnoyers
2008-10-20 20:57 ` Greg KH
2008-10-16 17:10 ` [PATCH 03/46] device create: block: convert device_create_drvdata to device_create Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 04/46] device create: char: " Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 05/46] device create: ieee1394: " Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 06/46] device create: infiniband: " Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 07/46] device create: misc: " Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 08/46] device create: net: " Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 09/46] device create: s390: " Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 10/46] device create: scsi: " Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 11/46] device create: sound: " Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 12/46] device create: usb: " Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 13/46] device create: video: " Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 14/46] device create: ide: " Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 15/46] device create: remove device_create_drvdata Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 16/46] usb gadget: link fixes for serial gadget Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 17/46] usb gadget: link fixes for gadget zero Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 18/46] usb gadget: link fixes for MIDI gadget Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 19/46] usb gadget: link fixes for printer gadget Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 20/46] usb gadget: link fixes for storage gadget Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 21/46] usb gadget: link fixes for cdc composite gadget Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 22/46] usb gadget: link fixes for network gadget Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 23/46] driver core: basic infrastructure for per-module dynamic debug messages Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 24/46] driver core: make struct platform_pm_ops static Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 25/46] sysfs: Support sysfs_notify from atomic context with new sysfs_notify_dirent Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 26/46] drivers/firmware/iscsi_ibft.c: make 3 functions static Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 27/46] Driver core: Clarify device cleanup Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 28/46] Driver core: Fix cleanup in device_create_vargs() Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 29/46] device model: Do a quickcheck for driver binding before doing an expensive check Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 30/46] sysfs: fix deadlock Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 31/46] debug: Introduce a dev_WARN() function Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 32/46] debug: use dev_WARN() rather than WARN_ON() in device_pm_add() Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 33/46] usb: turn dev_warn+WARN_ON combos into dev_WARN Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 34/46] Driver core: make bus_find_device_by_name() more robust Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 35/46] PNP: create device attributes via default device attributes Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 36/46] sysfs: use ilookup5() instead of ilookup5_nowait() Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 37/46] platform: add new device registration helper Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 38/46] sysfs: Make dir and name args to sysfs_notify() const Greg Kroah-Hartman
2008-10-16 17:10 ` Greg Kroah-Hartman [this message]
2008-10-16 17:10 ` [PATCH 40/46] kobject: Cleanup kobject_rename and !CONFIG_SYSFS Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 41/46] NET: convert the phy_device file to use bus_find_device_by_name Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 42/46] Driver core: add bus_sort_breadthfirst() function Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 43/46] UIO: Add alignment warnings for uio-mem Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 44/46] UIO: Change driver name of uio_pdrv Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 45/46] UIO: add automata sercos3 pci card support Greg Kroah-Hartman
2008-10-16 17:10 ` [PATCH 46/46] UIO: Fix mapping of logical and virtual memory Greg Kroah-Hartman
2008-10-17 15:31 ` [GIT PATCH] driver core patches for your 2.6-git tree Jason Baron
2008-10-17 18:01 ` Greg KH
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1224177047-11859-39-git-send-email-gregkh@suse.de \
--to=gregkh@suse.de \
--cc=ebiederm@xmission.com \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®