From: Philipp Reisner <philipp.reisner@linbit.com>
To: linux-kernel@vger.kernel.org
Cc: Andrew Morton <akpm@linux-foundation.org>,
Jens Axboe <jens.axboe@oracle.com>, Greg KH <gregkh@suse.de>,
Neil Brown <neilb@suse.de>,
James Bottomley <James.Bottomley@HansenPartnership.com>,
Sam Ravnborg <sam@ravnborg.org>, Dave Jones <davej@redhat.com>,
Nikanth Karthikesan <knikanth@suse.de>,
"Lars Marowsky-Bree" <lmb@suse.de>,
"Nicholas A. Bellinger" <nab@linux-iscsi.org>,
Kyle Moffett <kyle@moffetthome.net>,
Bart Van Assche <bart.vanassche@gmail.com>,
Lars Ellenberg <lars.ellenberg@linbit.com>,
Philipp Reisner <philipp.reisner@linbit.com>
Subject: [PATCH 00/16] DRBD: a block device for HA clusters
Date: Fri, 15 May 2009 14:10:27 +0200 [thread overview]
Message-ID: <1242389443-3470-1-git-send-email-philipp.reisner@linbit.com> (raw)
Hi,
This is a repost of DRBD, to keep you updated about the ongoing
cleanups and improvements.
Patch set attached. Git tree available:
git pull git://git.drbd.org/linux-2.6-drbd.git drbd
We are looking for reviews!
Note for reviewers:
Only the first two patches (major.h and lru_cache) are self contained.
The other patches are just split at file boundaries. Sorry, DRBD
was developed as out-of-tree modules just for too long.
Short Description
DRBD is a shared-nothing, synchronously replicated block device. It
is designed to serve as a building block for high availability
clusters and in this context, is a "drop-in" replacement for shared
storage. Simplistically, you could see it as a network RAID 1.
More information can be found at http://www.drbd.org
Changes since 2009-04-30
* Cleanup: Removed typecasts, more documentation in lru_cache. Moved to /lib
* Cleanup: replaced __attribute__((packed)) with __packed
* Cleanup: remove quite a few 'inline's from .c files
* Cleanup: renaming a few constants: _SECT -> _SECTOR_SIZE, _SIZE_B -> _SHIFT ...
* Cleanup: rename inc_local -> get_ldev; inc_net -> get_net_conf; and corresponding dec_* -> put_*
* Cleanup: rename mdev->bc to mdev->ldev (to match the recent change to get_ldev/put_ldev)
* Cleanup: Made function comments kernel-doc compliant
* Cleanup: vmalloc() only as a fall back for kmalloc()
* DRBD: Allow detach of a SyncTarget node. (Bugz 221)
* DRBD: Call drbd_rs_cancel_all() and reset rs_pending when aborting resync due to detach. (Bugz 223)
* DRBD: make drbd thread t_lock irqsave - lockdep complained, and lockdep is right (theoretically)
Changes since 2009-04-10
* Cleanup: Removed all CamelCase
* Cleanup: Replaced DRBD's own tracing stuff with regular tracepoints
* Cleanup: Removed ERR/INFO/ALERT ... macros, using dev_err/dev_info/... now
* Cleanup: Minor stuff, as suggested in feedback on LKML
* DRBD: Bitmap compression feature was finalised
* DRBD: new disable_sendpage parameter
Changes since the post on 2009-03-30, all triggered by reviews
* Improvements to Makefile and Kconfig
* Simplified definitions of bm_flags' bitnumbers
* Removed debugging aid
Changes since the post on 2009-03-23, from drbd-mainline
* Updated to the final drbd-8.3.1 code
* Optionally run-length encode bitmap transfers
Changes since the post on 2009-03-23, triggered by reviews
* Using the latest proc_create() now
* Moved the allocation of md_io_tmpp to attach/detach out of drbd_md_sync_page_io()
* Removing the mode selection comments for emacs
* Removed DRBD_ratelimit()
cheers,
Phil
next reply other threads:[~2009-05-15 12:11 UTC|newest]
Thread overview: 61+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-05-15 12:10 Philipp Reisner [this message]
2009-05-15 12:10 ` [PATCH 01/16] DRBD: major.h Philipp Reisner
2009-05-15 12:10 ` [PATCH 02/16] DRBD: lru_cache Philipp Reisner
2009-05-15 12:10 ` [PATCH 03/16] DRBD: activity_log Philipp Reisner
2009-05-15 12:10 ` [PATCH 04/16] DRBD: bitmap Philipp Reisner
2009-05-15 12:10 ` [PATCH 05/16] DRBD: request Philipp Reisner
2009-05-15 12:10 ` [PATCH 06/16] DRBD: userspace_interface Philipp Reisner
2009-05-15 12:10 ` [PATCH 07/16] DRBD: internal_data_structures Philipp Reisner
2009-05-15 12:10 ` [PATCH 08/16] DRBD: main Philipp Reisner
2009-05-15 12:10 ` [PATCH 09/16] DRBD: receiver Philipp Reisner
2009-05-15 12:10 ` [PATCH 10/16] DRBD: proc Philipp Reisner
2009-05-15 12:10 ` [PATCH 11/16] DRBD: worker Philipp Reisner
2009-05-15 12:10 ` [PATCH 12/16] DRBD: variable_length_integer_encoding Philipp Reisner
2009-05-15 12:10 ` [PATCH 13/16] DRBD: misc Philipp Reisner
2009-05-15 12:10 ` [PATCH 14/16] DRBD: tracepoint_probes Philipp Reisner
2009-05-15 12:10 ` [PATCH 15/16] DRBD: documentation Philipp Reisner
2009-05-15 12:10 ` [PATCH 16/16] DRBD: final Philipp Reisner
2009-05-15 12:18 ` [PATCH 13/16] DRBD: misc Lars Marowsky-Bree
-- strict thread matches above, loose matches on Subject: below --
2009-07-06 15:39 [PATCH 00/16] drbd: a block device for HA clusters Philipp Reisner
2009-07-21 5:49 ` Andrew Morton
2009-05-14 22:31 [PATCH 00/16] DRBD: " devzero
2009-04-30 11:26 Philipp Reisner
2009-05-01 8:59 ` Andrew Morton
2009-05-01 11:15 ` Lars Marowsky-Bree
2009-05-01 13:14 ` Dave Jones
2009-05-01 19:14 ` Andrew Morton
2009-05-05 4:05 ` Christian Kujau
2009-05-02 7:33 ` Bart Van Assche
2009-05-03 5:36 ` Willy Tarreau
2009-05-03 5:40 ` david
2009-05-03 14:21 ` James Bottomley
2009-05-03 14:36 ` david
2009-05-03 14:45 ` James Bottomley
2009-05-03 14:56 ` david
2009-05-03 15:09 ` James Bottomley
2009-05-03 15:22 ` david
2009-05-03 15:38 ` James Bottomley
2009-05-03 15:48 ` david
2009-05-03 16:02 ` James Bottomley
2009-05-03 16:13 ` david
2009-05-04 8:28 ` Philipp Reisner
2009-05-04 17:24 ` James Bottomley
2009-05-05 8:21 ` Philipp Reisner
2009-05-05 14:09 ` James Bottomley
2009-05-05 15:56 ` Philipp Reisner
2009-05-05 17:05 ` James Bottomley
2009-05-05 21:45 ` Philipp Reisner
2009-05-05 21:53 ` James Bottomley
2009-05-06 8:17 ` Philipp Reisner
2009-05-05 15:03 ` Bart Van Assche
2009-05-05 15:57 ` Philipp Reisner
2009-05-05 17:38 ` Lars Marowsky-Bree
2009-05-03 10:06 ` Philipp Reisner
2009-05-03 10:15 ` Thomas Backlund
2009-05-03 5:53 ` Neil Brown
2009-05-03 6:24 ` david
2009-05-03 8:29 ` Lars Ellenberg
2009-05-03 11:00 ` Neil Brown
2009-05-03 21:32 ` Lars Ellenberg
2009-05-04 16:12 ` Lars Marowsky-Bree
2009-05-05 22:08 ` Lars Ellenberg
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1242389443-3470-1-git-send-email-philipp.reisner@linbit.com \
--to=philipp.reisner@linbit.com \
--cc=James.Bottomley@HansenPartnership.com \
--cc=akpm@linux-foundation.org \
--cc=bart.vanassche@gmail.com \
--cc=davej@redhat.com \
--cc=gregkh@suse.de \
--cc=jens.axboe@oracle.com \
--cc=knikanth@suse.de \
--cc=kyle@moffetthome.net \
--cc=lars.ellenberg@linbit.com \
--cc=linux-kernel@vger.kernel.org \
--cc=lmb@suse.de \
--cc=nab@linux-iscsi.org \
--cc=neilb@suse.de \
--cc=sam@ravnborg.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®