From: Joerg Roedel <joerg.roedel@amd.com>
To: Ingo Molnar <mingo@elte.hu>
Cc: iommu@lists.linux-foundation.org, linux-kernel@vger.kernel.org,
Joerg Roedel <joerg.roedel@amd.com>
Subject: [PATCH 5/5] dma-debug: simplify logic in driver_filter()
Date: Mon, 8 Jun 2009 16:34:10 +0200 [thread overview]
Message-ID: <1244471650-4632-6-git-send-email-joerg.roedel@amd.com> (raw)
In-Reply-To: <1244471650-4632-1-git-send-email-joerg.roedel@amd.com>
This patch makes the driver_filter function more readable by
reorganizing the code. The removal of a code code block to an upper
indentation level makes hard-to-read line-wraps unnecessary.
Signed-off-by: Joerg Roedel <joerg.roedel@amd.com>
---
lib/dma-debug.c | 46 +++++++++++++++++++++++-----------------------
1 files changed, 23 insertions(+), 23 deletions(-)
diff --git a/lib/dma-debug.c b/lib/dma-debug.c
index 27b369d..ad65fc0 100644
--- a/lib/dma-debug.c
+++ b/lib/dma-debug.c
@@ -147,6 +147,10 @@ static inline void dump_entry_trace(struct dma_debug_entry *entry)
static bool driver_filter(struct device *dev)
{
+ struct device_driver *drv;
+ unsigned long flags;
+ bool ret;
+
/* driver filter off */
if (likely(!current_driver_name[0]))
return true;
@@ -155,32 +159,28 @@ static bool driver_filter(struct device *dev)
if (current_driver && dev->driver == current_driver)
return true;
- /* driver filter on but not yet initialized */
- if (!current_driver && current_driver_name[0]) {
- struct device_driver *drv = get_driver(dev->driver);
- unsigned long flags;
- bool ret = false;
-
- if (!drv)
- return false;
-
- /* lock to protect against change of current_driver_name */
- read_lock_irqsave(&driver_name_lock, flags);
+ if (current_driver || !current_driver_name[0])
+ return false;
- if (drv->name &&
- strncmp(current_driver_name, drv->name,
- NAME_MAX_LEN-1) == 0) {
- current_driver = drv;
- ret = true;
- }
+ /* driver filter on but not yet initialized */
+ drv = get_driver(dev->driver);
+ if (!drv)
+ return false;
- read_unlock_irqrestore(&driver_name_lock, flags);
- put_driver(drv);
+ /* lock to protect against change of current_driver_name */
+ read_lock_irqsave(&driver_name_lock, flags);
- return ret;
+ ret = false;
+ if (drv->name &&
+ strncmp(current_driver_name, drv->name, NAME_MAX_LEN - 1) == 0) {
+ current_driver = drv;
+ ret = true;
}
- return false;
+ read_unlock_irqrestore(&driver_name_lock, flags);
+ put_driver(drv);
+
+ return ret;
}
#define err_printk(dev, entry, format, arg...) do { \
--
1.6.3.1
next prev parent reply other threads:[~2009-06-08 14:36 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-06-08 14:34 [git pull][PATCH 0/5] dma-debug minor fixes and cleanups Joerg Roedel
2009-06-08 14:34 ` [PATCH 1/5] dma-debug: comment style fixes Joerg Roedel
2009-06-08 14:34 ` [PATCH 2/5] dma-debug: code " Joerg Roedel
2009-06-08 14:34 ` [PATCH 3/5] dma-debug: use pr_* instead of printk(KERN_* ...) Joerg Roedel
2009-06-08 14:34 ` [PATCH 4/5] dma-debug: disable/enable irqs only once in device_dma_allocations Joerg Roedel
2009-07-23 18:43 ` Leon Woestenberg
2009-06-08 14:34 ` Joerg Roedel [this message]
2009-06-08 15:29 ` [git pull][PATCH 0/5] dma-debug minor fixes and cleanups Ingo Molnar
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1244471650-4632-6-git-send-email-joerg.roedel@amd.com \
--to=joerg.roedel@amd.com \
--cc=iommu@lists.linux-foundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@elte.hu \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®