From: Steven Price <steven.price@arm.com>
To: Louis-Alexis Eyraud <louisalexis.eyraud@collabora.com>,
Maarten Lankhorst <maarten.lankhorst@linux.intel.com>,
Maxime Ripard <mripard@kernel.org>,
Thomas Zimmermann <tzimmermann@suse.de>,
David Airlie <airlied@gmail.com>, Simona Vetter <simona@ffwll.ch>,
Rob Herring <robh@kernel.org>,
Krzysztof Kozlowski <krzk+dt@kernel.org>,
Conor Dooley <conor+dt@kernel.org>,
Matthias Brugger <matthias.bgg@gmail.com>,
AngeloGioacchino Del Regno
<angelogioacchino.delregno@collabora.com>,
Boris Brezillon <boris.brezillon@collabora.com>
Cc: kernel@collabora.com, dri-devel@lists.freedesktop.org,
devicetree@vger.kernel.org, linux-kernel@vger.kernel.org,
linux-arm-kernel@lists.infradead.org,
linux-mediatek@lists.infradead.org
Subject: Re: [PATCH v6 2/5] drm/panfrost: Drop duplicated Mediatek supplies arrays
Date: Fri, 9 May 2025 11:59:07 +0100 [thread overview]
Message-ID: <124b8718-1a8e-4cf2-99e2-604fe63ae132@arm.com> (raw)
In-Reply-To: <20250509-mt8370-enable-gpu-v6-2-2833888cb1d3@collabora.com>
On 09/05/2025 11:12, Louis-Alexis Eyraud wrote:
> In the panfrost driver, the platform data of several Mediatek SoC
> declares and uses custom supplies array definitions
> (mediatek_mt8192_supplies, mediatek_mt8183_b_supplies), that are the
> same as default_supplies (used by default platform data).
>
> So drop these duplicated definitions and use default_supplies instead.
> Also, rename mediatek_mt8183_supplies to a more generic name too
> (legacy_supplies).
>
> Signed-off-by: Louis-Alexis Eyraud <louisalexis.eyraud@collabora.com>
Thanks for doing this.
Reviewed-by: Steven Price <steven.price@arm.com>
> ---
> drivers/gpu/drm/panfrost/panfrost_drv.c | 24 +++++++++++-------------
> 1 file changed, 11 insertions(+), 13 deletions(-)
>
> diff --git a/drivers/gpu/drm/panfrost/panfrost_drv.c b/drivers/gpu/drm/panfrost/panfrost_drv.c
> index f1ec3b02f15a0029d20c7d81046ded59854e885c..7b899a9b2120c608e61dab9ca831ab8e907e8139 100644
> --- a/drivers/gpu/drm/panfrost/panfrost_drv.c
> +++ b/drivers/gpu/drm/panfrost/panfrost_drv.c
> @@ -797,19 +797,18 @@ static const struct panfrost_compatible amlogic_data = {
> * On new devicetrees please use the _b variant with a single and
> * coupled regulators instead.
> */
> -static const char * const mediatek_mt8183_supplies[] = { "mali", "sram", NULL };
> +static const char * const legacy_supplies[] = { "mali", "sram", NULL };
> static const char * const mediatek_mt8183_pm_domains[] = { "core0", "core1", "core2" };
> static const struct panfrost_compatible mediatek_mt8183_data = {
> - .num_supplies = ARRAY_SIZE(mediatek_mt8183_supplies) - 1,
> - .supply_names = mediatek_mt8183_supplies,
> + .num_supplies = ARRAY_SIZE(legacy_supplies) - 1,
> + .supply_names = legacy_supplies,
> .num_pm_domains = ARRAY_SIZE(mediatek_mt8183_pm_domains),
> .pm_domain_names = mediatek_mt8183_pm_domains,
> };
>
> -static const char * const mediatek_mt8183_b_supplies[] = { "mali", NULL };
> static const struct panfrost_compatible mediatek_mt8183_b_data = {
> - .num_supplies = ARRAY_SIZE(mediatek_mt8183_b_supplies) - 1,
> - .supply_names = mediatek_mt8183_b_supplies,
> + .num_supplies = ARRAY_SIZE(default_supplies) - 1,
> + .supply_names = default_supplies,
> .num_pm_domains = ARRAY_SIZE(mediatek_mt8183_pm_domains),
> .pm_domain_names = mediatek_mt8183_pm_domains,
> .pm_features = BIT(GPU_PM_CLK_DIS) | BIT(GPU_PM_VREG_OFF),
> @@ -817,8 +816,8 @@ static const struct panfrost_compatible mediatek_mt8183_b_data = {
>
> static const char * const mediatek_mt8186_pm_domains[] = { "core0", "core1" };
> static const struct panfrost_compatible mediatek_mt8186_data = {
> - .num_supplies = ARRAY_SIZE(mediatek_mt8183_b_supplies) - 1,
> - .supply_names = mediatek_mt8183_b_supplies,
> + .num_supplies = ARRAY_SIZE(default_supplies) - 1,
> + .supply_names = default_supplies,
> .num_pm_domains = ARRAY_SIZE(mediatek_mt8186_pm_domains),
> .pm_domain_names = mediatek_mt8186_pm_domains,
> .pm_features = BIT(GPU_PM_CLK_DIS) | BIT(GPU_PM_VREG_OFF),
> @@ -826,20 +825,19 @@ static const struct panfrost_compatible mediatek_mt8186_data = {
>
> /* MT8188 uses the same power domains and power supplies as MT8183 */
> static const struct panfrost_compatible mediatek_mt8188_data = {
> - .num_supplies = ARRAY_SIZE(mediatek_mt8183_b_supplies) - 1,
> - .supply_names = mediatek_mt8183_b_supplies,
> + .num_supplies = ARRAY_SIZE(default_supplies) - 1,
> + .supply_names = default_supplies,
> .num_pm_domains = ARRAY_SIZE(mediatek_mt8183_pm_domains),
> .pm_domain_names = mediatek_mt8183_pm_domains,
> .pm_features = BIT(GPU_PM_CLK_DIS) | BIT(GPU_PM_VREG_OFF),
> .gpu_quirks = BIT(GPU_QUIRK_FORCE_AARCH64_PGTABLE),
> };
>
> -static const char * const mediatek_mt8192_supplies[] = { "mali", NULL };
> static const char * const mediatek_mt8192_pm_domains[] = { "core0", "core1", "core2",
> "core3", "core4" };
> static const struct panfrost_compatible mediatek_mt8192_data = {
> - .num_supplies = ARRAY_SIZE(mediatek_mt8192_supplies) - 1,
> - .supply_names = mediatek_mt8192_supplies,
> + .num_supplies = ARRAY_SIZE(default_supplies) - 1,
> + .supply_names = default_supplies,
> .num_pm_domains = ARRAY_SIZE(mediatek_mt8192_pm_domains),
> .pm_domain_names = mediatek_mt8192_pm_domains,
> .pm_features = BIT(GPU_PM_CLK_DIS) | BIT(GPU_PM_VREG_OFF),
>
next prev parent reply other threads:[~2025-05-09 10:59 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-05-09 10:12 [PATCH v6 0/5] Add Mali GPU support for Mediatek MT8370 SoC Louis-Alexis Eyraud
2025-05-09 10:12 ` [PATCH v6 1/5] dt-bindings: gpu: mali-bifrost: Add compatible for " Louis-Alexis Eyraud
2025-05-09 10:12 ` [PATCH v6 2/5] drm/panfrost: Drop duplicated Mediatek supplies arrays Louis-Alexis Eyraud
2025-05-09 10:59 ` Steven Price [this message]
2025-05-09 10:12 ` [PATCH v6 3/5] drm/panfrost: Commonize Mediatek power domain array definitions Louis-Alexis Eyraud
2025-05-09 10:59 ` Steven Price
2025-05-09 10:12 ` [PATCH v6 4/5] drm/panfrost: Add support for Mali on the MT8370 SoC Louis-Alexis Eyraud
2025-05-09 10:12 ` [PATCH v6 5/5] arm64: dts: mediatek: mt8370: Enable gpu support Louis-Alexis Eyraud
2025-06-20 14:58 ` [PATCH v6 0/5] Add Mali GPU support for Mediatek MT8370 SoC Steven Price
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=124b8718-1a8e-4cf2-99e2-604fe63ae132@arm.com \
--to=steven.price@arm.com \
--cc=airlied@gmail.com \
--cc=angelogioacchino.delregno@collabora.com \
--cc=boris.brezillon@collabora.com \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=dri-devel@lists.freedesktop.org \
--cc=kernel@collabora.com \
--cc=krzk+dt@kernel.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mediatek@lists.infradead.org \
--cc=louisalexis.eyraud@collabora.com \
--cc=maarten.lankhorst@linux.intel.com \
--cc=matthias.bgg@gmail.com \
--cc=mripard@kernel.org \
--cc=robh@kernel.org \
--cc=simona@ffwll.ch \
--cc=tzimmermann@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®