mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Joe Perches <joe@perches.com>
To: Andrew Morton <akpm@linux-foundation.org>
Cc: Roland Dreier <rdreier@cisco.com>,
	linux-kernel@vger.kernel.org, x86@kernel.org
Subject: Re: [PATCH] Use bool for boolean flag in printk_once()
Date: Thu, 13 Aug 2009 14:33:47 -0700	[thread overview]
Message-ID: <1250199227.28285.142.camel@Joe-Laptop.home> (raw)
In-Reply-To: <20090813142144.37509d52.akpm@linux-foundation.org>

On Thu, 2009-08-13 at 14:21 -0700, Andrew Morton wrote:
> On Thu, 13 Aug 2009 13:48:26 -0700
> Roland Dreier <rdreier@cisco.com> wrote:
> 
> > Using the type bool (instead of int) for the __print_once flag in the
> > printk_once() macro matches the intent of the code better, and allows
> > the compiler to generate smaller code; eg a typical callsite with gcc
> > 4.3.3 on i386:
> > 
> > add/remove: 0/0 grow/shrink: 0/2 up/down: 0/-6 (-6)
> > function                                     old     new   delta
> > static.__print_once                            4       1      -3
> > get_cpu_vendor                               146     143      -3
> > 
> > Saving 6 bytes of object size per callsite by slightly improving the
> > readability of the source seems like a win to me.
> > 
> > Signed-off-by: Roland Dreier <rolandd@cisco.com>
> > ---
> >  include/linux/kernel.h |    4 ++--
> >  1 files changed, 2 insertions(+), 2 deletions(-)
> > 
> > diff --git a/include/linux/kernel.h b/include/linux/kernel.h
> > index d6320a3..f828ce9 100644
> > --- a/include/linux/kernel.h
> > +++ b/include/linux/kernel.h
> > @@ -249,10 +249,10 @@ extern bool printk_timed_ratelimit(unsigned long *caller_jiffies,
> >   * Print a one-time message (analogous to WARN_ONCE() et al):
> >   */
> >  #define printk_once(x...) ({			\
> > -	static int __print_once = 1;		\
> > +	static bool __print_once = true;	\
> >  						\
> >  	if (__print_once) {			\
> > -		__print_once = 0;		\
> > +		__print_once = false;		\
> >  		printk(x);			\
> >  	}					\
> >  })
> 
> hm, OK,  in trace_recursive_lock() we get:
> 
> 	cmpl	$0, __print_once.28104(%rip)	#, __print_once
> 	je	.L719	#,
> 
> changed to
> 
> 	cmpb	$0, __print_once.28104(%rip)	# __print_once
> 	je	.L719	#,

The test should be inverted so that it's not initialized.

I submitted this once:
http://lkml.indiana.edu/hypermail/linux/kernel/0905.2/02636.html

	static bool printed;
	if (!printed) {
		printed = true;
		printk...
	}



      reply	other threads:[~2009-08-13 21:34 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2009-08-13 20:48 Roland Dreier
2009-08-13 21:21 ` Andrew Morton
2009-08-13 21:33   ` Joe Perches [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1250199227.28285.142.camel@Joe-Laptop.home \
    --to=joe@perches.com \
    --cc=akpm@linux-foundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=rdreier@cisco.com \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®