From: Tim Abbott <tabbott@ksplice.com>
To: Linux Kernel Mailing List <linux-kernel@vger.kernel.org>
Cc: Sam Ravnborg <sam@ravnborg.org>, Tim Abbott <tabbott@ksplice.com>
Subject: [PATCH v2 0/5] Use macros rather than hardcoding section names
Date: Tue, 8 Sep 2009 22:49:01 -0400 [thread overview]
Message-ID: <1252464546-26394-1-git-send-email-tabbott@ksplice.com> (raw)
This patch series cleans up the kernel's explicit references to
.data.page_aligned, .bss.page_aligned, and .data.init_task to instead
use the standard macros for those sections.embly code.
This version of the patch series differs from the previous one in that
I've added a new patch that fixes breakage in the x86 linker script
caused indirectly by the last patch in the patch series.
This cleanup is in preparation for being able to change the names of
the .data.page_aligned and .bss.page_aligned sections to be
compatabible with -ffunction-sections -fdata-sections.
This patch series doesn't touch the kernel's linker scripts, only the
C and assembly files. I've now sent to the LKML patches cleaning up
all the architecture linker scripts as well; the total diffstat for
this section name cleanup project targeted at 2.6.32 is:
79 files changed, 339 insertions(+), 1446 deletions(-)
Joe Perches (1):
Use new __init_task_data macro in arch init_task.c files.
Tim Abbott (4):
kbuild: Don't define ALIGN and ENTRY when preprocessing linker
scripts.
Use macros for .bss.page_aligned section.
powerpc: remove unused __page_aligned definition.
Use macros for .data.page_aligned section.
arch/arm/kernel/init_task.c | 5 ++---
arch/avr32/kernel/init_task.c | 5 ++---
arch/avr32/mm/init.c | 4 +---
arch/cris/kernel/process.c | 5 ++---
arch/frv/kernel/init_task.c | 5 ++---
arch/h8300/kernel/init_task.c | 5 ++---
arch/ia64/kernel/init_task.c | 3 ++-
arch/m32r/kernel/init_task.c | 5 ++---
arch/m68k/kernel/process.c | 6 +++---
arch/m68knommu/kernel/init_task.c | 5 ++---
arch/microblaze/kernel/init_task.c | 5 ++---
arch/mips/kernel/init_task.c | 5 ++---
arch/mn10300/kernel/init_task.c | 5 ++---
arch/parisc/kernel/init_task.c | 4 ++--
arch/powerpc/include/asm/page_64.h | 8 --------
arch/powerpc/kernel/init_task.c | 5 ++---
arch/powerpc/kernel/machine_kexec_64.c | 5 +++--
arch/powerpc/kernel/vdso.c | 3 ++-
arch/powerpc/kernel/vdso32/vdso32_wrapper.S | 3 ++-
arch/powerpc/kernel/vdso64/vdso64_wrapper.S | 3 ++-
arch/s390/kernel/init_task.c | 5 ++---
arch/s390/kernel/vdso.c | 2 +-
arch/s390/kernel/vdso32/vdso32_wrapper.S | 3 ++-
arch/s390/kernel/vdso64/vdso64_wrapper.S | 3 ++-
arch/sh/kernel/init_task.c | 5 ++---
arch/sh/kernel/irq.c | 6 ++----
arch/sparc/kernel/init_task.c | 5 ++---
arch/um/kernel/init_task.c | 5 ++---
arch/x86/include/asm/cache.h | 4 +++-
arch/x86/kernel/head_32.S | 4 ++--
arch/x86/kernel/head_64.S | 2 +-
arch/x86/kernel/init_task.c | 5 ++---
arch/xtensa/kernel/head.S | 2 +-
arch/xtensa/kernel/init_task.c | 5 ++---
include/linux/linkage.h | 2 ++
scripts/Makefile.build | 3 ++-
36 files changed, 69 insertions(+), 86 deletions(-)
next reply other threads:[~2009-09-09 2:49 UTC|newest]
Thread overview: 19+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-09-09 2:49 Tim Abbott [this message]
2009-09-09 2:49 ` [PATCH v2 1/5] kbuild: Don't define ALIGN and ENTRY when preprocessing linker scripts Tim Abbott
2009-09-09 2:49 ` [PATCH v2 2/5] Use new __init_task_data macro in arch init_task.c files Tim Abbott
2009-09-09 2:55 ` Paul Mundt
2009-09-09 2:58 ` Daniel Walker
2009-09-09 3:03 ` Joe Perches
2009-09-09 3:07 ` Daniel Walker
2009-09-09 3:10 ` Joe Perches
2009-09-09 3:21 ` Daniel Walker
2009-09-09 3:31 ` Joe Perches
2009-09-09 3:44 ` Daniel Walker
2009-09-09 3:49 ` Joe Perches
2009-09-09 3:32 ` Paul Mundt
2009-09-09 4:11 ` Dmitry Torokhov
2009-09-09 2:49 ` [PATCH v2 3/5] Use macros for .bss.page_aligned section Tim Abbott
2009-09-09 2:54 ` Paul Mundt
2009-09-09 2:49 ` [PATCH v2 4/5] powerpc: remove unused __page_aligned definition Tim Abbott
2009-09-11 7:33 ` Benjamin Herrenschmidt
2009-09-09 2:49 ` [PATCH v2 5/5] Use macros for .data.page_aligned section Tim Abbott
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1252464546-26394-1-git-send-email-tabbott@ksplice.com \
--to=tabbott@ksplice.com \
--cc=linux-kernel@vger.kernel.org \
--cc=sam@ravnborg.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®