From: Steven Rostedt <rostedt@goodmis.org>
To: Frederic Weisbecker <fweisbec@gmail.com>
Cc: Ingo Molnar <mingo@elte.hu>, LKML <linux-kernel@vger.kernel.org>,
Li Zefan <lizf@cn.fujitsu.com>
Subject: Re: [PATCH 2/3] tracing: Rename set_ftrace to set_bootup_ftrace
Date: Tue, 13 Oct 2009 09:22:07 -0400 [thread overview]
Message-ID: <1255440127.7113.1551.camel@gandalf.stny.rr.com> (raw)
In-Reply-To: <1255419540-5481-3-git-send-email-fweisbec@gmail.com>
On Tue, 2009-10-13 at 09:38 +0200, Frederic Weisbecker wrote:
> Do this rename because set_ftrace is too much generic and not enough
> self-explainable as a name.
>
> Signed-off-by: Frederic Weisbecker <fweisbec@gmail.com>
> Cc: Steven Rostedt <rostedt@goodmis.org>
> Cc: Li Zefan <lizf@cn.fujitsu.com>
> ---
> kernel/trace/trace.c | 4 ++--
> 1 files changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/kernel/trace/trace.c b/kernel/trace/trace.c
> index 4506826..866daf8 100644
> --- a/kernel/trace/trace.c
> +++ b/kernel/trace/trace.c
> @@ -129,7 +129,7 @@ static int tracing_set_tracer(const char *buf);
> static char bootup_tracer_buf[MAX_TRACER_SIZE] __initdata;
> static char *default_bootup_tracer;
>
> -static int __init set_ftrace(char *str)
> +static int __init set_bootup_ftrace(char *str)
> {
> strncpy(bootup_tracer_buf, str, MAX_TRACER_SIZE);
> default_bootup_tracer = bootup_tracer_buf;
> @@ -137,7 +137,7 @@ static int __init set_ftrace(char *str)
> ring_buffer_expanded = 1;
> return 1;
> }
> -__setup("ftrace=", set_ftrace);
> +__setup("ftrace=", set_bootup_ftrace);
Actually, it probably should be called, set_cmdline_ftrace. Since it
came from the command line, and that is what is matching.
-- Steve
>
> static int __init set_ftrace_dump_on_oops(char *str)
> {
next prev parent reply other threads:[~2009-10-13 13:24 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-10-13 7:38 [GIT PULL] tracing/core updates Frederic Weisbecker
2009-10-13 7:38 ` [PATCH 1/3] ftrace: add kernel command line graph function filtering Frederic Weisbecker
2009-10-13 8:06 ` Li Zefan
2009-10-13 8:58 ` Frédéric Weisbecker
2009-10-13 7:38 ` [PATCH 2/3] tracing: Rename set_ftrace to set_bootup_ftrace Frederic Weisbecker
2009-10-13 13:22 ` Steven Rostedt [this message]
2009-10-13 13:35 ` Frederic Weisbecker
2009-10-13 13:41 ` Steven Rostedt
2009-10-13 7:39 ` [PATCH 3/3] tracing: Remove unused ftrace_trace_addr helper Frederic Weisbecker
2009-10-13 10:04 ` [GIT PULL] tracing/core updates Ingo Molnar
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1255440127.7113.1551.camel@gandalf.stny.rr.com \
--to=rostedt@goodmis.org \
--cc=fweisbec@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=lizf@cn.fujitsu.com \
--cc=mingo@elte.hu \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®