From: Steven Rostedt <rostedt@goodmis.org>
To: Ingo Molnar <mingo@elte.hu>
Cc: Pekka Enberg <penberg@cs.helsinki.fi>,
Li Zefan <lizf@cn.fujitsu.com>,
Frederic Weisbecker <fweisbec@gmail.com>,
LKML <linux-kernel@vger.kernel.org>, Mel Gorman <mel@csn.ul.ie>
Subject: Re: [PATCH 2/9] tracing: Convert some kmem events to DEFINE_EVENT
Date: Thu, 26 Nov 2009 03:29:46 -0500 [thread overview]
Message-ID: <1259224186.21397.85.camel@gandalf.stny.rr.com> (raw)
In-Reply-To: <20091126075758.GA8011@elte.hu>
On Thu, 2009-11-26 at 08:57 +0100, Ingo Molnar wrote:
> * Pekka Enberg <penberg@cs.helsinki.fi> wrote:
>
> > Li Zefan kirjoitti:
> > >Use TRACE_EVENT_TEMPLATE to remove duplicate code:
> > >
> > > text data bss dec hex filename
> > > 333987 69800 27228 431015 693a7 mm/built-in.o.old
> > > 330030 69800 27228 427058 68432 mm/built-in.o
> > >
> > >8 events are converted:
> > >
> > > kmem_alloc: kmalloc, kmem_cache_alloc
> > > kmem_alloc_node: kmalloc_node, kmem_cache_alloc_node
> > > kmem_free: kfree, kmem_cache_free
> > > mm_page: mm_page_alloc_zone_locked, mm_page_pcpu_drain
> > >
> > >Signed-off-by: Li Zefan <lizf@cn.fujitsu.com>
> >
> > I have no idea what TRACE_EVENT_TEMPLATE is [...]
>
> Btw., the fact that it wasnt entirely obvious for you from the patch
> what it does, there's one rename we should do, to have more consistent
> and more self-explanatory naming:
>
> DECLARE_EVENT_CLASS(class)
>
> DEFINE_EVENT(class, event1)
> DEFINE_EVENT(class, event2)
> DEFINE_EVENT(class, event3)
>
> DEFINE_SINGLE_EVENT(single_event)
>
> Naming the 'standalone' variant like that signals this difference and
> encourages people to create classes/groups of events instead of creating
> many singular events.
I'm not really attached to the names, but I wouldn't go by it not being
obvious for Pekka as a reason for changing it. In the context of the
change log, if it were to say:
>Use DECLARE_EVENT_CLASS to remove duplicate code:
>
> text data bss dec hex filename
> 333987 69800 27228 431015 693a7 mm/built-in.o.old
> 330030 69800 27228 427058 68432 mm/built-in.o
>
>8 events are converted:
>
> kmem_alloc: kmalloc, kmem_cache_alloc
> kmem_alloc_node: kmalloc_node, kmem_cache_alloc_node
> kmem_free: kfree, kmem_cache_free
> mm_page: mm_page_alloc_zone_locked, mm_page_pcpu_drain
>
I'm not sure it would make it any more obvious to what the
class/template does. ;-)
-- Steve
next prev parent reply other threads:[~2009-11-26 8:29 UTC|newest]
Thread overview: 43+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-11-26 7:02 [PATCH 0/9] tracing: Convert some trace events to DEFINE_TRACE Li Zefan
2009-11-26 7:03 ` [PATCH 1/9] tracing: Convert module refcnt events to DEFINE_EVENT Li Zefan
2009-11-26 8:42 ` [tip:perf/core] " tip-bot for Li Zefan
2009-11-26 7:04 ` [PATCH 2/9] tracing: Convert some kmem " Li Zefan
2009-11-26 7:24 ` Pekka Enberg
2009-11-26 7:38 ` Steven Rostedt
2009-11-26 7:57 ` Ingo Molnar
2009-11-26 8:29 ` Steven Rostedt [this message]
2009-11-26 8:16 ` [tip:perf/core] events: Rename TRACE_EVENT_TEMPLATE() to DECLARE_EVENT_CLASS() tip-bot for Ingo Molnar
2009-11-26 8:33 ` Steven Rostedt
2009-11-26 8:40 ` Ingo Molnar
2009-11-26 14:45 ` Steven Rostedt
2009-11-26 17:55 ` Frederic Weisbecker
2009-11-26 18:12 ` Ingo Molnar
2009-11-26 19:12 ` Steven Rostedt
2009-11-26 19:20 ` Ingo Molnar
2009-11-26 19:44 ` Steven Rostedt
2009-11-26 19:47 ` Steven Rostedt
2009-11-26 23:13 ` Frederic Weisbecker
2009-11-27 3:52 ` Steven Rostedt
2009-11-26 8:42 ` [tip:perf/core] tracing: Convert some kmem events to DEFINE_EVENT tip-bot for Li Zefan
2009-11-26 12:34 ` [tip:perf/core] tracing: Fix kmem event exports tip-bot for Ingo Molnar
2009-11-26 7:04 ` [PATCH 3/9] tracing: Convert softirq events to DEFINE_EVENT Li Zefan
2009-11-26 8:43 ` [tip:perf/core] " tip-bot for Li Zefan
2009-11-26 7:05 ` [PATCH 4/9] tracing: Convert some workqueue " Li Zefan
2009-11-26 8:43 ` [tip:perf/core] " tip-bot for Li Zefan
2009-11-26 7:05 ` [PATCH 5/9] tracing: Convert some power " Li Zefan
2009-11-26 8:43 ` [tip:perf/core] " tip-bot for Li Zefan
2009-11-26 7:06 ` [PATCH 6/9] tracing: Convert some block " Li Zefan
2009-11-26 8:36 ` Jens Axboe
2009-11-26 8:44 ` Ingo Molnar
2009-11-26 8:47 ` Jens Axboe
2009-11-26 8:50 ` Ingo Molnar
2009-11-26 8:52 ` Jens Axboe
2009-11-26 8:43 ` [tip:perf/core] " tip-bot for Li Zefan
2009-11-26 7:06 ` [PATCH 7/9] tracing: Convert some jbd2 " Li Zefan
2009-11-26 8:44 ` [tip:perf/core] " tip-bot for Li Zefan
2009-11-26 7:07 ` [PATCH 8/9] tracing: Convert some ext4 events to DEFINE_TRACE Li Zefan
2009-11-26 8:44 ` [tip:perf/core] " tip-bot for Li Zefan
2009-11-26 7:08 ` [PATCH 9/9] tracing: Restore original format of sched events Li Zefan
2009-11-26 8:44 ` [tip:perf/core] " tip-bot for Li Zefan
2009-11-26 7:32 ` [PATCH 0/9] tracing: Convert some trace events to DEFINE_TRACE Steven Rostedt
2009-11-26 7:59 ` Ingo Molnar
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1259224186.21397.85.camel@gandalf.stny.rr.com \
--to=rostedt@goodmis.org \
--cc=fweisbec@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=lizf@cn.fujitsu.com \
--cc=mel@csn.ul.ie \
--cc=mingo@elte.hu \
--cc=penberg@cs.helsinki.fi \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®