mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Greg Kroah-Hartman <gregkh@suse.de>
To: linux-kernel@vger.kernel.org
Cc: "Eric W. Biederman" <ebiederm@xmission.com>,
	"Eric W. Biederman" <ebiederm@aristanetworks.com>,
	Greg Kroah-Hartman <gregkh@suse.de>
Subject: [PATCH 19/27] sysfs: Nicely indent sysfs_symlink_inode_operations
Date: Fri, 11 Dec 2009 14:24:41 -0800	[thread overview]
Message-ID: <1260570289-6997-19-git-send-email-gregkh@suse.de> (raw)
In-Reply-To: <20091211212642.GA6624@kroah.com>

From: Eric W. Biederman <ebiederm@xmission.com>

Lining up the functions in sysfs_symlink_inode_operations
follows the pattern in the rest of sysfs and makes things
slightly more readable.

Acked-by: Tejun Heo <tj@kernel.org>
Acked-by: Serge Hallyn <serue@us.ibm.com>
Signed-off-by: Eric W. Biederman <ebiederm@aristanetworks.com>
Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
---
 fs/sysfs/symlink.c |    8 ++++----
 1 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/fs/sysfs/symlink.c b/fs/sysfs/symlink.c
index c5081ad..1137418 100644
--- a/fs/sysfs/symlink.c
+++ b/fs/sysfs/symlink.c
@@ -210,10 +210,10 @@ static void sysfs_put_link(struct dentry *dentry, struct nameidata *nd, void *co
 }
 
 const struct inode_operations sysfs_symlink_inode_operations = {
-	.setxattr = sysfs_setxattr,
-	.readlink = generic_readlink,
-	.follow_link = sysfs_follow_link,
-	.put_link = sysfs_put_link,
+	.setxattr	= sysfs_setxattr,
+	.readlink	= generic_readlink,
+	.follow_link	= sysfs_follow_link,
+	.put_link	= sysfs_put_link,
 };
 
 
-- 
1.6.5.5


  parent reply	other threads:[~2009-12-11 22:33 UTC|newest]

Thread overview: 35+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2009-12-11 21:26 [GIT PATCH] driver core patches for 2.6.33-git Greg KH
2009-12-11 22:24 ` [PATCH 01/27] hpilo: add locking comment Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 02/27] sysfs: mark a locally-only used function static Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 03/27] Driver Core: devtmpfs: ignore umask while setting file mode Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 04/27] Driver core: devtmpfs: prevent concurrent subdirectory creation and removal Greg Kroah-Hartman
2009-12-21 13:37   ` Kirill A. Shutemov
2009-12-21 14:37     ` Kay Sievers
2009-12-22 14:10       ` Kirill A. Shutemov
2009-12-22 16:56         ` Greg KH
2009-12-22 16:57         ` Kay Sievers
2009-12-22 18:56           ` Kirill A. Shutemov
2009-12-22 21:25             ` Kay Sievers
2009-12-11 22:24 ` [PATCH 05/27] Driver Core: devtmpfs: use sys_mount() Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 06/27] Driver Core: devtmpfs: do not remove non-kernel-created directories Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 07/27] Driver Core: devtmpfs: cleanup node on device creation error Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 08/27] Driver-Core: devtmpfs - set root directory mode to 0755 Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 09/27] firmware_class: make request_firmware_nowait more useful Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 10/27] Driver core: Don't remove kobjects in device_shutdown Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 11/27] debugfs: fix create mutex racy fops and private data Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 12/27] sysfs: Update sysfs_setxattr so it updates secdata under the sysfs_mutex Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 13/27] sysfs: Rename sysfs_d_iput to sysfs_dentry_iput Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 14/27] sysfs: Use dentry_ops instead of directly playing with the dcache Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 15/27] sysfs: Simplify sysfs_chmod_file semantics Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 16/27] sysfs: Simplify iattr time assignments Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 17/27] sysfs: Fix locking and factor out sysfs_sd_setattr Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 18/27] sysfs: Update s_iattr on link and unlink Greg Kroah-Hartman
2009-12-11 22:24 ` Greg Kroah-Hartman [this message]
2009-12-11 22:24 ` [PATCH 20/27] sysfs: Implement sysfs_getattr & sysfs_permission Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 21/27] sysfs: In sysfs_chmod_file lazily propagate the mode change Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 22/27] sysfs: Gut sysfs_addrm_start and sysfs_addrm_finish Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 23/27] sysfs: Propagate renames to the vfs on demand Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 24/27] sysfs: Factor out sysfs_rename from sysfs_rename_dir and sysfs_move_dir Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 25/27] sysfs: sysfs_setattr remove unnecessary permission check Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 26/27] Driver Core: Early platform driver buffer Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 27/27] Driver core: fix race in dev_driver_string Greg Kroah-Hartman

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1260570289-6997-19-git-send-email-gregkh@suse.de \
    --to=gregkh@suse.de \
    --cc=ebiederm@aristanetworks.com \
    --cc=ebiederm@xmission.com \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®