From: "Paul E. McKenney" <paulmck@linux.vnet.ibm.com>
To: linux-kernel@vger.kernel.org
Cc: mingo@elte.hu, laijs@cn.fujitsu.com, dipankar@in.ibm.com,
akpm@linux-foundation.org, mathieu.desnoyers@polymtl.ca,
josh@joshtriplett.org, dvhltc@us.ibm.com, niv@us.ibm.com,
tglx@linutronix.de, peterz@infradead.org, rostedt@goodmis.org,
Valdis.Kletnieks@vt.edu, dhowells@redhat.com,
"Paul E. McKenney" <paulmck@linux.vnet.ibm.com>
Subject: [PATCH tip/core/rcu 07/18] sched: better name for for_each_domain_rd
Date: Wed, 17 Feb 2010 12:29:33 -0800 [thread overview]
Message-ID: <1266438584-29173-7-git-send-email-paulmck@linux.vnet.ibm.com> (raw)
In-Reply-To: <20100217202924.GA29007@linux.vnet.ibm.com>
As suggested by Peter Ziljstra, make better choice of name
for for_each_domain_rd(), containing "rcu_dereference", given
that it is but a wrapper for rcu_dereference_check(). The name
rcu_dereference_check_sched_domain() does that and provides a separate
per-subsystem name space.
Signed-off-by: Paul E. McKenney <paulmck@linux.vnet.ibm.com>
---
kernel/sched.c | 4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/kernel/sched.c b/kernel/sched.c
index ad419d9..478fc7d 100644
--- a/kernel/sched.c
+++ b/kernel/sched.c
@@ -645,7 +645,7 @@ static inline int cpu_of(struct rq *rq)
#endif
}
-#define for_each_domain_rd(p) \
+#define rcu_dereference_check_sched_domain(p) \
rcu_dereference_check((p), \
rcu_read_lock_sched_held() || \
lockdep_is_held(&sched_domains_mutex))
@@ -658,7 +658,7 @@ static inline int cpu_of(struct rq *rq)
* preempt-disabled sections.
*/
#define for_each_domain(cpu, __sd) \
- for (__sd = for_each_domain_rd(cpu_rq(cpu)->sd); __sd; __sd = __sd->parent)
+ for (__sd = rcu_dereference_check_sched_domain(cpu_rq(cpu)->sd); __sd; __sd = __sd->parent)
#define cpu_rq(cpu) (&per_cpu(runqueues, (cpu)))
#define this_rq() (&__get_cpu_var(runqueues))
--
1.6.6
next prev parent reply other threads:[~2010-02-17 20:34 UTC|newest]
Thread overview: 21+ messages / expand[flat|nested] mbox.gz Atom feed top
2010-02-17 20:29 [PATCH tip/core/rcu 0/18] v5 add lockdep-based diagnostics to rcu_dereference() Paul E. McKenney
2010-02-17 20:29 ` [PATCH tip/core/rcu 01/18] rcu: introduce lockdep-based checking to RCU read-side primitives Paul E. McKenney
2010-02-17 20:29 ` [PATCH tip/core/rcu 02/18] rcu: add lockdep-enabled variants of rcu_dereference() Paul E. McKenney
2010-02-17 20:29 ` [PATCH tip/core/rcu 03/18] rcu: integrate rcu_dereference_check() message into lockdep Paul E. McKenney
2010-02-17 20:29 ` [PATCH tip/core/rcu 04/18] rcu: disable lockdep checking in RCU list-traversal primitives Paul E. McKenney
2010-02-17 20:29 ` [PATCH tip/core/rcu 05/18] net: add checking to rcu_dereference() primitives Paul E. McKenney
2010-02-17 20:29 ` [PATCH tip/core/rcu 06/18] sched: use lockdep-based checking on rcu_dereference() Paul E. McKenney
2010-02-17 20:29 ` Paul E. McKenney [this message]
2010-02-17 20:29 ` [PATCH tip/core/rcu 08/18] vfs: apply lockdep-based checking to rcu_dereference() uses Paul E. McKenney
2010-02-17 20:29 ` [PATCH tip/core/rcu 09/18] vfs: abstract rcu_dereference_check for files-fdtable use Paul E. McKenney
2010-02-17 20:29 ` [PATCH tip/core/rcu 10/18] radix-tree: disable RCU lockdep checking in radix tree Paul E. McKenney
2010-02-17 20:29 ` [PATCH tip/core/rcu 11/18] idr: apply lockdep-based diagnostics to rcu_dereference() uses Paul E. McKenney
2010-02-17 20:29 ` [PATCH tip/core/rcu 12/18] security: apply lockdep-based checking " Paul E. McKenney
2010-02-17 20:29 ` [PATCH tip/core/rcu 13/18] rcu: documentation update for CONFIG_PROVE_RCU Paul E. McKenney
2010-02-17 20:29 ` [PATCH tip/core/rcu 14/18] rcu: fix citation of Mathieu's dissertation Paul E. McKenney
2010-02-17 20:29 ` [PATCH tip/core/rcu 15/18] rcu: accelerate grace period if last non-dynticked CPU Paul E. McKenney
2010-02-17 20:29 ` [PATCH tip/core/rcu 16/18] rcu: use canonical URL for Mathieu's dissertation Paul E. McKenney
2010-02-17 20:29 ` [PATCH tip/core/rcu 17/18] rcu: stop overflowing signed integers Paul E. McKenney
2010-02-17 21:30 ` Mathieu Desnoyers
2010-02-17 20:29 ` [PATCH tip/core/rcu 18/18] The spinlocks in rcutree need to be real spinlocks in preempt-rt. Convert them to raw_spinlocks Paul E. McKenney
2010-02-18 16:57 ` [PATCH tip/core/rcu 18/18 amended] rcu: Convert " Paul E. McKenney
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1266438584-29173-7-git-send-email-paulmck@linux.vnet.ibm.com \
--to=paulmck@linux.vnet.ibm.com \
--cc=Valdis.Kletnieks@vt.edu \
--cc=akpm@linux-foundation.org \
--cc=dhowells@redhat.com \
--cc=dipankar@in.ibm.com \
--cc=dvhltc@us.ibm.com \
--cc=josh@joshtriplett.org \
--cc=laijs@cn.fujitsu.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mathieu.desnoyers@polymtl.ca \
--cc=mingo@elte.hu \
--cc=niv@us.ibm.com \
--cc=peterz@infradead.org \
--cc=rostedt@goodmis.org \
--cc=tglx@linutronix.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®