From: Joe Perches <joe@perches.com>
To: Johan Meiring <johanmeiring@gmail.com>
Cc: gregkh@suse.de, devel@driverdev.osuosl.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 2/2] Staging: line6: fixed 80 character coding style issue in midibuf.c This is a patch to the midibuf.c file that fixes up an 80 character error thrown by the checkpatch.pl tool Signed-off-by: Johan Meiring <johanmeiring@gmail.com>
Date: Sun, 28 Mar 2010 13:05:31 -0700 [thread overview]
Message-ID: <1269806731.1500.60.camel@Joe-Laptop.home> (raw)
In-Reply-To: <1269804998-7169-1-git-send-email-johanmeiring@gmail.com>
On Sun, 2010-03-28 at 21:36 +0200, Johan Meiring wrote:
> ---
> drivers/staging/line6/midibuf.c | 9 ++++++---
> 1 files changed, 6 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/staging/line6/midibuf.c b/drivers/staging/line6/midibuf.c
> index ab0a5f3..fb2658d 100644
> --- a/drivers/staging/line6/midibuf.c
> +++ b/drivers/staging/line6/midibuf.c
> @@ -76,7 +76,8 @@ int midibuf_bytes_free(struct MidiBuffer *this)
> return
> midibuf_is_full(this) ?
> 0 :
> - (this->pos_read - this->pos_write + this->size - 1) % this->size + 1;
> + (this->pos_read - this->pos_write + this->size - 1) % \
> + this->size + 1;
It's not necessary to use line continuations like this.
this is an unfortunate variable name, it might be better
to rename it to mb or something.
The "(write - read + size) % size + 1" might be used a
couple of times. Maybe use a macro or function?
prev parent reply other threads:[~2010-03-28 20:05 UTC|newest]
Thread overview: 2+ messages / expand[flat|nested] mbox.gz Atom feed top
2010-03-28 19:36 Johan Meiring
2010-03-28 20:05 ` Joe Perches [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1269806731.1500.60.camel@Joe-Laptop.home \
--to=joe@perches.com \
--cc=devel@driverdev.osuosl.org \
--cc=gregkh@suse.de \
--cc=johanmeiring@gmail.com \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®