On Tue, 2010-07-20 at 11:46 +0400, Anton Vorontsov wrote: > On Tue, Jul 20, 2010 at 01:02:55AM +0100, Ben Hutchings wrote: > > commit 9b9ade6b612e562c4a5bd02ef38cc32e10f3f9ba "ds2782_battery: Add > > support for ds2786 battery gas gauge" introduced an operation named > > get_current. Since get_current() is defined as a macro on some > > architectures this driver no longer compiles on those architectures. > > > > Rename get_current to get_current_now to avoid the macro. > > Rename get_voltage to get_voltage_now for consistency. > > > > Reported-by: Geert Stappers > > Signed-off-by: Ben Hutchings > > --- > > Thanks for the patch, but I have a similar fix in the > battery-2.6.git tree (for -next): [...] This fix needs to go into 2.6.35. Ben. -- Ben Hutchings Once a job is fouled up, anything done to improve it makes it worse.