mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Nicholas A. Bellinger" <nab@linux-iscsi.org>
To: Konrad Rzeszutek Wilk <konrad@darnok.org>
Cc: linux-scsi <linux-scsi@vger.kernel.org>,
	linux-kernel <linux-kernel@vger.kernel.org>,
	FUJITA Tomonori <fujita.tomonori@lab.ntt.co.jp>,
	Mike Christie <michaelc@cs.wisc.edu>,
	Christoph Hellwig <hch@lst.de>, Hannes Reinecke <hare@suse.de>,
	James Bottomley <James.Bottomley@suse.de>,
	Jens Axboe <axboe@kernel.dk>, Boaz Harrosh <bharrosh@panasas.com>
Subject: Re: [RFC 04/22] tcm: Add v4 base data structures and struct target_core_fabric_ops
Date: Sat, 04 Sep 2010 16:53:10 -0700	[thread overview]
Message-ID: <1283644390.556.74.camel@haakon2.linux-iscsi.org> (raw)
In-Reply-To: <1283455187.5598.86.camel@haakon2.linux-iscsi.org>

On Thu, 2010-09-02 at 12:19 -0700, Nicholas A. Bellinger wrote:
> On Thu, 2010-09-02 at 01:56 -0400, Konrad Rzeszutek Wilk wrote:
> > On Monday 30 August 2010 05:20:40 Nicholas A. Bellinger wrote:
> > > From: Nicholas Bellinger <nab@linux-iscsi.org>
> > 
> > Hey Nicholas,
> > 
> > I did a cursory review .
> > 

<BIG SNIP>

> 
> Ok, I will go ahead and make the changes per the above comments and will
> drop you a line when the push is ready.  I do agree that mixing the
> struct variables with #defines in target_core_base.h does make things a
> bit more readable.  Let me consider this a bit.
> 
> Any comments from the kernel folks on this particular item..?
> 
> Thanks for your comments Konrad!
> 

Hi Konard,

I just pushed most of your recommend cleanups for target_core_base.h to
lio-core-2.6.git/lio-4.0.  The cleanup series has been posted on
lio-devel list to prevent extra noise on linux-scsi, et al, but for
reference the shortlog and diffstat are attached below..  I did not dive
into intermixed struct + #defines, but I am still pretty indifferent on
this particular item.

Please have a look and feel free to make additional comments.

Thanks again!

--nab

Nicholas Bellinger (13):
  tcm: Remove legacy struct se_lun->lun_type usage
  tcm: Remove legacy DEV_STATUS_THR_* defines
  tcm: Convert TCM base defines to enums, round 1
  tcm: Convert NAF_DYNAMIC_NODE_ACL to struct
    se_node_acl->dynamic_node_acl bitfield
  tcm: Convert MAP_SG_KMAP to struct se_map_sg->sg_kmap_active bitfield
  tcm: Convert TCM base defines to enums, round 2:
  tcm: Convert DEF_PR_REGISTERED to struct
    se_dev_entry->def_pr_registered bitfield
  tcm: Convert PRF_ISID_PRESENT_AT_REG to struct
    t10_pr_registration->isid_present_at_reg bitfield
  tcm: Convert struct se_cmd->scsi_sense_reason enum and add TCM_*
    prefix
  tcm: Add comments for t10_alua_index_t, t10_task_attr_index_t and
    t10_reservations_index_t
  tcm/pr: Add proper comment for struct
    t10_reservation_template->pr_res_holder
  tcm/alua: Move (*t10_*)() callers into struct t10_reservation_ops
  tcm: Cleanups for struct se_transport_task usage

 drivers/target/lio-target/iscsi_target.c       |   12 +-
 drivers/target/lio-target/iscsi_target_erl0.c  |    4 +-
 drivers/target/lio-target/iscsi_target_mib.c   |    6 +-
 drivers/target/lio-target/iscsi_target_util.c  |    6 +-
 drivers/target/target_core_device.c            |   17 +-
 drivers/target/target_core_fabric_lib.c        |    5 +-
 drivers/target/target_core_file.c              |    2 +-
 drivers/target/target_core_iblock.c            |    2 +-
 drivers/target/target_core_mib.c               |    6 +-
 drivers/target/target_core_pr.c                |   46 ++--
 drivers/target/target_core_rd.c                |    6 +-
 drivers/target/target_core_tpg.c               |   38 +--
 drivers/target/target_core_transport.c         |  161 ++++++------
 drivers/target/tcm_fc/tfc_cmd.c                |    4 +-
 drivers/target/tcm_fc/tfc_io.c                 |    4 +-
 drivers/target/tcm_loop/tcm_loop_fabric_scsi.c |    4 +-
 include/target/target_core_base.h              |  314 ++++++++++++++----------
 include/target/target_core_tpg.h               |    4 +-
 18 files changed, 331 insertions(+), 310 deletions(-)



  reply	other threads:[~2010-09-04 23:57 UTC|newest]

Thread overview: 11+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-08-30  9:20 Nicholas A. Bellinger
2010-09-02  5:56 ` Konrad Rzeszutek Wilk
2010-09-02 19:19   ` Nicholas A. Bellinger
2010-09-04 23:53     ` Nicholas A. Bellinger [this message]
2010-09-05  0:35       ` ldd scull_load question runcoderen
2010-09-05  0:43         ` Randy Dunlap
2010-09-05  1:01           ` runcoderen
2010-09-05 21:20             ` Randy Dunlap
2010-09-05  3:21         ` Adam Jiang
2010-09-07 20:56       ` [RFC 04/22] tcm: Add v4 base data structures and struct target_core_fabric_ops Konrad Rzeszutek Wilk
2010-09-08  1:44         ` Nicholas A. Bellinger

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1283644390.556.74.camel@haakon2.linux-iscsi.org \
    --to=nab@linux-iscsi.org \
    --cc=James.Bottomley@suse.de \
    --cc=axboe@kernel.dk \
    --cc=bharrosh@panasas.com \
    --cc=fujita.tomonori@lab.ntt.co.jp \
    --cc=hare@suse.de \
    --cc=hch@lst.de \
    --cc=konrad@darnok.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-scsi@vger.kernel.org \
    --cc=michaelc@cs.wisc.edu \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®