mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Robert Richter <robert.richter@amd.com>
To: Ingo Molnar <mingo@elte.hu>
Cc: LKML <linux-kernel@vger.kernel.org>,
	oprofile-list <oprofile-list@lists.sourceforge.net>,
	Will Deacon <will.deacon@arm.com>,
	Matt Fleming <matt@console-pimps.org>,
	Robert Richter <robert.richter@amd.com>
Subject: [PATCH 4/5] oprofile, ARM: Remove some goto statements
Date: Fri, 1 Oct 2010 17:56:26 +0200	[thread overview]
Message-ID: <1285948587-24521-5-git-send-email-robert.richter@amd.com> (raw)
In-Reply-To: <1285948587-24521-1-git-send-email-robert.richter@amd.com>

This patch removes some unnecessary goto statements.

Cc: Will Deacon <will.deacon@arm.com>
Signed-off-by: Robert Richter <robert.richter@amd.com>
---
 arch/arm/oprofile/common.c |    6 ++----
 1 files changed, 2 insertions(+), 4 deletions(-)

diff --git a/arch/arm/oprofile/common.c b/arch/arm/oprofile/common.c
index cec9305..ab875f3 100644
--- a/arch/arm/oprofile/common.c
+++ b/arch/arm/oprofile/common.c
@@ -135,11 +135,10 @@ static int op_perf_start(void)
 		for (event = 0; event < perf_num_counters; ++event) {
 			ret = op_create_counter(cpu, event);
 			if (ret)
-				goto out;
+				return ret;
 		}
 	}
 
-out:
 	return ret;
 }
 
@@ -263,7 +262,7 @@ static int __init init_driverfs(void)
 
 	ret = platform_driver_register(&oprofile_driver);
 	if (ret)
-		goto out;
+		return ret;
 
 	oprofile_pdev =	platform_device_register_simple(
 				oprofile_driver.driver.name, 0, NULL, 0);
@@ -272,7 +271,6 @@ static int __init init_driverfs(void)
 		platform_driver_unregister(&oprofile_driver);
 	}
 
-out:
 	return ret;
 }
 
-- 
1.7.2.2



  parent reply	other threads:[~2010-10-01 16:02 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-10-01 15:56 [PATCH 0/5] oprofile updates for v2.6.37 Robert Richter
2010-10-01 15:56 ` [PATCH 1/5] oprofile, x86: Simplify init/exit functions Robert Richter
2010-10-01 15:56 ` [PATCH 2/5] oprofile, ARM: Use oprofile_arch_exit() to cleanup on failure Robert Richter
2010-10-01 15:56 ` [PATCH 3/5] oprofile, ARM: Rework op_create_counter() Robert Richter
2010-10-01 15:56 ` Robert Richter [this message]
2010-10-01 15:56 ` [PATCH 5/5] oprofile: Remove duplicate code around __oprofilefs_create_file() Robert Richter
2010-10-01 17:05 ` [PATCH 0/5] oprofile updates for v2.6.37 Will Deacon
2010-10-05 10:31 ` Robert Richter

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1285948587-24521-5-git-send-email-robert.richter@amd.com \
    --to=robert.richter@amd.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=matt@console-pimps.org \
    --cc=mingo@elte.hu \
    --cc=oprofile-list@lists.sourceforge.net \
    --cc=will.deacon@arm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome