From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1754710Ab0KETU7 (ORCPT ); Fri, 5 Nov 2010 15:20:59 -0400 Received: from mail-ey0-f174.google.com ([209.85.215.174]:48526 "EHLO mail-ey0-f174.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753283Ab0KETUz (ORCPT ); Fri, 5 Nov 2010 15:20:55 -0400 DomainKey-Signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=subject:from:to:cc:in-reply-to:references:content-type:date :message-id:mime-version:x-mailer:content-transfer-encoding; b=AbJUAXY48oR7apTNO9bjMGMEyinkHpnX3gkVQdLtWFqXM4SAOhjfanxX0BS2prMDi0 tmzD+7VyPQkfw7tx5uhRtSqzC9Zp1tF69pVRqmXmSNgTCr/dQGrooJegD17kT/vhOZJ1 fDkG65zI/E4EK/6ip8jJe/Ris65Th6r/SGnUc= Subject: Re: [PATCH] atomic: add atomic_inc_not_zero_hint() From: Eric Dumazet To: Andrew Morton Cc: linux-kernel , David Miller , netdev , Arnaldo Carvalho de Melo , Christoph Lameter , Ingo Molnar , Andi Kleen , "Paul E. McKenney" , Nick Piggin In-Reply-To: <20101105112821.57f80481.akpm@linux-foundation.org> References: <1288975980.2882.877.camel@edumazet-laptop> <20101105102038.53e36f9e.akpm@linux-foundation.org> <1288980046.2882.1054.camel@edumazet-laptop> <20101105110828.52f061b3.akpm@linux-foundation.org> <1288981224.2882.1105.camel@edumazet-laptop> <20101105112821.57f80481.akpm@linux-foundation.org> Content-Type: text/plain; charset="UTF-8" Date: Fri, 05 Nov 2010 20:20:44 +0100 Message-ID: <1288984844.2665.52.camel@edumazet-laptop> Mime-Version: 1.0 X-Mailer: Evolution 2.30.3 Content-Transfer-Encoding: 8bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Le vendredi 05 novembre 2010 à 11:28 -0700, Andrew Morton a écrit : > But we haven't established that there _is_ duplicated code which needs > that treatment. > > Scanning arch/x86/include/asm/atomic.h, perhaps ATOMIC_INIT() is a > candidate. But I'm not sure that it _should_ be hoisted up - if every > architecture happens to do it the same way then that's just a fluke. > > Not sure I understand you. I was trying to avoid recursive includes, but that should be protected anyway. I see a lot of code that could be factorized in this new header (atomic_inc_not_zero() for example) Thanks [PATCH v3] atomic: add atomic_inc_not_zero_hint() Followup of perf tools session in Netfilter WorkShop 2010 In network stack we make high usage of atomic_inc_not_zero() in contexts we know the probable value of atomic before increment (2 for udp sockets for example) Using a special version of atomic_inc_not_zero() giving this hint can help processor to use less bus transactions. On x86 (MESI protocol) for example, this avoids entering Shared state, because "lock cmpxchg" issues an RFO (Read For Ownership) Signed-off-by: Eric Dumazet Cc: Christoph Lameter Cc: Ingo Molnar Cc: Andi Kleen Cc: Arnaldo Carvalho de Melo Cc: David Miller Cc: "Paul E. McKenney" Cc: Nick Piggin --- V3: adds the include if hint is null, use atomic_inc_not_zero() (Paul suggestion) V2: add #ifndef atomic_inc_not_zero_hint kerneldoc changes test that hint is not null Meant to be included at end of arch/*/asm/atomic.h files diff --git a/include/linux/atomic.h b/include/linux/atomic.h new file mode 100644 index 0000000..5a7df87 --- /dev/null +++ b/include/linux/atomic.h @@ -0,0 +1,37 @@ +#ifndef _LINUX_ATOMIC_H +#define _LINUX_ATOMIC_H +#include + +/** + * atomic_inc_not_zero_hint - increment if not null + * @v: pointer of type atomic_t + * @hint: probable value of the atomic before the increment + * + * This version of atomic_inc_not_zero() gives a hint of probable + * value of the atomic. This helps processor to not read the memory + * before doing the atomic read/modify/write cycle, lowering + * number of bus transactions on some arches. + * + * Returns: 0 if increment was not done, 1 otherwise. + */ +#ifndef atomic_inc_not_zero_hint +static inline int atomic_inc_not_zero_hint(atomic_t *v, int hint) +{ + int val, c = hint; + + /* sanity test, should be removed by compiler if hint is a constant */ + if (!hint) + return atomic_inc_not_zero(v); + + do { + val = atomic_cmpxchg(v, c, c + 1); + if (val == c) + return 1; + c = val; + } while (c); + + return 0; +} +#endif + +#endif /* _LINUX_ATOMIC_H */