From: Ben Skeggs <bskeggs@redhat.com>
To: Andrew Lutomirski <luto@mit.edu>
Cc: dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 2/2] nouveau: Acknowledge HPD irq in handler, not bottom half
Date: Thu, 11 Nov 2010 08:58:57 +1000 [thread overview]
Message-ID: <1289429937.9605.11.camel@nisroch> (raw)
In-Reply-To: <AANLkTinBTnJ0OjVkcYDQmYZ_HjqE4NCSHnCvD1_p_DJs@mail.gmail.com>
On Wed, 2010-11-10 at 17:51 -0500, Andrew Lutomirski wrote:
> On Wed, Nov 10, 2010 at 5:35 PM, Ben Skeggs <bskeggs@redhat.com> wrote:
> > On Wed, 2010-11-10 at 17:25 -0500, Andrew Lutomirski wrote:
> >> On Wed, Nov 10, 2010 at 5:10 PM, Ben Skeggs <bskeggs@redhat.com> wrote:
> >> > On Wed, 2010-11-10 at 16:32 -0500, Andy Lutomirski wrote:
> >> >> The old code generated an interrupt storm bad enough to completely
> >> >> take down my system.
> >> >>
> >> >> This only fixes the bits that are defined nouveau_regs.h. Newer hardware
> >> >> uses another register that isn't described, and I don't have that hardware
> >> >> to test.
> >> > Thanks for looking at this. I'll take a closer look at the problem
> >> > today and see what I can come up with too, that'll work with the newer
> >> > hardware too.
> >>
> >> It should be as simple as adding an hpd1 field to the hpd_state and
> >> making exactly the same change. (It would be nice to put the register
> >> definitions into nouveau_regs.h as well -- I didn't really want to
> >> muck around with a bunch of magic numbers that I can't test.)
> > Yes, it is. I can confirm the problem on another card, but it doesn't
> > actually cause any crashes here. If you can rework the patch to support
> > the newer chips too, that'd be great.
> >
> > As for magic numbers, the register names for those regs are wrong
> > anyway. The joy of reverse-engineering the support. It doesn't really
> > matter if you want to stick to them or go back to "magic" numbers.
>
> That explains why INTR and CTRL seemed backwards :) I'll leave the
> magic numbers for the 0xe07? stuff.
That sounds good, it'll all get a cleanup at some point and switched to
"proper" (well, our best guess, you'd have to ask NVIDIA about the real
ones) names.
Ben.
>
> Also, I accidentally dropped the "& enabled_bits" part -- I'll put that back.
>
> Patch to follow after I boot and test it here.
>
> --Andy
next prev parent reply other threads:[~2010-11-10 22:59 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2010-11-10 19:28 Severe reproducible nouveau breakage in 2.6.36 (and maybe .35) Andrew Lutomirski
2010-11-10 20:06 ` Andrew Lutomirski
2010-11-10 21:21 ` [PATCH 0/2] Fix nouveau-related freezes Andy Lutomirski
2010-11-10 21:32 ` Andy Lutomirski
2010-11-10 21:32 ` [PATCH 1/2] Use existing defines for NV50 hotplug registers Andy Lutomirski
2010-11-10 21:32 ` [PATCH 2/2] nouveau: Acknowledge HPD irq in handler, not bottom half Andy Lutomirski
2010-11-10 22:10 ` Ben Skeggs
2010-11-10 22:25 ` Andrew Lutomirski
2010-11-10 22:35 ` Ben Skeggs
2010-11-10 22:51 ` Andrew Lutomirski
2010-11-10 22:55 ` Maarten Maathuis
2010-11-10 23:01 ` Andrew Lutomirski
2010-11-10 23:12 ` Ben Skeggs
2010-11-10 22:58 ` Ben Skeggs [this message]
2010-11-10 23:04 [PATCH v2 0/2] Fix nouveau-related freezes Andy Lutomirski
2010-11-10 23:04 ` [PATCH 2/2] nouveau: Acknowledge HPD irq in handler, not bottom half Andy Lutomirski
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1289429937.9605.11.camel@nisroch \
--to=bskeggs@redhat.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=linux-kernel@vger.kernel.org \
--cc=luto@mit.edu \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome