mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Eric Paris <eparis@redhat.com>
To: Lino Sanfilippo <LinoSanfilippo@gmx.de>
Cc: linux-kernel@vger.kernel.org, linux-fsdevel@vger.kernel.org,
	viro@zeniv.linux.org.uk
Subject: Re: [PATCH 0/14] fsnotify: simplify locking
Date: Wed, 19 Jan 2011 12:12:51 -0500	[thread overview]
Message-ID: <1295457172.21577.19.camel@localhost.localdomain> (raw)
In-Reply-To: <1295455337-20219-1-git-send-email-LinoSanfilippo@gmx.de>

On Wed, 2011-01-19 at 17:42 +0100, Lino Sanfilippo wrote:

> The main goal of these patches is to change the locking order to 
> 
> group->mark_lock
> inode->i_lock
> mark->lock

There was a LOT of thought that went into the object locking and
lifetime to make sure it was safe, but I agree it is, ummm, complex.
I'll look at these patches but offhand I seem to recall that (by
definition) inode->i_lock was always supposed to be the smallest lock
ever held.  I added Al a VFS guy, who might veto these patches just on
that alone......

-Eric


      parent reply	other threads:[~2011-01-19 17:13 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-01-19 16:42 Lino Sanfilippo
2011-01-19 16:42 ` [PATCH 01/14] fsnotify: change locking order in fsnotify_add_mark() Lino Sanfilippo
2011-01-19 16:42 ` [PATCH 02/14] fsnotify: rename fsnotify_add_mark() to fsnotify_add_mark_locked() Lino Sanfilippo
2011-01-19 16:42 ` [PATCH 03/14] fsnotify: adjust locking in fsnotify_add_[inode|vfsmount]_mark() Lino Sanfilippo
2011-01-19 16:42 ` [PATCH 04/14] fsnotify: simplify fsnotify_destroy_mark() Lino Sanfilippo
2011-01-19 16:42 ` [PATCH 05/14] fsnotify: synchronize mark_srcu after a mark has been removed from a fsobject Lino Sanfilippo
2011-01-19 16:42 ` [PATCH 06/14] fsnotify: clear fsobject marks with object lock held Lino Sanfilippo
2011-01-19 16:42 ` [PATCH 07/14] fsnotify: handle number of marks and group ref counting independently from each other Lino Sanfilippo
2011-01-19 16:42 ` [PATCH 08/14] fanotify: add an extra flag to mark_remove_from_mask that indicates wheather a mark could be destroyed Lino Sanfilippo
2011-01-19 16:42 ` [PATCH 09/14] fsnotify: add new function fsnotify_remove_mark_locked() Lino Sanfilippo
2011-01-19 16:42 ` [PATCH 10/14] fanotify,dnotify,inotify,audit: replace destroy_mark() with remove_mark_locked() Lino Sanfilippo
2011-01-19 17:12 ` Eric Paris [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1295457172.21577.19.camel@localhost.localdomain \
    --to=eparis@redhat.com \
    --cc=LinoSanfilippo@gmx.de \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=viro@zeniv.linux.org.uk \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®