From: "Nicholas A. Bellinger" <nab@linux-iscsi.org>
To: Christoph Hellwig <hch@lst.de>
Cc: linux-scsi <linux-scsi@vger.kernel.org>,
linux-kernel <linux-kernel@vger.kernel.org>,
James Bottomley <James.Bottomley@HansenPartnership.com>,
Mike Christie <michaelc@cs.wisc.edu>,
Hannes Reinecke <hare@suse.de>,
FUJITA Tomonori <fujita.tomonori@lab.ntt.co.jp>,
Boaz Harrosh <bharrosh@panasas.com>,
Joel Becker <jlbec@evilplan.org>,
Stephen Rothwell <sfr@canb.auug.org.au>,
Douglas Gilbert <dgilbert@interlog.com>
Subject: Re: [PATCH 21/21] tcm_loop: Add multi-fabric Linux/SCSI LLD fabric module
Date: Wed, 16 Mar 2011 17:50:36 -0700 [thread overview]
Message-ID: <1300323036.28255.480.camel@haakon2.linux-iscsi.org> (raw)
In-Reply-To: <20110315101838.GB23623@lst.de>
On Tue, 2011-03-15 at 11:18 +0100, Christoph Hellwig wrote:
> On Mon, Mar 14, 2011 at 03:02:55PM -0700, Nicholas A. Bellinger wrote:
> > > Please descide on a naming scheme for the frontend modules. You have
> > > tcm_loop for thise one, and just iscsi for the iscsi frontend.
> >
> > Ok, curently everything that appears under drivers/target/ beside
> > iscsi_target_mod.ko is using a matching drivers/target/$FABRIC_MOD/ and
> > $FABRIC_MOD.ko naming scheme.
> >
> > I would prefer to keep iscsi_target_mod.ko for the software iSCSI case
> > in order to prevent chaos with existing userspace tools and prevent
> > breakage with existing other iSCSI target modules (IET is using
> > iscsi_trgt.ko IIRC).
> >
> > How about dropping the 'tcm_' prefix from the drivers/target/tcm_subdir/
> > to follow how the fabric module actually appears once loaded under
> > /sys/kernel/config/target/$FABRIC/..? We will need to keep the common
> > 'tcm_' prefix for the actual target fabric modules (or choose a
> > different one) to handle those that interface with existing SCSI LLD
> > code.
>
> Dropping the tcm sounds fine to me.
>
<nod>
> > This makes it a bit easier to grok as a reference for newcomers by
> > having seperate sections for configfs control plane, struct
> > target_core_fabric_ops API callers, and Linux/SCSI LLD specific glue.
>
> I don't think it's a very good reference, though. E.g. currently the
> fabric ops methods are implemented in tcm_loop_fabric.c, and all need
> non-static scope because they are assigned in tcm_loop_configfs.c, which
> creates a lot of global scope and pointless prototypes. Either one
> could clean all that up or just merge the files into one which would
> be a lot easier. Especiall as the way the target_fabric_configfs structure
> and the fabric ops are structured will get a big overhaul from me soon.
>
Ok, fair enough.. I will go ahead and look at getting this cleaned up.
In the mean time, James please go ahead and apply patches #1 -> #20 from
this target core series to scsi-misc as I have no futher changes to
report at this time. I will send out an updated PATCH 21/21 addressing
Christoph's comments for merging tcm_loop.ko shortly, and another RFC-v3
series addressing his comments for the initial iscsi_target_mod merge in
the next 24 hours.
--nab
prev parent reply other threads:[~2011-03-17 0:57 UTC|newest]
Thread overview: 26+ messages / expand[flat|nested] mbox.gz Atom feed top
2011-03-14 11:05 [PATCH 00/21] target patches for .39 scsi-misc (v3) Nicholas A. Bellinger
2011-03-14 11:05 ` [PATCH 01/21] target: Fix memory leak on error path in pscsi_alloc_task Nicholas A. Bellinger
2011-03-14 11:05 ` [PATCH 02/21] target: Fix match_strdup() memory leaks Nicholas A. Bellinger
2011-03-14 11:05 ` [PATCH 03/21] target: tcm_mod_builder.py generated Makefile cleanups Nicholas A. Bellinger
2011-03-14 11:05 ` [PATCH 04/21] target: remove EXTRA_CFLAGS Nicholas A. Bellinger
2011-03-14 11:05 ` [PATCH 05/21] target: Convert backend ->create_virtdevice() call to return ERR_PTR Nicholas A. Bellinger
2011-03-14 11:06 ` [PATCH 06/21] target: Remove unnecessary hba_dev_list walk and se_clear_dev_ports legacy code Nicholas A. Bellinger
2011-03-14 11:06 ` [PATCH 07/21] target: Minor sparse warning fixes and annotations Nicholas A. Bellinger
2011-03-14 11:06 ` [PATCH 08/21] target: Remove spurious double cast from structure macro accessors Nicholas A. Bellinger
2011-03-14 11:06 ` [PATCH 09/21] target: Convert rd_build_device_space() to use errno Nicholas A. Bellinger
2011-03-14 11:06 ` [PATCH 10/21] target: Convert TMR REQ/RSP definitions to target namespace Nicholas A. Bellinger
2011-03-14 11:06 ` [PATCH 11/21] target: Avoid mem leak and needless work in transport_generic_get_mem Nicholas A. Bellinger
2011-03-14 11:06 ` [PATCH 12/21] target: Fix bogus return in transport_add_device_to_core_hba failure path Nicholas A. Bellinger
2011-03-14 11:06 ` [PATCH 13/21] target: Fix generated *_drop_nodeacl() handler in tcm_mod_builder.py Nicholas A. Bellinger
2011-03-14 11:06 ` [PATCH 14/21] target: Fix FILEIO fd_buffered_io= token typo Nicholas A. Bellinger
2011-03-14 11:06 ` [PATCH 15/21] target: Add __init/__exit annotation for target_core_[init,exit]_configfs Nicholas A. Bellinger
2011-03-14 11:06 ` [PATCH 16/21] target core v4.0.0-rc7-ml Nicholas A. Bellinger
2011-03-14 11:06 ` [PATCH 17/21] target: add initial device backend context target_core_stat.c code Nicholas A. Bellinger
2011-03-14 11:06 ` [PATCH 18/21] target: add initial fabric port " Nicholas A. Bellinger
2011-03-14 11:06 ` [PATCH 19/21] target: add initial fabric MappedLUN " Nicholas A. Bellinger
2011-03-14 11:06 ` [PATCH 20/21] target: Add fabric_stat_group for fabric module statistics default_group Nicholas A. Bellinger
2011-03-14 11:06 ` [PATCH 21/21] tcm_loop: Add multi-fabric Linux/SCSI LLD fabric module Nicholas A. Bellinger
2011-03-14 14:58 ` Christoph Hellwig
2011-03-14 22:02 ` Nicholas A. Bellinger
2011-03-15 10:18 ` Christoph Hellwig
2011-03-17 0:50 ` Nicholas A. Bellinger [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1300323036.28255.480.camel@haakon2.linux-iscsi.org \
--to=nab@linux-iscsi.org \
--cc=James.Bottomley@HansenPartnership.com \
--cc=bharrosh@panasas.com \
--cc=dgilbert@interlog.com \
--cc=fujita.tomonori@lab.ntt.co.jp \
--cc=hare@suse.de \
--cc=hch@lst.de \
--cc=jlbec@evilplan.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-scsi@vger.kernel.org \
--cc=michaelc@cs.wisc.edu \
--cc=sfr@canb.auug.org.au \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®