From: Joerg Roedel <joerg.roedel@amd.com>
To: <iommu@lists.linux-foundation.org>
Cc: <linux-kernel@vger.kernel.org>
Subject: [PATCH 0/9] Rework command handling of AMD IOMMU driver
Date: Thu, 7 Apr 2011 15:29:55 +0200 [thread overview]
Message-ID: <1302183004-4081-1-git-send-email-joerg.roedel@amd.com> (raw)
Hi,
this patch-set reworks the command handling in the AMD IOMMU driver. The
functions are better named now and more clearly splitted. Some cases are
also better handled now than before, like the situation of congestion in
the command buffer.
To further increase maintainability the driver now flushes all internal
caches of the IOMMU right after it gets enabled and does not rely on
flushing individual caches before they are used.
Any feedback appreciated.
Regards,
Joerg
Diffstat:
arch/x86/include/asm/amd_iommu_proto.h | 2 -
arch/x86/include/asm/amd_iommu_types.h | 3 -
arch/x86/kernel/amd_iommu.c | 415 +++++++++++++++-----------------
arch/x86/kernel/amd_iommu_init.c | 11 +-
4 files changed, 202 insertions(+), 229 deletions(-)
Shortlog:
Joerg Roedel (9):
x86/amd-iommu: Move compl-wait command building to own function
x86/amd-iommu: Move inv-dte command building to own function
x86/amd-iommu: Cleanup inv_pages command handling
x86/amd-iommu: Cleanup completion-wait handling
x86/amd-iommu: Remove command buffer resetting logic
x86/amd-iommu: Rename iommu_flush* to domain_flush*
x86/amd-iommu: Improve handling of full command buffer
x86/amd-iommu: Rename iommu_flush_device
x86/amd-iommu: Flush all internal TLBs when IOMMUs are enabled
next reply other threads:[~2011-04-07 13:30 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2011-04-07 13:29 Joerg Roedel [this message]
2011-04-07 13:29 ` [PATCH 1/9] x86/amd-iommu: Move compl-wait command building to own function Joerg Roedel
2011-04-07 13:29 ` [PATCH 2/9] x86/amd-iommu: Move inv-dte " Joerg Roedel
2011-04-07 13:29 ` [PATCH 3/9] x86/amd-iommu: Cleanup inv_pages command handling Joerg Roedel
2011-04-07 13:29 ` [PATCH 4/9] x86/amd-iommu: Cleanup completion-wait handling Joerg Roedel
2011-04-07 13:30 ` [PATCH 5/9] x86/amd-iommu: Remove command buffer resetting logic Joerg Roedel
2011-04-07 13:30 ` [PATCH 6/9] x86/amd-iommu: Rename iommu_flush* to domain_flush* Joerg Roedel
2011-04-07 13:30 ` [PATCH 7/9] x86/amd-iommu: Improve handling of full command buffer Joerg Roedel
2011-04-07 13:30 ` [PATCH 8/9] x86/amd-iommu: Rename iommu_flush_device Joerg Roedel
2011-04-07 13:30 ` [PATCH 9/9] x86/amd-iommu: Flush all internal TLBs when IOMMUs are enabled Joerg Roedel
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1302183004-4081-1-git-send-email-joerg.roedel@amd.com \
--to=joerg.roedel@amd.com \
--cc=iommu@lists.linux-foundation.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®