From: Peter Zijlstra <peterz@infradead.org>
To: Christoph Lameter <cl@linux.com>
Cc: Tejun Heo <tj@kernel.org>,
Linus Torvalds <torvalds@linux-foundation.org>,
Thomas Gleixner <tglx@linutronix.de>,
"Paul E. McKenney" <paulmck@us.ibm.com>,
linux-kernel <linux-kernel@vger.kernel.org>,
Ingo Molnar <mingo@elte.hu>
Subject: Re: per-cpu operation madness vs validation
Date: Wed, 27 Jul 2011 15:01:17 +0200 [thread overview]
Message-ID: <1311771677.24752.495.camel@twins> (raw)
In-Reply-To: <1311768693.24752.488.camel@twins>
On Wed, 2011-07-27 at 14:11 +0200, Peter Zijlstra wrote:
> Hence my suggestion to do something like:
>
> struct foo {
> percpu_lock_t lock;
> int a;
> int b;
> }
>
> DEFINE_PER_CPU(struct foo, foo);
>
> percpu_lock(&foo.lock);
> __this_cpu_inc(foo.a);
> __this_cpu_inc(foo.b);
> percpu_unlock(&foo.lock);
>
> That would get us (aside from a shitload of work to make it so):
>
> - clear boundaries of where the data structure atomicy lie
> - validation, for if the above piece of code was also ran from IRQ
> context we could get lockdep complaining about IRQ unsafe locks used
> from IRQ context.
>
> Now for !-rt percpu_lock will not emit more than
> preempt_disable/local_bh_disable/local_irq_disable, depending on what
> variant is used, and the data type percpu_lock_t would be empty (except
> when enabling lockdep of course).
>
> Possibly we could reduce all this percpu madness back to one form
> (__this_cpu_*) and require that when used a lock of the percpu_lock_t is
> taken.
get_cpu_var()/put_cpu_var() were supposed to provide such delineation as
well, but you've been actively destroying things like that with the
recent per-cpu work.
Also, I think we can mostly deprecate preempt_disable, local_bh_disable
and local_irq_disable when we have percpu_lock_t, or is local_lock_t a
better name?
next prev parent reply other threads:[~2011-07-27 13:01 UTC|newest]
Thread overview: 16+ messages / expand[flat|nested] mbox.gz Atom feed top
2011-07-26 21:06 Peter Zijlstra
2011-07-26 21:32 ` Christoph Lameter
2011-07-27 12:11 ` Peter Zijlstra
2011-07-27 13:01 ` Peter Zijlstra [this message]
2011-07-27 14:20 ` Christoph Lameter
2011-07-27 16:20 ` Peter Zijlstra
2011-07-27 16:29 ` Peter Zijlstra
2011-07-27 17:04 ` Christoph Lameter
2011-07-27 16:53 ` Christoph Lameter
2011-07-27 14:16 ` Christoph Lameter
2011-07-27 16:20 ` Peter Zijlstra
2011-07-27 17:13 ` Christoph Lameter
2011-07-27 17:33 ` Thomas Gleixner
2011-07-27 20:48 ` Christoph Lameter
2011-07-27 22:17 ` Thomas Gleixner
2011-07-28 13:50 ` Christoph Lameter
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1311771677.24752.495.camel@twins \
--to=peterz@infradead.org \
--cc=cl@linux.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@elte.hu \
--cc=paulmck@us.ibm.com \
--cc=tglx@linutronix.de \
--cc=tj@kernel.org \
--cc=torvalds@linux-foundation.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®