mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Steven Rostedt <rostedt@goodmis.org>
To: Andrew Morton <akpm00@gmail.com>
Cc: Jeremy Fitzhardinge <jeremy@goop.org>,
	Rusty Russell <rusty@rustcorp.com.au>,
	Peter Zijlstra <a.p.zijlstra@chello.nl>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	"H. Peter Anvin" <hpa@zytor.com>, Tejun Heo <htejun@gmail.com>,
	Ingo Molnar <mingo@redhat.com>
Subject: Re: [PATCH RFC] stop_machine: make stop_machine safe and efficient to call early
Date: Fri, 30 Sep 2011 17:21:51 -0400	[thread overview]
Message-ID: <1317417713.4588.57.camel@gandalf.stny.rr.com> (raw)
In-Reply-To: <20110930140625.c7faad28.akpm00@gmail.com>

On Fri, 2011-09-30 at 14:06 -0700, Andrew Morton wrote:
> On Fri, 30 Sep 2011 10:00:06 -0700
> Jeremy Fitzhardinge <jeremy@goop.org> wrote:
> 
> > On 09/30/2011 09:34 AM, Steven Rostedt wrote:
> > > Doesn't interrupts need to be disabled here too? As stop machine
> > > functions also guarantee that they will not be interrupted by
> > > interrupts. -- Steve
> > 
> > Good point.
> > 
> >     J
> > 
> > Make stop_machine() safe to call early in boot, before SMP has been
> > set up, by simply calling the callback function directly if there's
> > only one CPU online.
> 
> Being a trusting soul, I shall assume that you presently have or soon
> will have some code which requires this change?

Yeah, it has to do with these patches:

https://lkml.org/lkml/2011/9/29/509

> 
> >
> > ...
> >
> > --- a/kernel/stop_machine.c
> > +++ b/kernel/stop_machine.c
> > @@ -485,6 +485,17 @@ int __stop_machine(int (*fn)(void *), void *data, const struct cpumask *cpus)
> >  					    .num_threads = num_online_cpus(),
> >  					    .active_cpus = cpus };
> >  
> > +	if (smdata.num_threads == 1) {
> > +		unsigned long flags;
> > +		int ret;
> > +
> > +		local_save_flags(flags);
> > +		ret = (*fn)(data);
> > +		local_irq_restore(flags);
> > +
> > +		return ret;
> > +	}
> 
> It is quite unobvious to readers why this code exists.  Therefore, we
> should tell them.
> 
> Also, bug.  local_save_flags() is used to read the irq flags - it does
> not actually disable interrupts.  We want local_irq_save() here.  None
> of these interfaces are documented and their naming system is crappy. 
> Cause, effect.
> 
> 
> --- a/kernel/stop_machine.c~stop_machine-make-stop_machine-safe-and-efficient-to-call-early-fix
> +++ a/kernel/stop_machine.c
> @@ -486,10 +486,14 @@ int __stop_machine(int (*fn)(void *), vo
>  					    .active_cpus = cpus };
>  
>  	if (smdata.num_threads == 1) {
> +		/*
> +		 * Handle the case where stop_machine() is called early in boot
> +		 * before SMP startup.
> +		 */
>  		unsigned long flags;
>  		int ret;
>  
> -		local_save_flags(flags);
> +		local_irq_save(flags);

Nice catch. Yeah, the naming convention is not too nice. They probably
should have been named: local_irq_disable_save() and
local_irq_enable_restore(). But that's too much to type ;)

-- Steve


>  		ret = (*fn)(data);
>  		local_irq_restore(flags);
>  
> _
> 



  reply	other threads:[~2011-09-30 21:21 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-09-30 16:28 Jeremy Fitzhardinge
2011-09-30 16:34 ` Steven Rostedt
2011-09-30 17:00   ` Jeremy Fitzhardinge
2011-09-30 21:06     ` Andrew Morton
2011-09-30 21:21       ` Steven Rostedt [this message]
2011-09-30 21:23   ` Andrew Morton
2011-09-30 23:06 ` Tejun Heo
2011-09-30 23:32   ` Jeremy Fitzhardinge
2011-09-30 23:39     ` Tejun Heo

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1317417713.4588.57.camel@gandalf.stny.rr.com \
    --to=rostedt@goodmis.org \
    --cc=a.p.zijlstra@chello.nl \
    --cc=akpm00@gmail.com \
    --cc=hpa@zytor.com \
    --cc=htejun@gmail.com \
    --cc=jeremy@goop.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=rusty@rustcorp.com.au \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®