From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from abi149ajj127.mrs1.oracleemaildelivery.com (abi149ajj127.mrs1.oracleemaildelivery.com [129.149.100.127]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id 7B0453DFC9A for ; Wed, 25 Mar 2026 14:24:48 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=129.149.100.127 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1774448690; cv=none; b=tSi26BZfDexGENGt8ptTrR2ATZTa4/l65BxwDGZUuGeeT8NtutYJeDoMafy9dkO4pbVinq65LN0EWv4hf3Whvz95YbwJBe/0hHxz2TV5cnYW8KIuYGZ9s9ZmZKypMzU/odBsEWXFbrZiQGgF1vNXdZuf2+k+UX36v4u31MMAsfk= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1774448690; c=relaxed/simple; bh=xlYyUZ7qm8LRKa9b1Hkp+8PMrJFWf5+5nn9p80ukUko=; h=Message-id:Date:MIME-version:From:Subject:To:Cc:References: In-reply-to:Content-type; b=EjJ/MCg8rubLg01pGlrvIIKKcETWXOj+4vuRKv5A2FPk5k6oeoxXK81+R+xY67EQgXxGJSIuXMXDIUsV2VUTFxtxWS6b4ostex6kVv7OmuxkYE1YuWEJ8sUc53GCwxXnbb5Je586jneu1KSQc04tNvWtYVALLf7bAHlB0wt6RpU= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=pta2002.com; spf=pass smtp.mailfrom=mrs1.rp.oracleemaildelivery.com; dkim=pass (2048-bit key) header.d=pta2002.com header.i=@pta2002.com header.b=d/c31OPC; dkim=pass (2048-bit key) header.d=mrs1.rp.oracleemaildelivery.com header.i=@mrs1.rp.oracleemaildelivery.com header.b=rRj5CrpY; arc=none smtp.client-ip=129.149.100.127 Authentication-Results: smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=pta2002.com Authentication-Results: smtp.subspace.kernel.org; spf=pass smtp.mailfrom=mrs1.rp.oracleemaildelivery.com Authentication-Results: smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=pta2002.com header.i=@pta2002.com header.b="d/c31OPC"; dkim=pass (2048-bit key) header.d=mrs1.rp.oracleemaildelivery.com header.i=@mrs1.rp.oracleemaildelivery.com header.b="rRj5CrpY" DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; s=pta2002-202603; d=pta2002.com; h=Date:To:From:Subject:Message-Id:MIME-Version:Sender:List-Unsubscribe:List-Unsubscribe-Post; bh=4J2bs+Xgq5dSGZ9Mv94Ovt55+98SGPNbD1rG7ZHb4uQ=; b=d/c31OPCS0pvHHb59f3c3prYbJH2JX0e1ENPC3Un4ZDCfLRJrmXHMGgJZVYj0D533bOQ0A7NqHQN fId35zwaHRlwqIxCJ8V/dAAf3toxJi5uCEftD//i3U7e0PfIIqzXhNPNYtxIwb+nivnXSEmBhFSg NZUBvEuMm5sHPCz4McLTF4S4aNehFihcJEBbWXCFuG9RyJ3rInSBYxKDLhj4weGQxHKlYfjoCGv6 h8Xqcm1QEfI+MRYdfuAW5nO/kpW25hvNK60eKVU5DskkLv9Iaa8OQcIetwY0Nv9Xb4f1NsD0QZKy pF6FGsRm/B5viyrNtBnss9ETXsLkY9mXO6+z5Q== DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; s=prod-mrs-20211019; d=mrs1.rp.oracleemaildelivery.com; h=Date:To:From:Subject:Message-Id:MIME-Version:Sender:List-Unsubscribe:List-Unsubscribe-Post; bh=4J2bs+Xgq5dSGZ9Mv94Ovt55+98SGPNbD1rG7ZHb4uQ=; b=rRj5CrpYyJvDoWm3Mx2pXRRa+R+fcOAohKcjnJ3snn1Q/wiNVanGXKh81FkkZh0n9/uM+694pVzC /o1n5oDe4Is13WcrZvAqVTJksd91OW57PtOGyea4tpF0kUcUdrAJLyaplBdxiX2CSm/vEhy7T7FZ 1NhUVkNt4Aezhuk4srznb6jp0Kw/ZamA/J1Cm9TjFKEYdFFE+hAznu6FdJjsLU/9Pzuw8WnYJGiJ 3QXSilw4T5H/sdhDJtHtt/cEmZG3U19MW3lNzGOaP3N8D22o/I3or6synWhiuipKtm4QnmWKJ7h6 OiDh2yIriX5ssIW9Nqtudj1e02Jc4Z2L4Il/+g== Received: by omta-ad1-fd1-401-eu-marseille-1.omtaad1.vcndpmrs.oraclevcn.com (Oracle Communications Messaging Server 8.1.0.1.20260212 64bit (built Feb 12 2026)) with ESMTPS id <0TCG005XALDAK3C0@omta-ad1-fd1-401-eu-marseille-1.omtaad1.vcndpmrs.oraclevcn.com> for linux-kernel@vger.kernel.org; Wed, 25 Mar 2026 14:24:46 +0000 (GMT) List-Unsubscribe-Post: List-Unsubscribe=One-Click Message-id: <1331010f-1446-4892-9d81-2f18b60f6977@pta2002.com> Date: Wed, 25 Mar 2026 14:24:45 +0000 Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-version: 1.0 User-Agent: Mozilla Thunderbird From: Pedro Alves Subject: Re: [PATCH RESEND v2] arm64: dts: rockchip: configure hdmirx in Rock 5 ITX To: Heiko Stuebner Cc: Rob Herring , Krzysztof Kozlowski , Conor Dooley , devicetree@vger.kernel.org, linux-arm-kernel@lists.infradead.org, linux-rockchip@lists.infradead.org, linux-kernel@vger.kernel.org References: <20260323-radxa-r5-itx-hdmirx-v2-1-c52501909577@pta2002.com> <3407927.44csPzL39Z@phil> Content-language: pt_PT, en-US In-reply-to: <3407927.44csPzL39Z@phil> Content-type: text/plain; charset=UTF-8 Content-transfer-encoding: 8bit Reporting-Meta: AAHaB8rt6U4pRWPuzg6HYoL14PsnJ3SvWR/H0/t4MAxeSZoxpcePWCN+kYBu4Dv9 oyx+yTPV6GooNsUjV5QDIcVW9vm8S/sArtTeLh/nQJF+631tkk/QWhrGEBP0ZnzW mTZVh2VMrsDNHxGooyKwiJILx2rMrCdRZ3Ar9PJFtt5SstfvywoIAhR0qQ2PLPEE CauevWnqamcyOVgGrXDWEaiJ/2SdtS8mnvlE9tyIft2SnSx/+rmB9txb/xKYXD1J ze6bjoKh8E/ZH5/AHEsftAcCRrAku4YgqFQa+R/eUD1N2TbiA4xgZMwksnCmByq5 rWzB8w8G/bSL8dO480nJ3PNQ2i8qVqDluylLDsvkVO7IPXJzTE61XUQ4aZxF23cL brQaVe3Sa9ax/+3FcAQ4pf36EUn1TBaZBylljhcq7Qqo2D79aBg86SmLrv8Cxko= Hi, On 24/03/2026 14:18, Heiko Stuebner wrote: > Am Montag, 23. März 2026, 10:25:33 Mitteleuropäische Normalzeit schrieb Pedro Alves: >> +&hdmi_receiver { >> + pinctrl-0 = <&hdmim1_rx_cec &hdmim1_rx_hpdin &hdmim1_rx_scl &hdmim1_rx_sda &hdmirx_det>; >> + pinctrl-names = "default"; >> + hpd-gpios = <&gpio1 RK_PC6 GPIO_ACTIVE_LOW>; > > as said before, please also add a pinctrl setting for this pin. > > gpio1_c6 is not part of the main hdmirx set of pins, hence needs an > additional pinctrl entry to configure it as gpio and possibly set any > additional pull settings. > > And yes the pinctrl-driver does "implcitly" set the gpio-mode when > a gpio is requested, but our more modern approach is to always have > a real pinctrl entry even for gpios. I am probably getting confused by what you are asking here, but I don't understand what exactly I should add. There was already a pinctrl for hdmirx_det (which is what the gpio1_c6 pin is) present in the file, hence why I did not add it in this patch: &pinctrl { /* ... */ hdmirx { hdmirx_det: hdmirx-det { rockchip,pins = <1 RK_PC6 RK_FUNC_GPIO &pcfg_pull_none>; }; }; /* ... */ }; Looking at the other boards, they do the same thing, but they call it hdmirx-5v-detection instead, but as discussed in v1 of this patch I ended up keeping the det naming to match the schematics. Sorry if I am missing something, I don't have much experience with this, so I would really appreciate some extra information. Thank you, Pedro