On Mon, 2012-05-21 at 16:41 +0200, Joel Reardon wrote: > +static void generate_key(struct ubifs_keymap *km, u8 *to) > +{ > + get_random_bytes(to, km->key_size); > +} If this function is not going to grow soon, just open-code 'get_random_bytes()' instead. Try to not introduce wrappers like this - we do not appreciate it usually, we prefer open-coding things unless there is a good reason to have a wrapper function. -- Best Regards, Artem Bityutskiy