From: Frederic Weisbecker <fweisbec@gmail.com>
To: LKML <linux-kernel@vger.kernel.org>
Cc: Frederic Weisbecker <fweisbec@gmail.com>,
Alessio Igor Bogani <abogani@kernel.org>,
Andrew Morton <akpm@linux-foundation.org>,
Avi Kivity <avi@redhat.com>, Chris Metcalf <cmetcalf@tilera.com>,
Christoph Lameter <cl@linux.com>,
Geoff Levand <geoff@infradead.org>,
Gilad Ben Yossef <gilad@benyossef.com>,
Hakan Akkan <hakanakkan@gmail.com>,
"H. Peter Anvin" <hpa@zytor.com>, Ingo Molnar <mingo@kernel.org>,
Kevin Hilman <khilman@ti.com>,
Max Krasnyansky <maxk@qualcomm.com>,
"Paul E. McKenney" <paulmck@linux.vnet.ibm.com>,
Peter Zijlstra <peterz@infradead.org>,
Stephen Hemminger <shemminger@vyatta.com>,
Steven Rostedt <rostedt@goodmis.org>,
Sven-Thorsten Dietrich <thebigcorporation@gmail.com>,
Thomas Gleixner <tglx@linutronix.de>
Subject: [RFC PATCH 0/5] cputime: Generic virtual based cputime accounting
Date: Fri, 27 Jul 2012 17:40:29 +0200 [thread overview]
Message-ID: <1343403634-31555-1-git-send-email-fweisbec@gmail.com> (raw)
So,
This is a proposition to handle the cputime accounting without the
tick to prepare for stopping the tick further idle.
I have managed to reuse and generalize the kernel/user boundary
hooks used by RCU. This way we can minimize the changes in archs
that don't support virtual cputime and we can also switch between
vtime and tick based accounting to minimize the overhead depending
on the tick behaviour.
This is based on top of rcu/idle branch in Paul's tree and my
vtime consolidation series: https://lkml.org/lkml/2012/6/20/762
(still waiting to be picked btw).
You, adventurer, can pull from:
git://github.com/fweisbec/linux-dynticks.git
vtime/generic
Frederic Weisbecker (5):
user_hooks: New user hooks subsystem
cputime: Don't allow virtual and irq finegrained cputime accounting
simultaneously
cputime: Allow dynamic switch between tick/virtual based cputime
accounting
cputime: Rename account_system_vtime to account_vtime
cputime: Generic on-demand virtual cputime accounting
arch/Kconfig | 10 +-
arch/ia64/include/asm/cputime.h | 5 +
arch/ia64/kernel/time.c | 6 +-
arch/powerpc/include/asm/cputime.h | 5 +
arch/powerpc/kernel/time.c | 10 +-
arch/s390/include/asm/cputime.h | 5 +
arch/s390/kernel/vtime.c | 6 +-
arch/x86/Kconfig | 2 +-
arch/x86/include/asm/{rcu.h => user_hooks.h} | 12 +-
arch/x86/kernel/ptrace.c | 6 +-
arch/x86/kernel/signal.c | 5 +-
arch/x86/kernel/traps.c | 2 +-
arch/x86/mm/fault.c | 2 +-
include/asm-generic/cputime.h | 7 +
include/linux/hardirq.h | 8 +-
include/linux/kernel_stat.h | 13 ++
include/linux/kvm_host.h | 4 +-
include/linux/rcupdate.h | 2 -
include/linux/sched.h | 13 +--
include/linux/user_hooks.h | 36 ++++++
init/Kconfig | 35 ++++--
kernel/Makefile | 1 +
kernel/fork.c | 3 +-
kernel/rcutree.c | 42 +-------
kernel/sched/core.c | 9 +-
kernel/sched/cputime.c | 159 +++++++++++++++++++++----
kernel/softirq.c | 6 +-
kernel/time/tick-sched.c | 28 ++---
kernel/user_hooks.c | 56 +++++++++
29 files changed, 348 insertions(+), 150 deletions(-)
rename arch/x86/include/asm/{rcu.h => user_hooks.h} (56%)
create mode 100644 include/linux/user_hooks.h
create mode 100644 kernel/user_hooks.c
--
1.7.5.4
next reply other threads:[~2012-07-27 15:40 UTC|newest]
Thread overview: 22+ messages / expand[flat|nested] mbox.gz Atom feed top
2012-07-27 15:40 Frederic Weisbecker [this message]
2012-07-27 15:40 ` [PATCH 1/5] user_hooks: New user hooks subsystem Frederic Weisbecker
2012-07-27 16:40 ` Paul E. McKenney
2012-07-27 16:58 ` Frederic Weisbecker
2012-07-30 15:08 ` Peter Zijlstra
2012-07-30 15:27 ` Steven Rostedt
2012-07-30 16:30 ` Peter Zijlstra
2012-07-30 15:51 ` Frederic Weisbecker
2012-07-30 16:07 ` Steven Rostedt
2012-07-30 16:31 ` Peter Zijlstra
2012-07-30 16:32 ` Peter Zijlstra
2012-07-31 7:06 ` Ingo Molnar
2012-07-31 10:48 ` Frederic Weisbecker
2012-07-31 14:57 ` Ingo Molnar
2012-07-31 16:14 ` Peter Zijlstra
2012-08-01 12:28 ` Frederic Weisbecker
2012-08-01 12:43 ` Steven Rostedt
2012-08-01 12:45 ` Frederic Weisbecker
2012-07-27 15:40 ` [PATCH 2/5] cputime: Don't allow virtual and irq finegrained cputime accounting simultaneously Frederic Weisbecker
2012-07-27 15:40 ` [PATCH 3/5] cputime: Allow dynamic switch between tick/virtual based cputime accounting Frederic Weisbecker
2012-07-27 15:40 ` [PATCH 4/5] cputime: Rename account_system_vtime to account_vtime Frederic Weisbecker
2012-07-27 15:40 ` [PATCH 5/5] cputime: Generic on-demand virtual cputime accounting Frederic Weisbecker
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1343403634-31555-1-git-send-email-fweisbec@gmail.com \
--to=fweisbec@gmail.com \
--cc=abogani@kernel.org \
--cc=akpm@linux-foundation.org \
--cc=avi@redhat.com \
--cc=cl@linux.com \
--cc=cmetcalf@tilera.com \
--cc=geoff@infradead.org \
--cc=gilad@benyossef.com \
--cc=hakanakkan@gmail.com \
--cc=hpa@zytor.com \
--cc=khilman@ti.com \
--cc=linux-kernel@vger.kernel.org \
--cc=maxk@qualcomm.com \
--cc=mingo@kernel.org \
--cc=paulmck@linux.vnet.ibm.com \
--cc=peterz@infradead.org \
--cc=rostedt@goodmis.org \
--cc=shemminger@vyatta.com \
--cc=tglx@linutronix.de \
--cc=thebigcorporation@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®