mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Steven Rostedt <rostedt@goodmis.org>
To: Peter Zijlstra <a.p.zijlstra@chello.nl>
Cc: linux-kernel@vger.kernel.org, Ingo Molnar <mingo@kernel.org>,
	Andrew Morton <akpm@linux-foundation.org>,
	Frederic Weisbecker <fweisbec@gmail.com>
Subject: Re: [RFC][PATCH 4/4] perf/events: Use helper functions in event assignment to shrink macro size
Date: Mon, 13 Aug 2012 10:40:44 -0400	[thread overview]
Message-ID: <1344868844.6935.121.camel@gandalf.stny.rr.com> (raw)
In-Reply-To: <1344865977.31459.26.camel@twins>

On Mon, 2012-08-13 at 15:52 +0200, Peter Zijlstra wrote:

> > Looking at the history of perf_trace_buf_submit(), it use to be more
> > than one function call. But when you inlined
> > perf_swevent_put_recursion_context(), it became just a one2one mapping.
> 
> Right.

OK, this should go as a separate change.

> 
> > I'm assuming that we want to convert all calls to
> > perf_trace_buf_submit()s into perf_tp_event()?
> 
> Yeah.. I think you're referring to the {u,k}probes open-coded nonsense?
> Should we make those use these new helpers you created as well?

They may not need it. The helpers I created were for the macros that are
created by all TRACE_EVENT() instances. If the uprobes and kprobes only
have a single instance, then they probably don't need the helpers. But
they still call the perf_trace_buf_submit(), which can can probably be
cleaned up.

-- Steve



  reply	other threads:[~2012-08-13 14:40 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-08-10  3:43 [RFC][PATCH 0/4] tracing/perf: Use helper functions to help shrink kernel size Steven Rostedt
2012-08-10  3:43 ` [RFC][PATCH 1/4] tracing: Move print code from macro to standalone function Steven Rostedt
2012-08-10  3:43 ` [RFC][PATCH 2/4] tracing: Move event storage for array " Steven Rostedt
2012-08-10  3:43 ` [RFC][PATCH 3/4] tracing: Use helper functions in event assignment to shrink macro size Steven Rostedt
2012-08-10  3:43 ` [RFC][PATCH 4/4] perf/events: " Steven Rostedt
2012-08-13  8:03   ` Peter Zijlstra
2012-08-13 13:03     ` Steven Rostedt
2012-08-13 13:52       ` Peter Zijlstra
2012-08-13 14:40         ` Steven Rostedt [this message]
2012-08-13 14:47           ` Peter Zijlstra
2014-02-06 17:39 [RFC][PATCH 0/4] tracing/perf: Use helper functions to help shrink kernel size Steven Rostedt
2014-02-06 17:39 ` [RFC][PATCH 4/4] perf/events: Use helper functions in event assignment to shrink macro size Steven Rostedt
2014-02-06 18:47   ` Steven Rostedt
2014-02-12 19:58   ` Peter Zijlstra
2014-02-21 18:53     ` Steven Rostedt

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1344868844.6935.121.camel@gandalf.stny.rr.com \
    --to=rostedt@goodmis.org \
    --cc=a.p.zijlstra@chello.nl \
    --cc=akpm@linux-foundation.org \
    --cc=fweisbec@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome