mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: anish kumar <anish198519851985@gmail.com>
To: myungjoo.ham@samsung.com
Cc: 최찬우 <cw00.choi@samsung.com>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"Lars-Peter Clausen" <lars@metafoo.de>
Subject: Re: [PATCH] Extcon: Minor change in the declaration of cable_names
Date: Mon, 20 Aug 2012 12:57:15 +0530	[thread overview]
Message-ID: <1345447635.1568.1.camel@anish-Inspiron-N5050> (raw)
In-Reply-To: <28057486.209671345445798709.JavaMail.weblogic@epml13>

On Mon, 2012-08-20 at 06:56 +0000, 함명주 wrote:
> > From: anish kumar <anish198519851985@gmail.com>
> > 
> > Instead of "const char **supported_cable" it is better to have
> > it as "const char *const *supported_cable".
> > 
> > Signed-off-by: anish kumar <anish198519851985@gmail.com>
> 
> Could you please elaborate on why it's better?
> 
> (Is this fixing the using the standard naming issue Mark mentioned before?)
No, It is what Lars(Lars-Peter Clausen) mentioned when he was doing the
review earlier.It is nothing but a general practise as cable_names is
constant. 
> 
> 
> Cheers!
> MyungJoo
> 
> > ---
> >  include/linux/extcon.h                 |    2 +-
> >  include/linux/extcon/extcon-adc-jack.h |    2 +-
> >  2 files changed, 2 insertions(+), 2 deletions(-)
> > 
> > diff --git a/include/linux/extcon.h b/include/linux/extcon.h
> > index cdd4014..a6bcc29 100644
> > --- a/include/linux/extcon.h
> > +++ b/include/linux/extcon.h
> > @@ -111,7 +111,7 @@ struct extcon_cable;
> >  struct extcon_dev {
> >  	/* --- Optional user initializing data --- */
> >  	const char	*name;
> > -	const char **supported_cable;
> > +	const char *const *supported_cable;
> >  	const u32	*mutually_exclusive;
> >  
> >  	/* --- Optional callbacks to override class functions --- */
> > diff --git a/include/linux/extcon/extcon-adc-jack.h b/include/linux/extcon/extcon-adc-jack.h
> > index 20e9eef..f27f2e8 100644
> > --- a/include/linux/extcon/extcon-adc-jack.h
> > +++ b/include/linux/extcon/extcon-adc-jack.h
> > @@ -60,7 +60,7 @@ struct adc_jack_pdata {
> >  	/*
> >  	 * The last entry should be NULL
> >  	 */
> > -	const char **cable_names;
> > +	const char *const *cable_names;
> >  	/* The last entry's state should be 0 */
> >  	struct adc_jack_cond *adc_conditions;
> >  
> > -- 
> > 1.7.1
> > 
> > 
> > 
> > 
> >        
> >   
> >          
> > 



  reply	other threads:[~2012-08-20  7:30 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-08-20  6:56 함명주
2012-08-20  7:27 ` anish kumar [this message]
  -- strict thread matches above, loose matches on Subject: below --
2012-08-18  8:19 anish kumar

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1345447635.1568.1.camel@anish-Inspiron-N5050 \
    --to=anish198519851985@gmail.com \
    --cc=cw00.choi@samsung.com \
    --cc=lars@metafoo.de \
    --cc=linux-kernel@vger.kernel.org \
    --cc=myungjoo.ham@samsung.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®