From: Greg Ungerer <gerg@linux-m68k.org>
To: Geert Uytterhoeven <geert@linux-m68k.org>,
"David S . Miller" <davem@davemloft.net>,
Dmitry Torokhov <dmitry.torokhov@gmail.com>,
Helge Deller <deller@gmx.de>
Cc: linux-m68k@lists.linux-m68k.org, netdev@vger.kernel.org,
linux-input@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 1/5] m68k/io: Add missing ioremap define guards, fix typo
Date: Tue, 3 Jul 2018 12:13:46 +1000 [thread overview]
Message-ID: <1349f685-e4a2-5e04-8227-dd55e11153f6@linux-m68k.org> (raw)
In-Reply-To: <20180702133532.5412-2-geert@linux-m68k.org>
Hi Geert,
On 02/07/18 23:35, Geert Uytterhoeven wrote:
> - Add missing define guard for ioremap_wt(),
> - Fix typo s/ioremap_fillcache/ioremap_fullcache/,
> - Add define guard for iounmap() for consistency with other
> architectures.
>
> Fixes: 9746882f547d2f00 ("m68k: group io mapping definitions and functions")
> Signed-off-by: Geert Uytterhoeven <geert@linux-m68k.org>
If I build for the m5475evb defconfig then I get warnings like this:
CC init/main.o
In file included from ./include/asm-generic/io.h:19:0,
from ./arch/m68k/include/asm/io_no.h:147,
from ./arch/m68k/include/asm/io.h:3,
from ./include/linux/bio.h:28,
from ./include/linux/blkdev.h:21,
from init/main.c:80:
./include/asm-generic/iomap.h:79:0: warning: "ioremap_wt" redefined
#define ioremap_wt ioremap_nocache
^
In file included from ./arch/m68k/include/asm/io_no.h:145:0,
from ./arch/m68k/include/asm/io.h:3,
from ./include/linux/bio.h:28,
from ./include/linux/blkdev.h:21,
from init/main.c:80:
./arch/m68k/include/asm/kmap.h:37:0: note: this is the location of the previous definition
#define ioremap_wt ioremap_wt
^
Regards
Greg
> ---
> arch/m68k/include/asm/kmap.h | 4 +++-
> 1 file changed, 3 insertions(+), 1 deletion(-)
>
> diff --git a/arch/m68k/include/asm/kmap.h b/arch/m68k/include/asm/kmap.h
> index 84b8333db8ad1987..bf1026def698f21f 100644
> --- a/arch/m68k/include/asm/kmap.h
> +++ b/arch/m68k/include/asm/kmap.h
> @@ -16,6 +16,7 @@
> */
> extern void __iomem *__ioremap(unsigned long physaddr, unsigned long size,
> int cacheflag);
> +#define iounmap iounmap
> extern void iounmap(void __iomem *addr);
> extern void __iounmap(void *addr, unsigned long size);
>
> @@ -33,13 +34,14 @@ static inline void __iomem *ioremap_nocache(unsigned long physaddr,
> }
>
> #define ioremap_uc ioremap_nocache
> +#define ioremap_wt ioremap_wt
> static inline void __iomem *ioremap_wt(unsigned long physaddr,
> unsigned long size)
> {
> return __ioremap(physaddr, size, IOMAP_WRITETHROUGH);
> }
>
> -#define ioremap_fillcache ioremap_fullcache
> +#define ioremap_fullcache ioremap_fullcache
> static inline void __iomem *ioremap_fullcache(unsigned long physaddr,
> unsigned long size)
> {
>
next prev parent reply other threads:[~2018-07-03 2:13 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-07-02 13:35 [PATCH 0/5] m68k: IO Fixes and Cleanups Geert Uytterhoeven
2018-07-02 13:35 ` [PATCH 1/5] m68k/io: Add missing ioremap define guards, fix typo Geert Uytterhoeven
2018-07-03 2:13 ` Greg Ungerer [this message]
2018-07-03 7:41 ` Geert Uytterhoeven
2018-07-02 13:35 ` [PATCH 2/5] net: mac8390: Use standard memcpy_{from,to}io() Geert Uytterhoeven
2018-07-02 13:39 ` David Miller
2018-07-02 13:35 ` [PATCH 3/5] Input: hilkbd - Add casts to HP9000/300 I/O accessors Geert Uytterhoeven
2018-07-02 13:35 ` [PATCH 4/5] m68k/io: Move mem*io define guards to <asm/kmap.h> Geert Uytterhoeven
2018-07-02 13:35 ` [PATCH 5/5] m68k/io: Switch mmu variant to <asm-generic/io.h> Geert Uytterhoeven
2018-07-03 2:15 ` [PATCH 0/5] m68k: IO Fixes and Cleanups Greg Ungerer
2018-07-09 9:30 Geert Uytterhoeven
2018-07-09 9:30 ` [PATCH 1/5] m68k/io: Add missing ioremap define guards, fix typo Geert Uytterhoeven
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1349f685-e4a2-5e04-8227-dd55e11153f6@linux-m68k.org \
--to=gerg@linux-m68k.org \
--cc=davem@davemloft.net \
--cc=deller@gmx.de \
--cc=dmitry.torokhov@gmail.com \
--cc=geert@linux-m68k.org \
--cc=linux-input@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-m68k@lists.linux-m68k.org \
--cc=netdev@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®