From: Akinobu Mita <akinobu.mita@gmail.com>
To: linux-kernel@vger.kernel.org, akpm@linux-foundation.org
Cc: Akinobu Mita <akinobu.mita@gmail.com>
Subject: [PATCH -v2 05/26] lib/: rename random32() to prandom_u32()
Date: Thu, 3 Jan 2013 21:19:01 +0900 [thread overview]
Message-ID: <1357215562-6288-6-git-send-email-akinobu.mita@gmail.com> (raw)
In-Reply-To: <1357215562-6288-1-git-send-email-akinobu.mita@gmail.com>
Use more preferable function name which implies using a pseudo-random
number generator.
Signed-off-by: Akinobu Mita <akinobu.mita@gmail.com>
---
No change from v1
lib/fault-inject.c | 2 +-
lib/list_sort.c | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/lib/fault-inject.c b/lib/fault-inject.c
index f7210ad..c5c7a76 100644
--- a/lib/fault-inject.c
+++ b/lib/fault-inject.c
@@ -122,7 +122,7 @@ bool should_fail(struct fault_attr *attr, ssize_t size)
return false;
}
- if (attr->probability <= random32() % 100)
+ if (attr->probability <= prandom_u32() % 100)
return false;
if (!fail_stacktrace(attr))
diff --git a/lib/list_sort.c b/lib/list_sort.c
index d7325c6..1183fa7 100644
--- a/lib/list_sort.c
+++ b/lib/list_sort.c
@@ -229,7 +229,7 @@ static int __init list_sort_test(void)
goto exit;
}
/* force some equivalencies */
- el->value = random32() % (TEST_LIST_LEN/3);
+ el->value = prandom_u32() % (TEST_LIST_LEN / 3);
el->serial = i;
el->poison1 = TEST_POISON1;
el->poison2 = TEST_POISON2;
--
1.7.11.7
next prev parent reply other threads:[~2013-01-03 12:26 UTC|newest]
Thread overview: 42+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-01-03 12:18 [PATCH -v2 00/26] rename random32 to prandom Akinobu Mita
2013-01-03 12:18 ` [PATCH -v2 01/26] raid6test: use prandom_bytes() Akinobu Mita
2013-01-03 12:18 ` [PATCH -v2 02/26] uuid: " Akinobu Mita
2013-01-03 12:18 ` [PATCH -v2 03/26] x86: pageattr-test: remove srandom32 call Akinobu Mita
2013-01-03 17:35 ` H. Peter Anvin
2013-01-04 13:48 ` Akinobu Mita
2013-01-03 12:19 ` [PATCH -v2 04/26] x86: rename random32() to prandom_u32() Akinobu Mita
2013-01-03 12:19 ` Akinobu Mita [this message]
2013-01-03 12:19 ` [PATCH -v2 06/26] mm/: " Akinobu Mita
2013-01-03 12:19 ` [PATCH -v2 07/26] kernel/: " Akinobu Mita
2013-01-03 12:19 ` [PATCH -v2 08/26] drbd: " Akinobu Mita
2013-01-03 12:19 ` [PATCH -v2 09/26] infiniband: " Akinobu Mita
2013-01-03 16:27 ` Steve Wise
2013-01-04 13:45 ` Akinobu Mita
2013-01-04 17:15 ` Steve Wise
2013-01-05 13:37 ` Akinobu Mita
2013-01-05 23:33 ` Steve Wise
2013-01-05 23:35 ` Steve Wise
2013-01-03 12:19 ` [PATCH -v2 10/26] mmc: " Akinobu Mita
2013-01-03 12:19 ` [PATCH -v2 11/26] video/uvesafb: " Akinobu Mita
2013-01-03 12:19 ` [PATCH -v2 12/26] xfs: " Akinobu Mita
2013-01-04 18:07 ` Ben Myers
2013-01-03 12:19 ` [PATCH -v2 13/26] ubifs: " Akinobu Mita
2013-01-15 13:47 ` Artem Bityutskiy
2013-01-03 12:19 ` [PATCH -v2 14/26] uwb: " Akinobu Mita
2013-01-03 12:19 ` [PATCH -v2 15/26] lguest: " Akinobu Mita
2013-01-03 12:19 ` [PATCH -v2 16/26] scsi: " Akinobu Mita
2013-01-03 12:19 ` [PATCH -v2 17/26] mtd: " Akinobu Mita
2013-01-15 13:47 ` Artem Bityutskiy
2013-01-03 12:19 ` [PATCH -v2 18/26] drivers/net: " Akinobu Mita
2013-01-03 19:36 ` Bing Zhao
2013-01-03 12:19 ` [PATCH -v2 19/26] batman-adv: " Akinobu Mita
2013-01-04 2:12 ` Antonio Quartulli
2013-01-04 13:50 ` Akinobu Mita
2013-01-06 9:00 ` Antonio Quartulli
2013-01-03 12:19 ` [PATCH -v2 20/26] net/sunrpc: " Akinobu Mita
2013-01-03 12:19 ` [PATCH -v2 21/26] net/sched: " Akinobu Mita
2013-01-03 12:19 ` [PATCH -v2 22/26] net/netfilter: " Akinobu Mita
2013-01-03 12:19 ` [PATCH -v2 23/26] net/core: " Akinobu Mita
2013-01-03 12:19 ` [PATCH -v2 24/26] net/core: remove duplicate statements by do-while loop Akinobu Mita
2013-01-03 12:19 ` [PATCH -v2 25/26] net: rename random32 to prandom Akinobu Mita
2013-01-03 12:19 ` [PATCH -v2 26/26] remove unused random32() and srandom32() Akinobu Mita
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1357215562-6288-6-git-send-email-akinobu.mita@gmail.com \
--to=akinobu.mita@gmail.com \
--cc=akpm@linux-foundation.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome