mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Mirsal Ennaime <mirsal@mirsal.fr>
To: Greg Kroah-Hartman <greg@kroah.com>
Cc: "Arve Hjønnevåg" <arve@android.com>,
	"Brian Swetland" <swetland@google.com>,
	devel@driverdev.osuosl.org, kernel-janitors@vger.kernel.org,
	linux-kernel@vger.kernel.org,
	"Dan Carpenter" <dan.carpenter@oracle.com>,
	"Joe Perches" <joe@perches.com>,
	"Mirsal Ennaime" <mirsal@mirsal.fr>
Subject: [PATCH v2 1/3] drivers: android: binder: Move the node release code to a separate function
Date: Tue, 12 Mar 2013 00:26:26 +0100	[thread overview]
Message-ID: <1363044388-11409-2-git-send-email-mirsal@mirsal.fr> (raw)
In-Reply-To: <1363044388-11409-1-git-send-email-mirsal@mirsal.fr>

The binder_deferred_release() function has many levels of indentation
which makes it difficult to read. This patch moves the code which deals
with disposing of a binder node to a separate binder_node_release()
function, thus removing one level of indentation and allowing the code to
fit in 80 columns.

Signed-off-by: Mirsal Ennaime <mirsal@mirsal.fr>
---
 drivers/staging/android/binder.c |   76 +++++++++++++++++++++++---------------
 1 file changed, 46 insertions(+), 30 deletions(-)

diff --git a/drivers/staging/android/binder.c b/drivers/staging/android/binder.c
index 24456a0..43f823d 100644
--- a/drivers/staging/android/binder.c
+++ b/drivers/staging/android/binder.c
@@ -2878,6 +2878,51 @@ static int binder_release(struct inode *nodp, struct file *filp)
 	return 0;
 }
 
+static int binder_node_release(struct binder_node *node, int refs)
+{
+	struct binder_ref *ref;
+	int death = 0;
+
+	list_del_init(&node->work.entry);
+	binder_release_work(&node->async_todo);
+
+	if (hlist_empty(&node->refs)) {
+		kfree(node);
+		binder_stats_deleted(BINDER_STAT_NODE);
+
+		return refs;
+	}
+
+	node->proc = NULL;
+	node->local_strong_refs = 0;
+	node->local_weak_refs = 0;
+	hlist_add_head(&node->dead_node, &binder_dead_nodes);
+
+	hlist_for_each_entry(ref, &node->refs, node_entry) {
+		refs++;
+
+		if (!ref->death)
+			goto out;
+
+		death++;
+
+		if (list_empty(&ref->death->work.entry)) {
+			ref->death->work.type = BINDER_WORK_DEAD_BINDER;
+			list_add_tail(&ref->death->work.entry,
+				&ref->proc->todo);
+			wake_up_interruptible(&ref->proc->wait);
+		} else
+			BUG();
+	}
+
+out:
+	binder_debug(BINDER_DEBUG_DEAD_BINDER,
+		"node %d now dead, refs %d, death %d\n",
+		node->debug_id, refs, death);
+
+	return refs;
+}
+
 static void binder_deferred_release(struct binder_proc *proc)
 {
 	struct binder_transaction *t;
@@ -2909,36 +2954,7 @@ static void binder_deferred_release(struct binder_proc *proc)
 
 		nodes++;
 		rb_erase(&node->rb_node, &proc->nodes);
-		list_del_init(&node->work.entry);
-		binder_release_work(&node->async_todo);
-		if (hlist_empty(&node->refs)) {
-			kfree(node);
-			binder_stats_deleted(BINDER_STAT_NODE);
-		} else {
-			struct binder_ref *ref;
-			int death = 0;
-
-			node->proc = NULL;
-			node->local_strong_refs = 0;
-			node->local_weak_refs = 0;
-			hlist_add_head(&node->dead_node, &binder_dead_nodes);
-
-			hlist_for_each_entry(ref, &node->refs, node_entry) {
-				incoming_refs++;
-				if (ref->death) {
-					death++;
-					if (list_empty(&ref->death->work.entry)) {
-						ref->death->work.type = BINDER_WORK_DEAD_BINDER;
-						list_add_tail(&ref->death->work.entry, &ref->proc->todo);
-						wake_up_interruptible(&ref->proc->wait);
-					} else
-						BUG();
-				}
-			}
-			binder_debug(BINDER_DEBUG_DEAD_BINDER,
-				     "node %d now dead, refs %d, death %d\n",
-				      node->debug_id, incoming_refs, death);
-		}
+		incoming_refs = binder_node_release(node, incoming_refs);
 	}
 	outgoing_refs = 0;
 	while ((n = rb_first(&proc->refs_by_desc))) {
-- 
1.7.10.4


  reply	other threads:[~2013-03-11 23:26 UTC|newest]

Thread overview: 27+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-03-11 19:31 [PATCH 0/4] Cosmetic changes to the android binder proc release code Mirsal Ennaime
2013-03-11 19:31 ` [PATCH 1/4] drivers: android: binder: Move the node release code to a separate function Mirsal Ennaime
2013-03-11 21:46   ` Dan Carpenter
2013-03-11 19:31 ` [PATCH 2/4] drivers: android: binder: Fix code style Mirsal Ennaime
2013-03-11 21:54   ` Dan Carpenter
2013-03-11 22:27     ` mirsal
2013-03-11 19:31 ` [PATCH 3/4] drivers: android: binder: Remove excessive indentation Mirsal Ennaime
2013-03-11 20:25   ` Joe Perches
2013-03-11 20:51     ` mirsal
2013-03-11 19:31 ` [PATCH 4/4] drivers: android: binder: Fix compiler warning Mirsal Ennaime
2013-03-11 21:44   ` Dan Carpenter
2013-03-11 23:26 ` [PATCH v2 0/3] Cosmetic changes to the android binder proc release code Mirsal Ennaime
2013-03-11 23:26   ` Mirsal Ennaime [this message]
2013-03-11 23:26   ` [PATCH v2 2/3] drivers: android: binder: Fix code style Mirsal Ennaime
2013-03-11 23:57     ` Arve Hjønnevåg
2013-03-12  8:52       ` mirsal
2013-03-11 23:26   ` [PATCH v2 3/3] drivers: android: binder: Remove excessive indentation Mirsal Ennaime
2013-03-12  0:04     ` Joe Perches
2013-03-12  0:21       ` Arve Hjønnevåg
2013-03-12  0:29         ` Joe Perches
2013-03-12  9:52       ` mirsal
2013-03-12 10:41   ` [PATCH v3 0/4] Cosmetic changes to the android binder proc release code Mirsal Ennaime
2013-03-12 10:41     ` [PATCH v3 1/4] drivers: android: binder: Move the node release code to a separate function Mirsal Ennaime
2013-03-12 10:42     ` [PATCH v3 2/4] drivers: android: binder: Fix code style in binder_deferred_release Mirsal Ennaime
2013-03-12 10:42     ` [PATCH v3 3/4] drivers: android: binder: Remove excessive indentation Mirsal Ennaime
2013-03-12 10:42     ` [PATCH v3 4/4] drivers: android: binder: Use __func__ in debug messages Mirsal Ennaime
2013-03-12 10:56     ` [PATCH v3 0/4] Cosmetic changes to the android binder proc release code Dan Carpenter

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1363044388-11409-2-git-send-email-mirsal@mirsal.fr \
    --to=mirsal@mirsal.fr \
    --cc=arve@android.com \
    --cc=dan.carpenter@oracle.com \
    --cc=devel@driverdev.osuosl.org \
    --cc=greg@kroah.com \
    --cc=joe@perches.com \
    --cc=kernel-janitors@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=swetland@google.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®