From: Yinghai Lu <yinghai@kernel.org>
To: Bjorn Helgaas <bhelgaas@google.com>, Ram Pai <linuxram@us.ibm.com>
Cc: linux-pci@vger.kernel.org, linux-kernel@vger.kernel.org,
Yinghai Lu <yinghai@kernel.org>
Subject: [PATCH v4 02/29] PCI: Add pci_dev_resource_n()
Date: Fri, 12 Apr 2013 15:44:16 -0700 [thread overview]
Message-ID: <1365806683-26717-3-git-send-email-yinghai@kernel.org> (raw)
In-Reply-To: <1365806683-26717-1-git-send-email-yinghai@kernel.org>
Now pci device resource iteration is done via "for (i=0...)" open code.
That make code hard to read esp when only bridge or sriov resources
are involved.
We want to replace those open code with for_each_pci_resource().
Also want to add addon_resource handling, and need to make addon resource
to be treated as normal PCI resources during iteration.
Add pci_device_resource_n() instead of using dev->resources[n].
Use it with for_each_pci_resource macro and addon_resource support.
-v2: Add EXPORT_SYMBOL to find building error found by Gary Hade
Signed-off-by: Yinghai Lu <yinghai@kernel.org>
---
drivers/pci/probe.c | 9 +++++++++
include/linux/pci.h | 2 ++
2 files changed, 11 insertions(+)
diff --git a/drivers/pci/probe.c b/drivers/pci/probe.c
index b494066..9cb3eb3 100644
--- a/drivers/pci/probe.c
+++ b/drivers/pci/probe.c
@@ -105,6 +105,15 @@ static int __init pcibus_class_init(void)
}
postcore_initcall(pcibus_class_init);
+struct resource *pci_dev_resource_n(struct pci_dev *dev, int n)
+{
+ if (n >= 0 && n < PCI_NUM_RESOURCES)
+ return &dev->resource[n];
+
+ return NULL;
+}
+EXPORT_SYMBOL(pci_dev_resource_n);
+
static u64 pci_size(u64 base, u64 maxbase, u64 mask)
{
u64 size = mask & maxbase; /* Find the significant bits */
diff --git a/include/linux/pci.h b/include/linux/pci.h
index bcd9769..ffff013 100644
--- a/include/linux/pci.h
+++ b/include/linux/pci.h
@@ -353,6 +353,8 @@ struct pci_dev {
size_t romlen; /* Length of ROM if it's not from the BAR */
};
+struct resource *pci_dev_resource_n(struct pci_dev *dev, int n);
+
static inline struct pci_dev *pci_physfn(struct pci_dev *dev)
{
#ifdef CONFIG_PCI_IOV
--
1.8.1.4
next prev parent reply other threads:[~2013-04-12 22:46 UTC|newest]
Thread overview: 35+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-04-12 22:44 [PATCH v4 00/29] PCI: Add for_each_pci_resource and addon_res support Yinghai Lu
2013-04-12 22:44 ` [PATCH v4 01/29] PCI: Clean up quirk_io_region Yinghai Lu
2013-04-15 18:23 ` Bjorn Helgaas
2013-04-12 22:44 ` Yinghai Lu [this message]
2013-04-12 22:44 ` [PATCH v4 03/29] PCI: Update pci_resource_start etc to use pci_dev_resource_n() Yinghai Lu
2013-04-12 22:44 ` [PATCH v4 04/29] PCI: Add pci_dev_resource_idx() helper Yinghai Lu
2013-04-12 22:44 ` [PATCH v4 05/29] PCI: Add is_pci_*_resource_idx() helpers Yinghai Lu
2013-04-12 22:44 ` [PATCH v4 06/29] PCI: pci resource iterator Yinghai Lu
2013-04-12 22:44 ` [PATCH v4 07/29] PCI, x86: Use for_each_pci_resource() with pci_allocate_bridge_resources Yinghai Lu
2013-04-12 22:44 ` [PATCH v4 08/29] PCI, x86: Use for_each_pci_resource() with pci_allocate_dev_resources Yinghai Lu
2013-04-12 22:44 ` [PATCH v4 09/29] PCI: Use for_each_pci_resource() with IOV releated functions Yinghai Lu
2013-04-12 22:44 ` [PATCH v4 10/29] PCI, acpiphp: Use for_each_pci_resource() helper Yinghai Lu
2013-04-12 22:44 ` [PATCH v4 11/29] PCI, pciehp: " Yinghai Lu
2013-04-12 22:44 ` [PATCH v4 12/29] PCI: Use for_each_pci_resource() in pci_enable_dev Yinghai Lu
2013-04-12 22:44 ` [PATCH v4 13/29] PCI: Use for_each_pci_resource() in pci_reassigndev Yinghai Lu
2013-04-12 22:44 ` [PATCH v4 14/29] PCI: Use for_each_pci_resource() with pci bar reassign funcs Yinghai Lu
2013-04-12 22:44 ` [PATCH v4 15/29] PCI: Use for_each_pci_resource() in pci_assign_resource Yinghai Lu
2013-04-12 22:44 ` [PATCH v4 16/29] PCI, x86: Use for_each_pci_resource() with noassign_bars Yinghai Lu
2013-04-12 22:44 ` [PATCH v4 17/29] PCI: Use for_each_pci_resource() in pci_dev_driver() Yinghai Lu
2013-04-12 22:44 ` [PATCH v4 18/29] PCI: Use for_each_pci_resource() in pci resource release Yinghai Lu
2013-04-12 22:44 ` [PATCH v4 19/29] PCI: Use for_each_pci_resource() in pci bases reading Yinghai Lu
2013-04-12 22:44 ` [PATCH v4 20/29] PCI, x86: Use for_each_pci_resource() with mrst Yinghai Lu
2013-04-12 22:44 ` [PATCH v4 21/29] PCI, xen: Use for_each_pci_resource() with xen pci Yinghai Lu
2013-04-12 22:44 ` [PATCH v4 22/29] PCI: Add addon_resource support for pci devices Yinghai Lu
2013-04-12 22:44 ` [PATCH v4 23/29] PCI: Treat addon res as std resources Yinghai Lu
2013-04-12 22:44 ` [PATCH v4 24/29] PCI: Add helpers to add addon_resource Yinghai Lu
2013-04-12 22:44 ` [PATCH v4 25/29] PCI: Update pci_resource_bar() to support addon_resource Yinghai Lu
2013-04-12 22:44 ` [PATCH v4 26/29] PCI: Assign/update resource to addon_res Yinghai Lu
2013-04-12 22:44 ` [PATCH v4 27/29] PCI: Make piix4 quirk to use addon_res Yinghai Lu
2013-04-25 20:39 ` Bjorn Helgaas
2013-04-26 15:22 ` Bjorn Helgaas
2013-04-26 20:29 ` Rafael J. Wysocki
2013-04-12 22:44 ` [PATCH v4 28/29] PCI: Make quirk_io_region " Yinghai Lu
2013-04-12 22:44 ` [PATCH v4 29/29] PCI: Use addon_fixed_resource with ati fixed resource Yinghai Lu
2013-04-25 19:53 ` [PATCH v4 00/29] PCI: Add for_each_pci_resource and addon_res support Bjorn Helgaas
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1365806683-26717-3-git-send-email-yinghai@kernel.org \
--to=yinghai@kernel.org \
--cc=bhelgaas@google.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=linuxram@us.ibm.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome