From: "Paul E. McKenney" <paulmck@linux.vnet.ibm.com>
To: linux-kernel@vger.kernel.org
Cc: mingo@elte.hu, laijs@cn.fujitsu.com, dipankar@in.ibm.com,
akpm@linux-foundation.org, mathieu.desnoyers@polymtl.ca,
josh@joshtriplett.org, niv@us.ibm.com, tglx@linutronix.de,
peterz@infradead.org, rostedt@goodmis.org,
Valdis.Kletnieks@vt.edu, dhowells@redhat.com,
edumazet@google.com, darren@dvhart.com, fweisbec@gmail.com,
sbw@mit.edu, "Paul E. McKenney" <paulmck@linux.vnet.ibm.com>
Subject: [PATCH tip/core/rcu 7/8] rcu: Inline trivial wrapper function rcu_start_gp_per_cpu()
Date: Fri, 12 Apr 2013 16:32:36 -0700 [thread overview]
Message-ID: <1365809557-22575-7-git-send-email-paulmck@linux.vnet.ibm.com> (raw)
In-Reply-To: <1365809557-22575-1-git-send-email-paulmck@linux.vnet.ibm.com>
From: "Paul E. McKenney" <paulmck@linux.vnet.ibm.com>
Given the changes that introduce note_gp_change(), rcu_start_gp_per_cpu()
is now a trivial wrapper function with only one caller. This commit
therefore inlines it into its sole call site.
Signed-off-by: Paul E. McKenney <paulmck@linux.vnet.ibm.com>
---
kernel/rcutree.c | 14 +-------------
1 file changed, 1 insertion(+), 13 deletions(-)
diff --git a/kernel/rcutree.c b/kernel/rcutree.c
index f6cf5e1..0848341 100644
--- a/kernel/rcutree.c
+++ b/kernel/rcutree.c
@@ -1298,18 +1298,6 @@ static void note_gp_changes(struct rcu_state *rsp, struct rcu_data *rdp)
}
/*
- * Do per-CPU grace-period initialization for running CPU. The caller
- * must hold the lock of the leaf rcu_node structure corresponding to
- * this CPU.
- */
-static void
-rcu_start_gp_per_cpu(struct rcu_state *rsp, struct rcu_node *rnp, struct rcu_data *rdp)
-{
- /* Set state so that this CPU will detect the next quiescent state. */
- __note_gp_changes(rsp, rnp, rdp);
-}
-
-/*
* Initialize a new grace period.
*/
static int rcu_gp_init(struct rcu_state *rsp)
@@ -1357,7 +1345,7 @@ static int rcu_gp_init(struct rcu_state *rsp)
WARN_ON_ONCE(rnp->completed != rsp->completed);
ACCESS_ONCE(rnp->completed) = rsp->completed;
if (rnp == rdp->mynode)
- rcu_start_gp_per_cpu(rsp, rnp, rdp);
+ __note_gp_changes(rsp, rnp, rdp);
rcu_preempt_boost_start_gp(rnp);
trace_rcu_grace_period_init(rsp->name, rnp->gpnum,
rnp->level, rnp->grplo,
--
1.8.1.5
next prev parent reply other threads:[~2013-04-12 23:33 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-04-12 23:32 [PATCH tip/core/rcu 0/8] RCU callback-numbering simplifications for 3.11 Paul E. McKenney
2013-04-12 23:32 ` [PATCH tip/core/rcu 1/8] rcu: Move code to apply callback-numbering simplifications Paul E. McKenney
2013-04-12 23:32 ` [PATCH tip/core/rcu 2/8] rcu: Make __note_new_gpnum() check for ends of prior grace periods Paul E. McKenney
2013-04-12 23:32 ` [PATCH tip/core/rcu 3/8] rcu: Rename note_new_gpnum() to note_gp_changes() Paul E. McKenney
2013-04-12 23:32 ` [PATCH tip/core/rcu 4/8] rcu: Switch callers from rcu_process_gp_end() " Paul E. McKenney
2013-04-12 23:32 ` [PATCH tip/core/rcu 5/8] rcu: Merge __rcu_process_gp_end() into __note_gp_changes() Paul E. McKenney
2013-04-12 23:32 ` [PATCH tip/core/rcu 6/8] rcu: Eliminate check_for_new_grace_period() wrapper function Paul E. McKenney
2013-04-12 23:32 ` Paul E. McKenney [this message]
2013-04-12 23:32 ` [PATCH tip/core/rcu 8/8] rcu: Move redundant call to note_gp_changes() into called function Paul E. McKenney
2013-04-13 18:37 ` [PATCH tip/core/rcu 0/8] RCU callback-numbering simplifications for 3.11 Josh Triplett
2013-05-20 14:37 [PATCH tip/core/rcu 0/8] v2 " Paul E. McKenney
2013-05-20 14:38 ` [PATCH tip/core/rcu 1/8] rcu: Move code to apply callback-numbering simplifications Paul E. McKenney
2013-05-20 14:38 ` [PATCH tip/core/rcu 7/8] rcu: Inline trivial wrapper function rcu_start_gp_per_cpu() Paul E. McKenney
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1365809557-22575-7-git-send-email-paulmck@linux.vnet.ibm.com \
--to=paulmck@linux.vnet.ibm.com \
--cc=Valdis.Kletnieks@vt.edu \
--cc=akpm@linux-foundation.org \
--cc=darren@dvhart.com \
--cc=dhowells@redhat.com \
--cc=dipankar@in.ibm.com \
--cc=edumazet@google.com \
--cc=fweisbec@gmail.com \
--cc=josh@joshtriplett.org \
--cc=laijs@cn.fujitsu.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mathieu.desnoyers@polymtl.ca \
--cc=mingo@elte.hu \
--cc=niv@us.ibm.com \
--cc=peterz@infradead.org \
--cc=rostedt@goodmis.org \
--cc=sbw@mit.edu \
--cc=tglx@linutronix.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome