mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Joonsoo Kim <iamjoonsoo.kim@lge.com>
To: Ingo Molnar <mingo@redhat.com>, Peter Zijlstra <peterz@infradead.org>
Cc: linux-kernel@vger.kernel.org,
	Srivatsa Vaddagiri <vatsa@linux.vnet.ibm.com>,
	Davidlohr Bueso <davidlohr.bueso@hp.com>,
	Jason Low <jason.low2@hp.com>,
	Joonsoo Kim <iamjoonsoo.kim@lge.com>
Subject: [PATCH v3 5/6] sched: rename load_balance_tmpmask to load_balance_mask
Date: Tue, 23 Apr 2013 17:27:41 +0900	[thread overview]
Message-ID: <1366705662-3587-6-git-send-email-iamjoonsoo.kim@lge.com> (raw)
In-Reply-To: <1366705662-3587-1-git-send-email-iamjoonsoo.kim@lge.com>

This name doesn't represent specific meaning.
So rename it to imply it's purpose.

Acked-by: Peter Zijlstra <a.p.zijlstra@chello.nl>
Tested-by: Jason Low <jason.low2@hp.com>
Signed-off-by: Joonsoo Kim <iamjoonsoo.kim@lge.com>

diff --git a/kernel/sched/core.c b/kernel/sched/core.c
index ee8c1bd..cb49b2a 100644
--- a/kernel/sched/core.c
+++ b/kernel/sched/core.c
@@ -6873,7 +6873,7 @@ struct task_group root_task_group;
 LIST_HEAD(task_groups);
 #endif
 
-DECLARE_PER_CPU(cpumask_var_t, load_balance_tmpmask);
+DECLARE_PER_CPU(cpumask_var_t, load_balance_mask);
 
 void __init sched_init(void)
 {
@@ -6910,7 +6910,7 @@ void __init sched_init(void)
 #endif /* CONFIG_RT_GROUP_SCHED */
 #ifdef CONFIG_CPUMASK_OFFSTACK
 		for_each_possible_cpu(i) {
-			per_cpu(load_balance_tmpmask, i) = (void *)ptr;
+			per_cpu(load_balance_mask, i) = (void *)ptr;
 			ptr += cpumask_size();
 		}
 #endif /* CONFIG_CPUMASK_OFFSTACK */
diff --git a/kernel/sched/fair.c b/kernel/sched/fair.c
index b8ef321..5b1e966 100644
--- a/kernel/sched/fair.c
+++ b/kernel/sched/fair.c
@@ -4977,7 +4977,7 @@ static struct rq *find_busiest_queue(struct lb_env *env,
 #define MAX_PINNED_INTERVAL	512
 
 /* Working cpumask for load_balance and load_balance_newidle. */
-DEFINE_PER_CPU(cpumask_var_t, load_balance_tmpmask);
+DEFINE_PER_CPU(cpumask_var_t, load_balance_mask);
 
 static int need_active_balance(struct lb_env *env)
 {
@@ -5012,7 +5012,7 @@ static int load_balance(int this_cpu, struct rq *this_rq,
 	struct sched_group *group;
 	struct rq *busiest;
 	unsigned long flags;
-	struct cpumask *cpus = __get_cpu_var(load_balance_tmpmask);
+	struct cpumask *cpus = __get_cpu_var(load_balance_mask);
 
 	struct lb_env env = {
 		.sd		= sd,
-- 
1.7.9.5


  parent reply	other threads:[~2013-04-23  8:28 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-04-23  8:27 [PATCH v3 0/6] correct load_balance() Joonsoo Kim
2013-04-23  8:27 ` [PATCH v3 1/6] sched: change position of resched_cpu() in load_balance() Joonsoo Kim
2013-04-24  9:32   ` [tip:sched/core] sched: Change " tip-bot for Joonsoo Kim
2013-04-23  8:27 ` [PATCH v3 2/6] sched: explicitly cpu_idle_type checking in rebalance_domains() Joonsoo Kim
2013-04-24  9:33   ` [tip:sched/core] sched: Explicitly " tip-bot for Joonsoo Kim
2013-04-23  8:27 ` [PATCH v3 3/6] sched: don't consider other cpus in our group in case of NEWLY_IDLE Joonsoo Kim
2013-04-24  9:35   ` [tip:sched/core] sched: Don' t " tip-bot for Joonsoo Kim
2013-04-23  8:27 ` [PATCH v3 4/6] sched: move up affinity check to mitigate useless redoing overhead Joonsoo Kim
2013-04-24  9:36   ` [tip:sched/core] sched: Move " tip-bot for Joonsoo Kim
2013-04-23  8:27 ` Joonsoo Kim [this message]
2013-04-24  9:37   ` [tip:sched/core] sched: Rename load_balance_tmpmask to load_balance_mask tip-bot for Joonsoo Kim
2013-04-23  8:27 ` [PATCH v3 6/6] sched: prevent to re-select dst-cpu in load_balance() Joonsoo Kim
2013-04-24  9:38   ` [tip:sched/core] sched: Prevent " tip-bot for Joonsoo Kim

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1366705662-3587-6-git-send-email-iamjoonsoo.kim@lge.com \
    --to=iamjoonsoo.kim@lge.com \
    --cc=davidlohr.bueso@hp.com \
    --cc=jason.low2@hp.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=peterz@infradead.org \
    --cc=vatsa@linux.vnet.ibm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®