From: Betty Dall <betty.dall@hp.com>
To: Bjorn Helgaas <bhelgaas@google.com>
Cc: lenb@kernel.org, rjw@rjwysocki.net, linux-acpi@vger.kernel.org,
linux-kernel@vger.kernel.org, linux-pci@vger.kernel.org
Subject: Re: [PATCH] PCI AER: Handle non-AER HEST error sources in aer_hest_parse()
Date: Fri, 13 Dec 2013 15:47:33 -0700 [thread overview]
Message-ID: <1386974853.10497.64.camel@ejdallLaptop> (raw)
In-Reply-To: <20131213221616.GC6746@google.com>
On Fri, 2013-12-13 at 15:16 -0700, Bjorn Helgaas wrote:
> On Fri, Dec 13, 2013 at 08:23:16AM -0700, Betty Dall wrote:
> > aer_hest_parse() could pass a non-AER HEST error source to the function
> > hest_match_pci(). hest_match_pci() assumes that the HEST error source is
> > type ACPI_HEST_TYPE_AER_ROOT_PORT, ACPI_HEST_TYPE_AER_ENDPOINT, or
> > ACPI_HEST_TYPE_AER_BRIDGE. I have a platform that has some
> > ACPI_HEST_TYPE_GENERIC error sources where hest_match_pci() was trying to
> > access the structure as if it had the acpi_hest_aer_common fields.
> >
> > aer_hest_parse() is only ever interested in the AER type HEST error
> > sources. Add a check on the type of the error souce at the beginning of
> > aer_hest_parse().
> >
> > Signed-off-by: Betty Dall <betty.dall@hp.com>
> > ---
> >
> > drivers/pci/pcie/aer/aerdrv_acpi.c | 4 ++++
> > 1 files changed, 4 insertions(+), 0 deletions(-)
> >
> >
> > diff --git a/drivers/pci/pcie/aer/aerdrv_acpi.c b/drivers/pci/pcie/aer/aerdrv_acpi.c
> > index cf611ab..39186e3 100644
> > --- a/drivers/pci/pcie/aer/aerdrv_acpi.c
> > +++ b/drivers/pci/pcie/aer/aerdrv_acpi.c
> > @@ -56,6 +56,10 @@ static int aer_hest_parse(struct acpi_hest_header *hest_hdr, void *data)
> > struct acpi_hest_aer_common *p;
> > int ff;
> >
> > + if (hest_hdr->type != ACPI_HEST_TYPE_AER_ROOT_PORT &&
> > + hest_hdr->type != ACPI_HEST_TYPE_AER_ENDPOINT &&
> > + hest_hdr->type != ACPI_HEST_TYPE_AER_BRIDGE)
> > + return 0;
> > p = (struct acpi_hest_aer_common *)(hest_hdr + 1);
> > ff = !!(p->flags & ACPI_HEST_FIRMWARE_FIRST);
> > if (p->flags & ACPI_HEST_GLOBAL) {
>
> Hi Betty,
>
> I propose the following tweaked version. Will this work for you?
>
>
> PCI/AER: Ingore non-PCIe AER error sources in aer_hest_parse()
>
> From: Betty Dall <betty.dall@hp.com>
>
> aer_set_firmware_first() searches the HEST for an error source descriptor
> matching the specified PCI device. It uses the apei_hest_parse() iterator
> to call aer_hest_parse() for every descriptor in the HEST.
>
> Previously, aer_hest_parse() incorrectly assumed every descriptor was for a
> PCIe error source. This patch adds a check to avoid that error.
>
> [bhelgaas: factor check into helper function, changelog]
> Signed-off-by: Betty Dall <betty.dall@hp.com>
> Signed-off-by: Bjorn Helgaas <bhelgaas@google.com>
> ---
> drivers/pci/pcie/aer/aerdrv_acpi.c | 12 ++++++++++++
> 1 file changed, 12 insertions(+)
>
> diff --git a/drivers/pci/pcie/aer/aerdrv_acpi.c b/drivers/pci/pcie/aer/aerdrv_acpi.c
> index cf611ab2193a..f670313479ee 100644
> --- a/drivers/pci/pcie/aer/aerdrv_acpi.c
> +++ b/drivers/pci/pcie/aer/aerdrv_acpi.c
> @@ -50,12 +50,24 @@ struct aer_hest_parse_info {
> int firmware_first;
> };
>
> +static int hest_source_is_pcie_aer(struct acpi_hest_header *hest_hdr)
> +{
> + if (hest_hdr->type == ACPI_HEST_TYPE_AER_ROOT_PORT ||
> + hest_hdr->type == ACPI_HEST_TYPE_AER_ENDPOINT ||
> + hest_hdr->type == ACPI_HEST_TYPE_AER_BRIDGE)
> + return 1;
> + return 0;
> +}
> +
> static int aer_hest_parse(struct acpi_hest_header *hest_hdr, void *data)
> {
> struct aer_hest_parse_info *info = data;
> struct acpi_hest_aer_common *p;
> int ff;
>
> + if (!hest_source_is_pcie_aer(hest_hdr))
> + return 0;
> +
> p = (struct acpi_hest_aer_common *)(hest_hdr + 1);
> ff = !!(p->flags & ACPI_HEST_FIRMWARE_FIRST);
> if (p->flags & ACPI_HEST_GLOBAL) {
Hi Bjorn,
Yes, that is more readable code. Thanks for revising it. I tested it on
my system that has non-AER error sources and it works fine. One nit is
that "Ignore" is misspelled in the subject line.
-Betty
next prev parent reply other threads:[~2013-12-13 22:47 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-12-13 15:23 Betty Dall
2013-12-13 22:16 ` Bjorn Helgaas
2013-12-13 22:47 ` Betty Dall [this message]
2013-12-13 23:06 ` Bjorn Helgaas
2013-12-16 15:15 ` Betty Dall
2013-12-16 19:12 ` Bjorn Helgaas
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1386974853.10497.64.camel@ejdallLaptop \
--to=betty.dall@hp.com \
--cc=bhelgaas@google.com \
--cc=lenb@kernel.org \
--cc=linux-acpi@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=rjw@rjwysocki.net \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome