mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: James Bottomley <jbottomley@parallels.com>
To: "arnd@arndb.de" <arnd@arndb.de>
Cc: "linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"rdunlap@infradead.org" <rdunlap@infradead.org>,
	"Liviu.Dudau@arm.com" <Liviu.Dudau@arm.com>,
	"joro@8bytes.org" <joro@8bytes.org>,
	"gregkh@linuxfoundation.org" <gregkh@linuxfoundation.org>,
	"dwmw2@infradead.org" <dwmw2@infradead.org>,
	"linux-pci@vger.kernel.org" <linux-pci@vger.kernel.org>,
	"bhelgaas@google.com" <bhelgaas@google.com>,
	"linux-doc@vger.kernel.org" <linux-doc@vger.kernel.org>
Subject: Re: [PATCH v3 1/4] DMA-API: Clarify physical/bus address distinction
Date: Fri, 9 May 2014 14:09:31 +0000	[thread overview]
Message-ID: <1399644571.2166.1.camel@dabdike.int.hansenpartnership.com> (raw)
In-Reply-To: <119388463.n2RtThRsle@wuerfel>

On Fri, 2014-05-09 at 08:12 +0200, Arnd Bergmann wrote:
> On Thursday 08 May 2014 14:48:54 Bjorn Helgaas wrote:
> > The DMA-API documentation sometimes refers to "physical addresses" when it
> > really means "bus addresses."  Sometimes these are identical, but they may
> > be different if the bridge leading to the bus performs address translation.
> > Update the documentation to use "bus address" when appropriate.
> > 
> > Also, consistently capitalize "DMA", use parens with function names, use
> > dev_printk() in examples, and reword a few sections for clarity.
> > 
> > No functional change; documentation changes only.
> > 
> > Signed-off-by: Bjorn Helgaas <bhelgaas@google.com>
> 
> Looks great!
> 
> Acked-by: Arnd Bergmann <arnd@arndb.de>

Yes, from me too (probably only patches 1-2, since that's only what I
directly wrote originally); thanks for listening to the arguments and
persevering.

Acked-by: James Bottomley <jbottomley@Parallels.com>

James


  reply	other threads:[~2014-05-09 14:09 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-05-08 20:48 [PATCH v3 0/4] Clean up DMA API docs and dma_addr_t usage Bjorn Helgaas
2014-05-08 20:48 ` [PATCH v3 1/4] DMA-API: Clarify physical/bus address distinction Bjorn Helgaas
2014-05-09  2:49   ` Greg Kroah-Hartman
2014-05-09  6:12   ` Arnd Bergmann
2014-05-09 14:09     ` James Bottomley [this message]
2014-05-08 20:49 ` [PATCH v3 2/4] DMA-API: Change dma_declare_coherent_memory() CPU address to phys_addr_t Bjorn Helgaas
2014-05-09  2:50   ` Greg Kroah-Hartman
2014-05-08 20:49 ` [PATCH v3 3/4] sh/PCI: Pass GAPSPCI_DMA_BASE CPU & bus address to dma_declare_coherent_memory() Bjorn Helgaas
2014-05-26 14:46   ` Geert Uytterhoeven
2014-05-26 23:33     ` Bjorn Helgaas
2014-05-08 20:49 ` [PATCH v3 4/4] iommu/exynos: Remove unnecessary "&" from function pointers Bjorn Helgaas
2014-05-14 10:23 ` [PATCH v3 0/4] Clean up DMA API docs and dma_addr_t usage Joerg Roedel
2014-05-14 15:50   ` Randy Dunlap
2014-05-14 15:56     ` Joerg Roedel

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1399644571.2166.1.camel@dabdike.int.hansenpartnership.com \
    --to=jbottomley@parallels.com \
    --cc=Liviu.Dudau@arm.com \
    --cc=arnd@arndb.de \
    --cc=bhelgaas@google.com \
    --cc=dwmw2@infradead.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=joro@8bytes.org \
    --cc=linux-doc@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pci@vger.kernel.org \
    --cc=rdunlap@infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®