From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753019AbaEUSuE (ORCPT ); Wed, 21 May 2014 14:50:04 -0400 Received: from mga09.intel.com ([134.134.136.24]:2334 "EHLO mga09.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752939AbaEUSuC (ORCPT ); Wed, 21 May 2014 14:50:02 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="4.98,881,1392192000"; d="scan'208";a="515600127" Subject: Re: [PATCH] sched: Reduce the rate of needless idle load balancing From: Tim Chen To: Davidlohr Bueso Cc: Joe Perches , Jason Low , Ingo Molnar , Peter Zijlstra , Andrew Morton , Len Brown , Russ Anderson , Dimitri Sivanich , Hedi Berriche , Andi Kleen , Michel Lespinasse , Rik van Riel , Peter Hurley , Linux Kernel Mailing List In-Reply-To: <1400696776.2646.6.camel@buesod1.americas.hpqcorp.net> References: <1400617046.2970.270.camel@schen9-DESK> <1400619550.2970.274.camel@schen9-DESK> <1400619878.2970.276.camel@schen9-DESK> <1400634953.26709.42.camel@joe-AO725> <1400690267.2970.287.camel@schen9-DESK> <1400696776.2646.6.camel@buesod1.americas.hpqcorp.net> Content-Type: text/plain; charset="UTF-8" Date: Wed, 21 May 2014 11:49:59 -0700 Message-ID: <1400698199.2970.303.camel@schen9-DESK> Mime-Version: 1.0 X-Mailer: Evolution 2.32.3 (2.32.3-1.fc14) Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed, 2014-05-21 at 11:26 -0700, Davidlohr Bueso wrote: > On Wed, 2014-05-21 at 09:37 -0700, Tim Chen wrote: > > On Tue, 2014-05-20 at 18:15 -0700, Joe Perches wrote: > > > On Tue, 2014-05-20 at 14:04 -0700, Tim Chen wrote: > > > > On Tue, 2014-05-20 at 13:59 -0700, Tim Chen wrote: > > > > > On Tue, 2014-05-20 at 13:51 -0700, Jason Low wrote: > > > > > > On Tue, May 20, 2014 at 1:17 PM, Tim Chen wrote: > > > > > > > diff --git a/kernel/sched/fair.c b/kernel/sched/fair.c > > > [] > > > > > > If we want to do idle load balancing only when it is due for a > > > > > > balance, shouldn't the above just be "if (time_after(jiffies, > > > > > > rq->next_balance))"? > > > > > > > > > > If rq->next_balance and jiffies are equal, then > > > > > time_after(jiffies, rq->next_balance) check will be false and > > > > > you will not do balance. But actually you want to balance > > > > > for this case so the jiffies+1 was used. > > > > > > > > So maybe I should switch the check to > > > > if (time_before(rq->next_balance, jiffies)) > > > > > > time_after_eq() or time_is_after_eq_jiffies() > > > > > > > > > > I prefer time_after_eq to keep the code style consistent with the > > rest of the code in fair.c. > > Should all the code be updated then? We should use the existing > interfaces if available. > BTW, if this code was to be updated, time_is_before_eq_jiffies(rq->next_balance) check will be the correct thing to do for the patch. This expands to time_after_eq(jiffies, rq->next_balance), which is what we want. So something like: if (time_is_before_eq_jiffies(rq->next_balance)) { raw_spin_lock_irq(&rq->lock); update_rq_clock(rq); update_idle_cpu_load(rq); raw_spin_unlock_irq(&rq->lock); rebalance_domains(rq, CPU_IDLE); } But I don't think this change is making the code logic any clearer. I prefer time_after_eq(jiffies, rq->next_balance), which is more readable. Tim