mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Andrew Pinski <apinski@cavium.com>
To: linux-arm-kernel@lists.infradead.org, linux-kernel@vger.kernel.org
To: linux-arm-kernel@lists.infradead.org
To: linux-kernel@vger.kernel.org
To: Roland McGrath <roland@redhat.com>
To: Oleg Nesterov <oleg@redhat.com>
Cc: Andrew Pinski <apinski@cavium.com>
Subject: [PATCH 20/24] ptrace: Allow compat to use the native siginfo.
Date: Sat, 24 May 2014 00:02:15 -0700	[thread overview]
Message-ID: <1400914939-9708-21-git-send-email-apinski@cavium.com> (raw)
In-Reply-To: <1400914939-9708-1-git-send-email-apinski@cavium.com>

With ARM64 ILP32 ABI, we want to use the non-compat siginfo as we want to simplify signal handling for this new ABI.  This patch just adds a new define COMPAT_USE_NATIVE_SIGINFO and if it is true then read/write in the compat case as it was the non-compat case.

Thanks,
Andrew Pinski

Signed-off-by: Andrew Pinski <apinski@cavium.com>
---
 include/linux/compat.h |    4 ++++
 kernel/ptrace.c        |   24 +++++++++++++++++-------
 2 files changed, 21 insertions(+), 7 deletions(-)

diff --git a/include/linux/compat.h b/include/linux/compat.h
index e649426..2d8c535 100644
--- a/include/linux/compat.h
+++ b/include/linux/compat.h
@@ -24,6 +24,10 @@
 #define COMPAT_USE_64BIT_TIME 0
 #endif
 
+#ifndef COMPAT_USE_NATIVE_SIGINFO
+#define COMPAT_USE_NATIVE_SIGINFO 0
+#endif
+
 #ifndef __SC_DELOUSE
 #define __SC_DELOUSE(t,v) ((t)(unsigned long)(v))
 #endif
diff --git a/kernel/ptrace.c b/kernel/ptrace.c
index adf9862..5f8bb5c 100644
--- a/kernel/ptrace.c
+++ b/kernel/ptrace.c
@@ -663,7 +663,7 @@ static int ptrace_peek_siginfo(struct task_struct *child,
 			break;
 
 #ifdef CONFIG_COMPAT
-		if (unlikely(is_compat_task())) {
+		if (unlikely(is_compat_task() && !COMPAT_USE_NATIVE_SIGINFO)) {
 			compat_siginfo_t __user *uinfo = compat_ptr(data);
 
 			if (copy_siginfo_to_user32(uinfo, &info) ||
@@ -1132,16 +1132,26 @@ int compat_ptrace_request(struct task_struct *child, compat_long_t request,
 
 	case PTRACE_GETSIGINFO:
 		ret = ptrace_getsiginfo(child, &siginfo);
-		if (!ret)
-			ret = copy_siginfo_to_user32(
-				(struct compat_siginfo __user *) datap,
-				&siginfo);
+		if (!ret) {
+			if (COMPAT_USE_NATIVE_SIGINFO)
+				ret = copy_siginfo_to_user(
+					(struct siginfo __user *) datap,
+					&siginfo);
+			else
+				ret = copy_siginfo_to_user32(
+					(struct compat_siginfo __user *) datap,
+					&siginfo);
+		}
 		break;
 
 	case PTRACE_SETSIGINFO:
 		memset(&siginfo, 0, sizeof siginfo);
-		if (copy_siginfo_from_user32(
-			    &siginfo, (struct compat_siginfo __user *) datap))
+		if (COMPAT_USE_NATIVE_SIGINFO)
+			ret = copy_from_user(&siginfo, datap, sizeof(siginfo));
+		else
+			ret = copy_siginfo_from_user32(
+				 &siginfo, (struct compat_siginfo __user *) datap);
+		if (ret)
 			ret = -EFAULT;
 		else
 			ret = ptrace_setsiginfo(child, &siginfo);
-- 
1.7.2.5


  parent reply	other threads:[~2014-05-24  7:03 UTC|newest]

Thread overview: 49+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-05-24  7:01 [PATCHv2 00/24] ILP32 Support in ARM64 Andrew Pinski
2014-05-24  7:01 ` [PATCH 01/24] ARM64: Force LP64 to compile the kernel Andrew Pinski
2014-05-24  7:01 ` [PATCH 02/24] ARM64: Rename COMPAT to AARCH32_EL0 in Kconfig Andrew Pinski
2014-05-24  7:01 ` [PATCH 03/24] ARM64: Change some CONFIG_COMPAT over to use CONFIG_AARCH32_EL0 instead Andrew Pinski
2014-06-17 15:15   ` Catalin Marinas
2014-05-24  7:01 ` [PATCH 04/24] ARM64:ILP32: Set kernel_long to long long so we can reuse most of the same syscalls as LP64 Andrew Pinski
2014-05-24  7:02 ` [PATCH 05/24] ARM64:UAPI: Set the correct __BITS_PER_LONG for ILP32 Andrew Pinski
2014-06-17 15:22   ` Catalin Marinas
2014-06-17 15:29     ` Arnd Bergmann
2014-05-24  7:02 ` [PATCH 06/24] Allow for some signal structures to be the same between a 32bit ABI and the 64bit ABI Andrew Pinski
2014-06-17 15:43   ` Catalin Marinas
2014-05-24  7:02 ` [PATCH 07/24] ARM64:ILP32: Use the same size and layout of the signal structures for ILP32 as for LP64 Andrew Pinski
2014-06-17 15:58   ` Catalin Marinas
2014-05-24  7:02 ` [PATCH 08/24] Allow a 32bit ABI to use the naming of the 64bit ABI syscalls to avoid confusion of not splitting the registers Andrew Pinski
2014-06-17 16:22   ` Catalin Marinas
2014-05-24  7:02 ` [PATCH 09/24] ARM64:ILP32: Use the same syscall names as LP64 Andrew Pinski
2014-06-18  8:51   ` Catalin Marinas
2014-05-24  7:02 ` [PATCH 10/24] ARM64: Introduce is_a32_task and is_a32_thread. Use them in the correct locations Andrew Pinski
2014-06-18 17:47   ` Catalin Marinas
2014-05-24  7:02 ` [PATCH 11/24] ARM64: Add ARM64_ILP32 to Kconfig Andrew Pinski
2014-05-24  7:02 ` [PATCH 12/24] ARM64: Add is_ilp32_compat_task and is_ilp32_compat_thread and TIF_32BIT_AARCH64 Andrew Pinski
2014-06-19 12:49   ` Catalin Marinas
2014-05-24  7:02 ` [PATCH 13/24] Drivers:input: Use is_compat_task for ARM64 also Andrew Pinski
2014-06-19 12:50   ` Catalin Marinas
2014-05-24  7:02 ` [PATCH 14/24] ARM64:ILP32: COMPAT_USE_64BIT_TIME is true for ILP32 tasks Andrew Pinski
2014-06-19 12:52   ` Catalin Marinas
2014-05-24  7:02 ` [PATCH 15/24] ARM64:ILP32: Use the non compat HWCAP for ILP32 Andrew Pinski
2014-06-19 12:54   ` Catalin Marinas
2014-07-01 13:01   ` Dr. Philipp Tomsich
2014-05-24  7:02 ` [PATCH 16/24] ARM64:ILP32 use the standard start_thread for ILP32 so the processor state is not AARCH32 Andrew Pinski
2014-05-24  7:02 ` [PATCH 17/24] ARM64:ILP32: Support core dump for ILP32 Andrew Pinski
2014-05-24  7:02 ` [PATCH 18/24] ARM64: Add loading of ILP32 binaries Andrew Pinski
2014-05-24  7:02 ` [PATCH 19/24] ARM64: Add vdso for ILP32 and use it for the signal return Andrew Pinski
2014-05-24  7:02 ` Andrew Pinski [this message]
2014-05-24  7:02 ` [PATCH 21/24] ARM64:ILP32: The native siginfo is used instead of the compat siginfo Andrew Pinski
2014-05-24 18:56   ` H. Peter Anvin
2014-05-24  7:02 ` [PATCH 22/24] ARM64:ILP32: Use a seperate syscall table as a few syscalls need to be using the compat syscalls Andrew Pinski
2014-07-01 15:05   ` Catalin Marinas
2014-07-01 15:30     ` Pinski, Andrew
2014-07-01 16:38       ` Arnd Bergmann
2014-07-01 16:50         ` Catalin Marinas
2014-07-01 17:04           ` Arnd Bergmann
2014-07-01 16:49       ` Catalin Marinas
2014-05-24  7:02 ` [PATCH 23/24] ARM64:ILP32: Fix signal return for ILP32 when the user modified the signal stack Andrew Pinski
2014-05-24  7:02 ` [PATCH 24/24] Add documentation about ARM64 ILP32 ABI Andrew Pinski
2014-06-16 17:08 ` [PATCHv2 00/24] ILP32 Support in ARM64 Catalin Marinas
2014-06-16 17:19   ` Pinski, Andrew
2014-06-17 10:43     ` Catalin Marinas
2014-06-17 11:30       ` Pinski, Andrew

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1400914939-9708-21-git-send-email-apinski@cavium.com \
    --to=apinski@cavium.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®