From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S932677AbaGET3r (ORCPT ); Sat, 5 Jul 2014 15:29:47 -0400 Received: from seketeli.net ([94.23.218.202]:48729 "EHLO ms.seketeli.fr" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1756060AbaGET3q (ORCPT ); Sat, 5 Jul 2014 15:29:46 -0400 From: Apelete Seketeli To: Ralf Baechle , Lars-Peter Clausen , John Crispin , Paul Gortmaker , Vinod Koul , linux-mips@linux-mips.org Cc: linux-kernel@vger.kernel.org Subject: [PATCH v2] mips: jz4740: rename usb_nop_xceiv to usb_phy_generic Date: Sat, 5 Jul 2014 21:30:15 +0200 Message-Id: <1404588615-14722-2-git-send-email-apelete@seketeli.net> X-Mailer: git-send-email 1.7.10.4 In-Reply-To: <1404588615-14722-1-git-send-email-apelete@seketeli.net> References: <1404588615-14722-1-git-send-email-apelete@seketeli.net> Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Rename usb_nop_xceiv to usb_phy_generic in platform data to match the name change of the nop transceiver driver in commit 4525bee (usb: phy: rename usb_nop_xceiv to usb_phy_generic). The name change induced a kernel panic due to an unhandled kernel unaligned access while trying to dereference musb->xceiv->io_ops in musb_init_controller(). Signed-off-by: Apelete Seketeli --- arch/mips/jz4740/platform.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/arch/mips/jz4740/platform.c b/arch/mips/jz4740/platform.c index a447101..0b12f27 100644 --- a/arch/mips/jz4740/platform.c +++ b/arch/mips/jz4740/platform.c @@ -59,7 +59,7 @@ struct platform_device jz4740_usb_ohci_device = { /* USB Device Controller */ struct platform_device jz4740_udc_xceiv_device = { - .name = "usb_phy_gen_xceiv", + .name = "usb_phy_generic", .id = 0, }; -- 1.7.10.4