mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Scott Wood <scottwood@freescale.com>
To: Jingchang Lu <jingchang.lu@freescale.com>
Cc: <mturquette@linaro.org>, <linuxppc-dev@lists.ozlabs.org>,
	<linux-kernel@vger.kernel.org>,
	<linux-arm-kernel@lists.infradead.org>
Subject: Re: [PATCHv2] clk: ppc-corenet: rename to ppc-qoriq and add CLK_OF_DECLARE support
Date: Fri, 29 Aug 2014 14:38:15 -0500	[thread overview]
Message-ID: <1409341095.24184.18.camel@snotra.buserror.net> (raw)
In-Reply-To: <1409301354-13699-1-git-send-email-jingchang.lu@freescale.com>

On Fri, 2014-08-29 at 16:35 +0800, Jingchang Lu wrote:
> The IP is shared on PPC and ARM, this rename it to qoriq for better
> represention, and this also add the CLK_OF_DECLARE support for being
> initialized by of_clk_init() on ARM.
> 
> Signed-off-by: Jingchang Lu <jingchang.lu@freescale.com>
> ---
> changes in v2:
>  rename the driver name to ppc-qoriq.c for shared on PPC and ARM.
> 
>  drivers/clk/Kconfig           |   9 +-
>  drivers/clk/Makefile          |   2 +-
>  drivers/clk/clk-ppc-corenet.c | 307 -----------------------------------------
>  drivers/clk/clk-qoriq.c       | 312 ++++++++++++++++++++++++++++++++++++++++++
>  4 files changed, 318 insertions(+), 312 deletions(-)
>  delete mode 100644 drivers/clk/clk-ppc-corenet.c
>  create mode 100644 drivers/clk/clk-qoriq.c

Please use -M -C with git format-patch to detect the rename, so we can
see what changed during the rename.

-Scott



      reply	other threads:[~2014-08-29 19:38 UTC|newest]

Thread overview: 2+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-08-29  8:35 Jingchang Lu
2014-08-29 19:38 ` Scott Wood [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1409341095.24184.18.camel@snotra.buserror.net \
    --to=scottwood@freescale.com \
    --cc=jingchang.lu@freescale.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=mturquette@linaro.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®