From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1754755AbaIVTxO (ORCPT ); Mon, 22 Sep 2014 15:53:14 -0400 Received: from mail-yk0-f177.google.com ([209.85.160.177]:56307 "EHLO mail-yk0-f177.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753057AbaIVTxM (ORCPT ); Mon, 22 Sep 2014 15:53:12 -0400 From: Pranith Kumar To: Thomas Gleixner , Ingo Molnar , "H. Peter Anvin" , x86@kernel.org (maintainer:X86 ARCHITECTURE...), Peter Zijlstra , "Paul E. McKenney" , linux-kernel@vger.kernel.org (open list:X86 ARCHITECTURE...) Subject: [RFC PATCH] x86: Use ACCESS_ONCE() for atomic_read() Date: Mon, 22 Sep 2014 15:53:09 -0400 Message-Id: <1411415590-12193-1-git-send-email-bobby.prani@gmail.com> X-Mailer: git-send-email 2.1.0 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Use the much easier to read ACCESS_ONCE() which is basically the same thing as the cast to volatile. Please note the change in volatile cast: ACCESS_ONCE(v)->counter to ACCESS_ONCE(v->counter). Signed-off-by: Pranith Kumar --- arch/x86/include/asm/atomic.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/arch/x86/include/asm/atomic.h b/arch/x86/include/asm/atomic.h index fa92e93..dea3434 100644 --- a/arch/x86/include/asm/atomic.h +++ b/arch/x86/include/asm/atomic.h @@ -24,7 +24,7 @@ */ static inline int atomic_read(const atomic_t *v) { - return (*(volatile int *)&(v)->counter); + return ACCESS_ONCE(v->counter); } /** -- 2.1.0